Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » problem opening Application.e4xmi in e4 windows 64bit
problem opening Application.e4xmi in e4 windows 64bit [message #571185] Fri, 19 March 2010 19:14 Go to next message
Todd Wilson is currently offline Todd WilsonFriend
Messages: 4
Registered: July 2009
Junior Member
I've installed 2 versions of e4 on my Vista 64 bit:
eclipse-e4-SDK-incubation-I20100318-2100-win32-x86_64
eclipse-e4-SDK-incubation-1.0M4-win32-x86_64

I've tried sample e4 projects and creating new e4 projects on both installations, but whenever I try to open the Application.e4xmi file using the e4 Workbench Designer it just opens with a blank white interface (doesn't look like the screenshots of other OSes with the gui layout stuff).

Is this a known issue or is there a newer plugin I need on 64 bit for it to behave like the screenshots from the mac and 32 bit versions I've seen?

Thanks,
Todd
Re: problem opening Application.e4xmi in e4 windows 64bit [message #571244 is a reply to message #571185] Sat, 20 March 2010 02:10 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Hi,

try the reflective EMF editor or a text editor, as described also here:
http://www.vogella.de/articles/EclipseE4/article.html


Best regards, Lars

On 19.03.2010 12:14, Todd Wilson wrote:
> I've installed 2 versions of e4 on my Vista 64 bit:
> eclipse-e4-SDK-incubation-I20100318-2100-win32-x86_64
> eclipse-e4-SDK-incubation-1.0M4-win32-x86_64
>
> I've tried sample e4 projects and creating new e4 projects on both
> installations, but whenever I try to open the Application.e4xmi file
> using the e4 Workbench Designer it just opens with a blank white
> interface (doesn't look like the screenshots of other OSes with the gui
> layout stuff).
> Is this a known issue or is there a newer plugin I need on 64 bit for it
> to behave like the screenshots from the mac and 32 bit versions I've seen?
>
> Thanks,
> Todd
Re: problem opening Application.e4xmi in e4 windows 64bit [message #571270 is a reply to message #571244] Sat, 20 March 2010 02:23 Go to previous messageGo to next message
Todd Wilson is currently offline Todd WilsonFriend
Messages: 4
Registered: July 2009
Junior Member
Hi Lars,

Thanks for the feedback. I've tried both the Sample Reflective Ecore Model Editor and a text editor with no troubles. It's only the e4 Workbench Designer that's not working. I couldn't find a bug report or find any posts from anyone else experiencing this issue on Windows 64 bit, so I was curious whether it was just me or if there are others that can't use the Workbench Designer then I would report a bug on Bugzilla.

Thanks,
Todd
Re: problem opening Application.e4xmi in e4 windows 64bit [message #720998 is a reply to message #571270] Wed, 31 August 2011 16:24 Go to previous messageGo to next message
Christian Hanster is currently offline Christian HansterFriend
Messages: 22
Registered: March 2011
Junior Member
Hey Todd,

I have the same issue with my eclipse now. How have you solved the problem??
It is a little bit crazy because at first it works and now there is a problem (see the screenshot). I haven't changed the code and now I don't know the problem.

Thanks
Christian
Re: problem opening Application.e4xmi in e4 windows 64bit [message #721000 is a reply to message #720998] Wed, 31 August 2011 16:27 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,

What is your version of the Eclipse 4.x and the tooling? There was a bug
in when elements got deleted they haven't been removed from the
references and so the model was invalid.

Can you send me your e4xmi-File so that I can take a look locally?

Tom

Am 31.08.11 18:24, schrieb christian-hanster:
> Hey Todd,
>
> I have the same issue with my eclipse now. How have you solved the problem??
> It is a little bit crazy because at first it works and now there is a problem (see the screenshot). I haven't changed the code and now I don't know the problem.
>
> Thanks
> Christian
Re: problem opening Application.e4xmi in e4 windows 64bit [message #721011 is a reply to message #721000] Wed, 31 August 2011 16:56 Go to previous messageGo to next message
Christian Hanster is currently offline Christian HansterFriend
Messages: 22
Registered: March 2011
Junior Member
Thank you for the very fast response. I use eclipse 4.1 with e4 0.11. I have added the .e4xmi in the attachements.
The full exception is:
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'org.eclipse.e4.ui.model.application.ui.basic.impl.PartSashContainerImpl@1ed5c93a (elementId: null, tags: null, contributorURI: null) (widget: null, renderer: null, toBeRendered: true, onTop: false, visible: true, containerData: null, accessibilityPhrase: null) (horizontal: true)' is not legal. (platform:/resource/de.kvg-gymnasium.mobi.manager/Application.e4xmi, -1, -1)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:315)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
	at org.eclipse.e4.tools.emf.ui.common.XMIModelResource.<init>(XMIModelResource.java:67)
	at org.eclipse.e4.tools.emf.editor3x.XMIResourceFunction.compute(XMIResourceFunction.java:21)
	at org.eclipse.e4.core.internal.contexts.ValueComputation.get(ValueComputation.java:122)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.internalGet(EclipseContext.java:247)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.internalGet(EclipseContext.java:255)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.internalGet(EclipseContext.java:255)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.internalGet(EclipseContext.java:255)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.internalGet(EclipseContext.java:255)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.internalGet(EclipseContext.java:255)
	at org.eclipse.e4.core.internal.contexts.EclipseContext.get(EclipseContext.java:208)
	at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier.fillArgs(ContextObjectSupplier.java:181)
	at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier.get(ContextObjectSupplier.java:165)
	at org.eclipse.e4.core.internal.di.InjectorImpl.resolveArgs(InjectorImpl.java:411)
	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:303)
	at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:237)
	at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:153)
	at org.eclipse.e4.tools.compat.internal.PartHelper.creatComponent(PartHelper.java:76)
	at org.eclipse.e4.tools.compat.parts.DIEditorPart.createPartControl(DIEditorPart.java:92)
	at org.eclipse.e4.tools.emf.editor3x.E4WorkbenchModelEditor.createPartControl(E4WorkbenchModelEditor.java:43)
	at org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.createPartControl(CompatibilityPart.java:122)
	at org.eclipse.ui.internal.e4.compatibility.CompatibilityEditor.createPartControl(CompatibilityEditor.java:45)
	at org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.create(CompatibilityPart.java:256)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:56)
	at org.eclipse.e4.core.internal.di.InjectorImpl.processAnnotated(InjectorImpl.java:828)
	at org.eclipse.e4.core.internal.di.InjectorImpl.processAnnotated(InjectorImpl.java:808)
	at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:108)
	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:310)
	at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:237)
	at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:153)
	at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.createFromBundle(ReflectionContributionFactory.java:90)
	at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.doCreate(ReflectionContributionFactory.java:64)
	at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.create(ReflectionContributionFactory.java:53)
	at org.eclipse.e4.ui.workbench.renderers.swt.ContributedPartRenderer.createWidget(ContributedPartRenderer.java:141)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createWidget(PartRenderingEngine.java:858)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:612)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:714)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.access$2(PartRenderingEngine.java:685)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$7.run(PartRenderingEngine.java:679)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createGui(PartRenderingEngine.java:664)
	at org.eclipse.e4.ui.workbench.renderers.swt.StackRenderer.showTab(StackRenderer.java:686)
	at org.eclipse.e4.ui.workbench.renderers.swt.LazyStackRenderer$1.handleEvent(LazyStackRenderer.java:66)
	at org.eclipse.e4.ui.services.internal.events.UIEventHandler$1.run(UIEventHandler.java:41)
	at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:180)
	at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:150)
	at org.eclipse.swt.widgets.Display.syncExec(Display.java:4610)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application$1.syncExec(E4Application.java:182)
	at org.eclipse.e4.ui.services.internal.events.UIEventHandler.handleEvent(UIEventHandler.java:38)
	at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:197)
	at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:197)
	at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
	at org.eclipse.equinox.internal.event.EventAdminImpl.dispatchEvent(EventAdminImpl.java:135)
	at org.eclipse.equinox.internal.event.EventAdminImpl.sendEvent(EventAdminImpl.java:78)
	at org.eclipse.equinox.internal.event.EventComponent.sendEvent(EventComponent.java:39)
	at org.eclipse.e4.ui.services.internal.events.EventBroker.send(EventBroker.java:81)
	at org.eclipse.e4.ui.internal.workbench.UIEventPublisher.notifyChanged(UIEventPublisher.java:58)
	at org.eclipse.emf.common.notify.impl.BasicNotifierImpl.eNotify(BasicNotifierImpl.java:380)
	at org.eclipse.e4.ui.model.application.ui.impl.ElementContainerImpl.setSelectedElement(ElementContainerImpl.java:171)
	at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.showElementInWindow(ModelServiceImpl.java:357)
	at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.bringToTop(ModelServiceImpl.java:311)
	at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.bringToTop(PartServiceImpl.java:273)
	at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.showPart(PartServiceImpl.java:912)
	at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2729)
	at org.eclipse.ui.internal.WorkbenchPage.access$19(WorkbenchPage.java:2654)
	at org.eclipse.ui.internal.WorkbenchPage$7.run(WorkbenchPage.java:2636)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
	at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2632)
	at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2612)
	at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2603)
	at org.eclipse.ui.ide.IDE.openEditor(IDE.java:651)
	at org.eclipse.ui.ide.IDE.openEditor(IDE.java:610)
	at org.eclipse.jdt.internal.ui.javaeditor.EditorUtility.openInEditor(EditorUtility.java:355)
	at org.eclipse.jdt.internal.ui.javaeditor.EditorUtility.openInEditor(EditorUtility.java:164)
	at org.eclipse.jdt.ui.actions.OpenAction.run(OpenAction.java:249)
	at org.eclipse.jdt.ui.actions.OpenAction.run(OpenAction.java:228)
	at org.eclipse.jdt.ui.actions.SelectionDispatchAction.dispatchRun(SelectionDispatchAction.java:275)
	at org.eclipse.jdt.ui.actions.SelectionDispatchAction.run(SelectionDispatchAction.java:251)
	at org.eclipse.jdt.internal.ui.packageview.PackageExplorerActionGroup.handleOpen(PackageExplorerActionGroup.java:376)
	at org.eclipse.jdt.internal.ui.packageview.PackageExplorerPart$4.open(PackageExplorerPart.java:538)
	at org.eclipse.ui.OpenAndLinkWithEditorHelper$InternalListener.open(OpenAndLinkWithEditorHelper.java:48)
	at org.eclipse.jface.viewers.StructuredViewer$2.run(StructuredViewer.java:866)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
	at org.eclipse.jface.viewers.StructuredViewer.fireOpen(StructuredViewer.java:864)
	at org.eclipse.jface.viewers.StructuredViewer.handleOpen(StructuredViewer.java:1152)
	at org.eclipse.jface.viewers.StructuredViewer$6.handleOpen(StructuredViewer.java:1256)
	at org.eclipse.jface.util.OpenStrategy.fireOpenEvent(OpenStrategy.java:275)
	at org.eclipse.jface.util.OpenStrategy.access$2(OpenStrategy.java:269)
	at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:309)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4125)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1457)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1480)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1465)
	at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1270)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3971)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3610)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:969)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:885)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:87)
	at org.eclipse.ui.internal.Workbench$3.run(Workbench.java:539)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:519)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'org.eclipse.e4.ui.model.application.ui.basic.impl.PartSashContainerImpl@1ed5c93a (elementId: null, tags: null, contributorURI: null) (widget: null, renderer: null, toBeRendered: true, onTop: false, visible: true, containerData: null, accessibilityPhrase: null) (horizontal: true)' is not legal. (platform:/resource/de.kvg-gymnasium.mobi.manager/Application.e4xmi, -1, -1)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XMLHandler.java:2663)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.handleForwardReferences(XMLHandler.java:1149)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.endDocument(XMLHandler.java:1228)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endDocument(AbstractSAXParser.java:737)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:516)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
	at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
	at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:181)
	at org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.java:242)
	at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1511)
	at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1290)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
	... 126 more
Caused by: java.lang.IllegalArgumentException: The selected element org.eclipse.e4.ui.model.application.ui.basic.impl.PartSashContainerImpl@1ed5c93a (elementId: null, tags: null, contributorURI: null) (widget: null, renderer: null, toBeRendered: true, onTop: false, visible: true, containerData: null, accessibilityPhrase: null) (horizontal: true) is not a child of this container
	at org.eclipse.e4.ui.model.application.ui.impl.ElementContainerImpl.setSelectedElement(ElementContainerImpl.java:158)
	at org.eclipse.e4.ui.model.application.ui.impl.ElementContainerImpl.eSet(ElementContainerImpl.java:234)
	at org.eclipse.e4.ui.model.application.ui.basic.impl.WindowImpl.eSet(WindowImpl.java:749)
	at org.eclipse.e4.ui.model.application.ui.basic.impl.TrimmedWindowImpl.eSet(TrimmedWindowImpl.java:121)
	at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSet(BasicEObjectImpl.java:1081)
	at org.eclipse.emf.ecore.xmi.impl.XMLHelperImpl.setValue(XMLHelperImpl.java:1210)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XMLHandler.java:2658)
	... 142 more


I hope you can help me thank you.
Chrisitan

[Updated on: Wed, 31 August 2011 20:12]

Report message to a moderator

Re: problem opening Application.e4xmi in e4 windows 64bit [message #721100 is a reply to message #721011] Wed, 31 August 2011 21:18 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,

The problem is the selectedElement in your Window which is pointing to a
PartSashContainer which is kind of strange and I can't think how you
could get your model in this state.

if you change the XMI-File to make the TrimmedWindow look like this

> <children xsi:type="basic:TrimmedWindow" xmi:id="_BL6281IlEeC4t7DZ8Z1yaw" elementId="de.kvg-gymnasium.mobi.manager.MainWindow" label="Mobi-Manager" width="750" height="400">

It once more works.

Tom

Am 31.08.11 18:56, schrieb christian-hanster:
> Thank you for the very fast response. I use eclipse 4.1 with e4 0.11. I have added the .e4xmi in the attachements.
>
> I hope you can help me thank you.
> Chrisitan
Re: problem opening Application.e4xmi in e4 windows 64bit [message #721106 is a reply to message #721100] Wed, 31 August 2011 21:53 Go to previous messageGo to next message
Christian Hanster is currently offline Christian HansterFriend
Messages: 22
Registered: March 2011
Junior Member
Thank you very much for the solution you have helped me very much also with your tutorial.

I first didn't have a perspectiveStack only the PartSash, then I added the perspective stack and put the partsash in the perspective and then eclipse does not recognize that PartSash can not be the selected element.

Christian

[Updated on: Wed, 31 August 2011 21:53]

Report message to a moderator

Re: problem opening Application.e4xmi in e4 windows 64bit [message #721131 is a reply to message #721106] Wed, 31 August 2011 23:07 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,

That's what I thought also so i tried to reproduce it but was not able
to do so. Did you do this directly in the XMI or using the UI can you
give me detailed steps on how reproduce this because I tried and didn't
managed to do so.

Tom

Am 31.08.11 23:53, schrieb christian-hanster:
> Thank you very much for the solution you have helped me very much also
> with your tutorial. I first didn't have a perspectiveStack only the
> PartSash, then I added the perspective stack and put the partsash in the
> perspective and then eclipse does not recognize that PartSash can not be
> the selected element.
>
> Christian
Re: problem opening Application.e4xmi in e4 windows 64bit [message #727218 is a reply to message #721131] Tue, 20 September 2011 16:15 Go to previous messageGo to next message
Christian Hanster is currently offline Christian HansterFriend
Messages: 22
Registered: March 2011
Junior Member
Sorry for the late response but I unsubscribed by mistake from this topic Sad
I have built the application with the "e4 workbenchmodel-editor". The problem is that I also have tried to reproduce the problem but I didn't get it.
I have the suspicion that my mac rans out of ram (I had only 2GB) and then eclipse does not have done all stuff with the xmi. In this time I had often problems with my mac slowing down because of not having enough memory.

Christian
Re: problem opening Application.e4xmi in e4 windows 64bit [message #728373 is a reply to message #727218] Fri, 23 September 2011 06:56 Go to previous messageGo to next message
Parvez Ahmad Hakim is currently offline Parvez Ahmad HakimFriend
Messages: 31
Registered: May 2010
Member
I get bellow error while running exported product file.
Can you help me. I tried bot features as well as plugin based approach, but no luck

Parvez Ahmad Hakim
Srinagar Kashmir http://www.abobjects.com
!SESSION 2011-09-23 11:07:40.531 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.equinox.app 0 0 2011-09-23 11:07:50.609
!MESSAGE Product org.cord.client.dms.mainapp.e4.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2011-09-23 11:07:50.625
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:126)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Re: problem opening Application.e4xmi in e4 windows 64bit [message #728384 is a reply to message #728373] Fri, 23 September 2011 07:16 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5468
Registered: July 2009
Senior Member
Like stated in the error message the product can't be found. I guess the
reason is that the plugin.xml is missing in the build.properties.

There's been a bug in the project-wizard which didn't included necessary
files in the build.properties [1]

Tom

[1]https://bugs.eclipse.org/bugs/show_bug.cgi?id=351421

Am 23.09.11 08:56, schrieb Parvez Ahmad Hakim:
> I get bellow error while running exported product file.
> Can you help me. I tried bot features as well as plugin based approach,
> but no luck
>
> Parvez Ahmad Hakim
> Srinagar Kashmir http://www.abobjects.com
> !SESSION 2011-09-23 11:07:40.531
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0_11
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Command-line arguments: -os win32 -ws win32 -arch x86
>
> !ENTRY org.eclipse.equinox.app 0 0 2011-09-23 11:07:50.609
> !MESSAGE Product org.cord.client.dms.mainapp.e4.product could not be found.
>
> !ENTRY org.eclipse.osgi 4 0 2011-09-23 11:07:50.625
> !MESSAGE Application error
> !STACK 1
> java.lang.NullPointerException
> at
> org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:126)
>
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
>
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
>
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> at java.lang.reflect.Method.invoke(Unknown Source)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
>
Previous Topic:E4 Eclipse product export wizard
Next Topic:Eclipse E4 - Example for css styling
Goto Forum:
  


Current Time: Thu Nov 27 08:52:58 GMT 2014

Powered by FUDForum. Page generated in 0.12109 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software