Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » ClassLoader hook bug fix?
ClassLoader hook bug fix? [message #570939] Mon, 26 January 2009 14:34
David Beers is currently offline David BeersFriend
Messages: 17
Registered: July 2009
Location: Denver, CO
Junior Member

Greetings,

I just installed MTJ (0.9.1.200812301406-07h27I99mDIN9DS9c) on Eclipse 3.5
and ran into immediate trouble launching Eclipse once I updated the
config.ini to support preprocessing:

java.lang.NoClassDefFoundError:
org/eclipse/osgi/framework/internal/core/BundleLoader
at
org.eclipse.mtj.core.hooks.MTJClassLoadingHook.createClassLo ader(Unknown
Source)
at
org.eclipse.osgi.baseadaptor.BaseData.createClassLoader(Base Data.java:92)

I saw Craig's post on equinox-dev about this
( http://dev.eclipse.org/mhonarc/lists/equinox-dev/msg05165.ht ml) and from
the thread there it sounded like he had discovered a fix. I'm eager to
get the preprocessing working but not that excited about rolling back to
an older version of Eclipse for it. How soon can we expect a patch to be
available?

Cheers,

David Beers
MapQuest
Previous Topic:Debugging a Midlet [caution MTJ noob inside]
Next Topic:ClassLoader hook bug fix?
Goto Forum:
  


Current Time: Mon Nov 24 16:43:25 GMT 2014

Powered by FUDForum. Page generated in 0.03946 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software