Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Webtools incubator » Error Installing from Web Tools (WTP) Update Site
Error Installing from Web Tools (WTP) Update Site [message #570368] Fri, 28 August 2009 06:58 Go to next message
Steven McArdle is currently offline Steven McArdle
Messages: 5
Registered: July 2009
Junior Member
Hi,

I am trying to update the WTP from the update site and I get the following error : 8o

Cannot find a solution satisfying the following requirements javax.wsdl [1.6.2.v200806030405].

In my plugins directory I have the following :

javax.wsdl_1.6.2.v200806030405.jar

As well as the 1.4.0 and 1.5.1 versions

This is really causing me some issues now and I have run out of ideas on how to solve the problem. :(

I am running 3.4 on a MacBook Pro and have set -clean in the ini file just in case.

Any ideas on how to get over this would be well appreciated.

Regards

Steven McArdle
Re: Error Installing from Web Tools (WTP) Update Site [message #570452 is a reply to message #570368] Fri, 28 August 2009 09:59 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
Steven McArdle wrote:
>
> Any ideas on how to get over this would be well appreciated.
>

A couple of ideas.

-clean probably makes things worse in most cases (these days ... I know
it used to be routine, but don't think its needed or desirable these days).

Which update site are you "going" to? I looked at /webtools/updates and
it appears there. If you are using /releases/galileo I do not see it
there. Which means it is probably not at /releases/ganymede either.

Another problem is that our /webtools/updates site is really only for
installing Eclipse 3.5 based software ... not moving from 3.4 to 3.5.

You say "javax.wsdl" is in you plugins directory, but how did they get
there? Were they "installed" or just "copied" into there. Copying is
seldom enough. If it wasn't "installed" it may not be "seen" by Eclipse
during update.

If none of these ideas lead to anything, I think you'd have to give very
detailed steps of what you started with, what you did next, what you are
trying to do, etc., for anyone to be of much help.
Re: Error Installing from Web Tools (WTP) Update Site [message #570700 is a reply to message #570368] Mon, 11 January 2010 05:31 Go to previous message
Christian Bayer is currently offline Christian Bayer
Messages: 2
Registered: January 2010
Junior Member
I am having exactly the same problem with Eclipse 3.4 based Rational Software Architect 7.5.4. I do also have dozens of plugins installed, don't know which one initially pulled javax.wsdl [1.6.2.v200806030405].
WTP refuses to install because this exact requirement is missing, which is obviously there:
As a matter of facts javax.wsdl_1.6.2.v200806030405.jar is in the plugins directory and is loaded on startup - if I delete it from the plugins directory, the IDE hangs with "initializing plugins" or something like that. So you cannot use Update manager to install an older version of it. WSDL 1.5.2 cannot be installed when 1.6.2 is present, because Update Manager complains that a newer version is installed...
Putting a WSDL 1.5.1-jar changes nothing, either it is not properly installed or simply ignored. To make it even worse I do not even know if the WTP will run with WSDL 1.5.
Previous Topic:Error Installing from Web Tools (WTP) Update Site
Next Topic:Is it possible to disable the EAR Project generation for the Web Service?
Goto Forum:
  


Current Time: Sat Aug 30 22:30:23 EDT 2014

Powered by FUDForum. Page generated in 0.03416 seconds