Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Re: User region and springframework upgrades
Re: User region and springframework upgrades [message #570243] Thu, 06 May 2010 09:59 Go to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Virgo is more conservative than Spring DM. We assume that backward incompatibilities may be introduced by Spring 3.1 whereas Spring DM assumes sufficient backward compatibility right up until Spring 4!

Your point about the version of Spring being unchecked is interesting. Of course there will be some resolution failures which will give a pretty strong hint, but there is no simple event log messages which says "Your version of Spring is too high". I suppose a check could be added during user region initialisation. Please file a bug if you would like to see that.

At some stage, we are going to be looking for people to fix some of these bugs. ;)
Re: User region and springframework upgrades [message #570279 is a reply to message #570243] Thu, 06 May 2010 10:57 Go to previous message
Dmitry Sklyut is currently offline Dmitry Sklyut
Messages: 268
Registered: January 2010
Senior Member
Bugzilla: 311900

I think in short term a version matrix should be enough.

But the burden is on you to commit the code so we can start looking at it :) . With change in packaging it would be much harder to try to address it in both places (dm-server and virgo code base)
Previous Topic:User region and springframework upgrades
Next Topic:Developer tools in Virgo
Goto Forum:
  


Current Time: Thu Apr 17 17:47:16 EDT 2014

Powered by FUDForum. Page generated in 0.01520 seconds