Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » User region and springframework upgrades
User region and springframework upgrades [message #570227] Thu, 06 May 2010 13:51
Dmitry Sklyut is currently offline Dmitry SklyutFriend
Messages: 278
Registered: January 2010
Senior Member
Breaking up server into a kernel and user region allows user region to independently update version of springframework.

Should there be some documentation available or validation done before starting user region that checks on the maximum supported version of springframework?

Currently the only fool proof way to check the max version of support for user region that I know of is to look in the manifest of com.springsource.kernel.dmfragment

....
org.springframework.beans.factory;version="[2.5.6
,3.1)",org.springframework.beans.factory.config;version="[2.5.6,3.1) "
,org.springframework.beans.factory.support;version="[2.5.6,3.1) ",org.
springframework.context;version="[2.5.6,3.1)",org.springframework.con
text.event;version="[2.5.6,3.1)",org.springframework.instrument.class
loading;version="[2.5.6,3.1)",org.springframework.jmx.export;version=
"[2.5.6,3.1)"
....


Am I missing something? Shouldn't version range of dm extender fragment match dm extender version range that is
[2.5.6, 4.0.0)?

Regards,

Dmitry
Previous Topic:Virgo Build - common directory for ivy repo
Next Topic:Speeding up resolution and server start up
Goto Forum:
  


Current Time: Thu Dec 18 00:46:14 GMT 2014

Powered by FUDForum. Page generated in 0.02280 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software