Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » some notes to make imp work for 3.3/3.4m5
some notes to make imp work for 3.3/3.4m5 [message #569979] Tue, 25 March 2008 07:28
Jin Missing name is currently offline Jin Missing nameFriend
Messages: 100
Registered: July 2009
Senior Member
The offical version for eclipse 3.3(or higher) seem in a very low priority.
But I sugguest imp committers to deal with this request soonly.
If we are extremely anxious, we should do it ourselves:)

I wrrite some notes here in some experiments today. And I hope this may
answer some questions about this topic to some extent.

1. make all prerequisites ready in your workspace.
see more: http://eclipse-imp.sourceforge.net/developers/index.html
notes: for me, lpg.runtime.java(and its dependencies) source ,
com.ibm.wala.shrike source, and polyglot binary

2. get the source from offical svn.
see more: http://www.eclipse.org/imp

3. some compiling error will appear after step 1,2. Then, we should
"Building Required Parsers".
see more: http://eclipse-imp.sourceforge.net/developers/index.html
notes: build every *.g files. Some projects seem been removed in offical svn
, such as "org.eclipse.imp.java.core", just remove or ingore some
instructions in the "IMP Developer's Corner".

4. close some un-completing projects(in my understanding?^_^) and
notes: I close *.formatting,*lpg.analysis.
I add some guessed-implenmentation to *.box
and *.leg. But I'm not sure they will work really^_^ So you can close them
as well.
sdf_eclipse_install,*.pbd seem not existing. So close/ingore/remove their
infos. Remember to DO some cleaning in MF files.

5. arrive here, you will see a litte compiling errors in *imp.mattooling and
*lpg.runtime. There are main errors caused by the API migration. trrival to
correct them.
note: I don't use the patch by Karl(see more:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=221887), the patch seem
seriously to modify the orignal imp. I'm not very sure it is neccessary.

6. After some fixes, there should be no compiling errors.But in fact, there
some runtime errors.
notes:1>
LanguageRegistry#updateEditorRegistry
should use display.asyncExec() to avoild "invalid thread access"
2> a building mistake in *lpg.metatooling make it stop loading when running
form workspace.(maybe pass after deploying?) Delete the "jikespg.jar" in
"Building Configuaration" page, and recorrect them.

7. After 1-6, the basic functionalities seem ready to use. And I migrate the
imp to 3.3/3.4m5. seem no big problem^_^

I add a snapshot in the attachment.


Previous Topic:state of lpg
Next Topic:state of lpg
Goto Forum:
  


Current Time: Sat Dec 20 13:51:48 GMT 2014

Powered by FUDForum. Page generated in 0.01590 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software