Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [MTL] How to register ecore metamodel for the editor?
[MTL] How to register ecore metamodel for the editor? [message #57317] Fri, 13 February 2009 07:53 Go to next message
Andreas Voss is currently offline Andreas VossFriend
Messages: 51
Registered: July 2009
I'm developing an ecore metamodel and want to generate code via MTL. But
the editor does not recognize my ecore URI. Will there be some kind of
mapping dialog similar to QVT (where I can map URIs to their
corresponding ecore files)?

I can generate the model code (genmodel), start a runtime workbench and
work there, then the MTL editor recognizes my generated model. But I'd
prefer not to launch a second eclipse instance.

Kind Regards,
Re: [MTL] How to register ecore metamodel for the editor? [message #57395 is a reply to message #57317] Fri, 13 February 2009 10:52 Go to previous message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1752
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit


We have the same constraints as EMF on this : if the metamodel URI
hasn't been registered you cannot write templates on it. You can either
create a dynamic instance of your metamodel (I think this makes EMF
register the nsURI), or use the AM3's right-click action "register
metamodel". I believe MTL would recognize your metamodel in such cases,
though this hasn't been tested.

Laurent Goubet

Andreas Voss a
Previous Topic:[MTL] Add custom function for special formatting?
Next Topic:[Announce] M2T XPAND 0.7.0 I200902191437 is available
Goto Forum:

Current Time: Sat Oct 22 05:45:20 GMT 2016

Powered by FUDForum. Page generated in 0.25918 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software