Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » TemplateFactory.load help
TemplateFactory.load help [message #566877] Tue, 21 April 2009 10:56
No real name is currently offline No real nameFriend
Messages: 92
Registered: July 2009
Hi there,

I have in an EGL script the following line:

var t : Template := TemplateFactory.load('./Other.egl');

Previously, this line worked, but after my version of Epsilon from the SVN
I find that I get the following error:

Internal error: java.lang.IllegalArgumentException: URI is not absolute
at org.eclipse.epsilon.egl.EglModule.parse[]
at org.eclipse.epsilon.egl.types.EglTemplate.<init>[]
org.eclipse.epsilon.egl.types.EglFileGeneratingTemplate.<init >[]
org.eclipse.epsilon.egl.template.FileGeneratingTemplateFacto ry.load[]
at sun.reflect.NativeMethodAccessorImpl.invoke0[Native Method]

Do you have any ideas why this might have occurred.

I believe I am probably using the method incorrectly, as I may have
unintentionally changed some of my code along the lines. However, when
having a naive look in to the code, as to why this might error might be
happenning I noticed that in:


the resolveTemplate method calls UriUtil.resolve(path, templateRoot, root)
-- and on inspection templateRoot and root are null. Should this be the
case? Perhaps I need to call the TemplateFactory.load method differently?!

Any help to resolve this issue would be much appreciated.

PS. I'm running this EGL script from a standard launch configuration.

All the best,

Previous Topic:EWL setting a profile/stereotype and trigger the wizard
Next Topic:Access to the Diagram Model
Goto Forum:

Current Time: Wed Oct 07 21:19:13 GMT 2015

Powered by FUDForum. Page generated in 0.02292 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software