Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » OAW: issues with outlet path declaration in generator.oaw file
OAW: issues with outlet path declaration in generator.oaw file [message #56998] Sun, 08 February 2009 10:50 Go to next message
Philipp Zech is currently offline Philipp ZechFriend
Messages: 96
Registered: July 2009
Member
Hi,

I'm still working on a code generator using Xpand and OAw to generate
java source files out of UML activity diagrams. Currently I'm facing the
problem, that in the corresponding generator.oaw file, inside the
Generator component, the outlet for the generated files can be set with

<outlet path="some_path"/>

The problem I'm facing now, is that inside my generated java files i
have to use a specific package declaration (for this example let it be
"some_path"), which may looks like

package some_path;

public class SomeClass{
...
}

Now the conrete problem is, that somehow inside the some_path directory
the default-package is automatically created and all the generated java
files are stored there, which for sure leads to classpath problems.

To summarize it:

In the workflow file the defined outlet-path is: "some_path"
In the java files the decalred pacakge is: "some_path"

What it should look like after the generation:
some_path/File1.java
File2.java
.....

What it actually looks like:
some_path/(default-package)/File1.java
File2.java
.....

Anybody has got any ideas how to resolve this problem?

Thanks a lot in advance.

Cheers,

Philipp
Re: OAW: issues with outlet path declaration in generator.oaw file [message #57026 is a reply to message #56998] Sun, 08 February 2009 10:59 Go to previous message
Philipp Zech is currently offline Philipp ZechFriend
Messages: 96
Registered: July 2009
Member
Philipp Zech schrieb:
> Hi,
>
> I'm still working on a code generator using Xpand and OAw to generate
> java source files out of UML activity diagrams. Currently I'm facing the
> problem, that in the corresponding generator.oaw file, inside the
> Generator component, the outlet for the generated files can be set with
>
> <outlet path="some_path"/>
>
> The problem I'm facing now, is that inside my generated java files i
> have to use a specific package declaration (for this example let it be
> "some_path"), which may looks like
>
> package some_path;
>
> public class SomeClass{
> ...
> }
>
> Now the conrete problem is, that somehow inside the some_path directory
> the default-package is automatically created and all the generated java
> files are stored there, which for sure leads to classpath problems.
>
> To summarize it:
>
> In the workflow file the defined outlet-path is: "some_path"
> In the java files the decalred pacakge is: "some_path"
>
> What it should look like after the generation:
> some_path/File1.java
> File2.java
> .....
>
> What it actually looks like:
> some_path/(default-package)/File1.java
> File2.java
> .....
>
> Anybody has got any ideas how to resolve this problem?
>
> Thanks a lot in advance.
>
> Cheers,
>
> Philipp
again resolved: just some misconfigurations in eclipse: the path was
decalred as a source folder and not as a package. so now it works
Previous Topic:[Announce] M2T XPAND 0.7.0M5 is available
Next Topic:Xpand: invoking getValue() leads to an invocation target exception
Goto Forum:
  


Current Time: Sun Nov 23 21:37:08 GMT 2014

Powered by FUDForum. Page generated in 0.02891 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software