Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Error when running my RCP product using e4 as the target platform
Error when running my RCP product using e4 as the target platform [message #563047] Thu, 03 September 2009 03:50
Mickael Istria is currently offline Mickael Istria
Messages: 735
Registered: July 2009
Location: Grenoble, France
Senior Member
Hi all,

I tried to run a working RCP product on e4, just for the fun.
To achieve this, I use e4 0.9 as target platform, and I create a new product definition that includes all e4 things.

Then, when executing the product, I get while loading the workbench:

java.lang.NullPointerException
at org.eclipse.e4.workbench.ui.menus.MenuHelper.indexForId(Menu Helper.java:126)
at org.eclipse.e4.workbench.ui.menus.ActionSet.addMenu(ActionSe t.java:126)
at org.eclipse.e4.workbench.ui.menus.ActionSet.merge(ActionSet. java:56)
at org.eclipse.e4.workbench.ui.menus.MenuHelper.processActionSe ts(MenuHelper.java:101)
at org.eclipse.ui.internal.WorkbenchWindow.<init>(WorkbenchWindow.java:383)
at org.eclipse.ui.internal.tweaklets.Workbench3xImplementation. createWorkbenchWindow(Workbench3xImplementation.java:31)
at org.eclipse.ui.internal.Workbench.newWorkbenchWindow(Workben ch.java:2289)
at org.eclipse.ui.internal.Workbench.access$16(Workbench.java:2 286)
at org.eclipse.ui.internal.Workbench$17.runWithException(Workbe nch.java:1119)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run (StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3468)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3115)
at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(Work benchAdvisor.java:803)
at org.eclipse.ui.internal.Workbench$30.runWithException(Workbe nch.java:1551)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run (StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3468)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3115)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2729)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:26 34)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:562)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:555)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.bonitasoft.studio.application.BonitaStudioApplication.st art(BonitaStudioApplication.java:37)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)

I tried to remove the org.eclipse.e4.ui.workbench.fragment, but I still get this error.

How can I get rid of this error and run my product? Is this a bug in e4, should I open an issue on bugzilla for it?

Mickael
Previous Topic:Something is fishy
Next Topic:Error in running the photo demo
Goto Forum:
  


Current Time: Fri Jul 25 21:09:04 EDT 2014

Powered by FUDForum. Page generated in 0.02048 seconds