Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMT (Generative Modeling Technologies) » [oaw] metamodel referencing
[oaw] metamodel referencing [message #562565] Fri, 16 February 2007 20:20
Hans Boerstra is currently offline Hans BoerstraFriend
Messages: 48
Registered: July 2009
We have a metamodel for our DSL that references the UML2 metamodel.
When we refer to a UML2 metamodel element like this
It works fine when using a model based on this metamodel in a oaw workflow.
The standard ecore editor saves the UML2 references like this however:
.../../../plugin/org.eclipse.uml2.uml/model/UML.ecore#//Prop erty
and that trips up the oaw workflow with an exception like stated below.

Is there a way to make these relative metamodel references work in oaw?
I did put my vote up in bugzilla for emf to have a choice between relative
or absolute referencing registered plugin models, but in the mean time it
would be great if you could support the relative referencing as well.



1663 ERROR WorkflowRunner -
org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Value
'MyElementName' is not legal.
(file:/C:/Documents%20and%20Settings/Hans/Eclipse%203.3%20pr ojects/my.generator.project/bin/model/test.model,
3, 105)
at org.openarchitectureware.emf.XmiReader.invoke( :83)
org.openarchitectureware.workflow.container.CompositeCompone nt.internalInvoke(
org.openarchitectureware.workflow.container.CompositeCompone nt.invoke(
org.openarchitectureware.workflow.WorkflowRunner.executeWork flow(
Previous Topic:[Announce] EclipseCon 2007 Registration
Next Topic:xText Startup Questions
Goto Forum:

Current Time: Tue Dec 01 09:19:43 GMT 2015

Powered by FUDForum. Page generated in 0.02111 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software