Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Getting http connection issues mylyn+trac
Getting http connection issues mylyn+trac [message #56610] Mon, 25 August 2008 21:26 Go to next message
PK Missing name is currently offline PK Missing name
Messages: 24
Registered: July 2009
Junior Member
Hello,
An eclipse mylyn client on my Mac is able to connect to the task
respository and synchronize wihtout any issues. However the same versions
of eclipse & mylyn on Windowx XP give "HTTP connection reset" errors and
fail to synchronize. The update attributes from server button also causes
the same error on win xp.

Can somebody tell me what might be wrong and how I can correct this issue.


Thanks,
PK
Re: Getting http connection issues mylyn+trac [message #56664 is a reply to message #56610] Tue, 26 August 2008 00:36 Go to previous messageGo to next message
Eclipse User
Originally posted by: steffen.pingel.eclipse.org

If your network connection to the repository works otherwise on the XP
machine (e.g. from a browser) check if Eclipse/Mylyn is blocked in your
firewall settings or if you have a proxy configured in the Eclipse
preferences that may block the connection.

Steffen


> Hello,
> An eclipse mylyn client on my Mac is able to connect to the task
> respository and synchronize wihtout any issues. However the same versions
> of eclipse & mylyn on Windowx XP give "HTTP connection reset" errors and
> fail to synchronize. The update attributes from server button also causes
> the same error on win xp.
>
> Can somebody tell me what might be wrong and how I can correct this issue.
>
>
> Thanks,
> PK
Re: Getting http connection issues mylyn+trac [message #56718 is a reply to message #56664] Tue, 26 August 2008 12:57 Go to previous messageGo to next message
PK Missing name is currently offline PK Missing name
Messages: 24
Registered: July 2009
Junior Member
Steffen,
Thanks for replying. The mylyn trac connector is able to validate the
connection to the server fine. After I posted the original message, I
found out that I get http connection reset errors only when i am connected
via my wireless connection. Through a wired connection it works fine.

Any hints on why i might be getting http connection reset errors when
connected via wireless? I am connecting to a tracd daemon running on my
home server and trac is my mylyn task repository.

Thanks,
PK
Re: Getting http connection issues mylyn+trac [message #57350 is a reply to message #56718] Tue, 09 September 2008 17:18 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
Are you using digest authentication? If so the errors might be related to
this bug:

214341: Large XML-RPC requests fail when using digest authentication and
tracd
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214341

Steffen


PK wrote:

> Steffen,
> Thanks for replying. The mylyn trac connector is able to validate the
> connection to the server fine. After I posted the original message, I
> found out that I get http connection reset errors only when i am connected
> via my wireless connection. Through a wired connection it works fine.
>
> Any hints on why i might be getting http connection reset errors when
> connected via wireless? I am connecting to a tracd daemon running on my
> home server and trac is my mylyn task repository.
>
> Thanks,
> PK
Re: Getting http connection issues mylyn+trac [message #592777 is a reply to message #56610] Tue, 26 August 2008 00:36 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
If your network connection to the repository works otherwise on the XP
machine (e.g. from a browser) check if Eclipse/Mylyn is blocked in your
firewall settings or if you have a proxy configured in the Eclipse
preferences that may block the connection.

Steffen


> Hello,
> An eclipse mylyn client on my Mac is able to connect to the task
> respository and synchronize wihtout any issues. However the same versions
> of eclipse & mylyn on Windowx XP give "HTTP connection reset" errors and
> fail to synchronize. The update attributes from server button also causes
> the same error on win xp.
>
> Can somebody tell me what might be wrong and how I can correct this issue.
>
>
> Thanks,
> PK
Re: Getting http connection issues mylyn+trac [message #592798 is a reply to message #56664] Tue, 26 August 2008 12:57 Go to previous message
PK Missing name is currently offline PK Missing name
Messages: 24
Registered: July 2009
Junior Member
Steffen,
Thanks for replying. The mylyn trac connector is able to validate the
connection to the server fine. After I posted the original message, I
found out that I get http connection reset errors only when i am connected
via my wireless connection. Through a wired connection it works fine.

Any hints on why i might be getting http connection reset errors when
connected via wireless? I am connecting to a tracd daemon running on my
home server and trac is my mylyn task repository.

Thanks,
PK
Re: Getting http connection issues mylyn+trac [message #593070 is a reply to message #56718] Tue, 09 September 2008 17:18 Go to previous message
Steffen Pingel is currently offline Steffen Pingel
Messages: 706
Registered: July 2009
Senior Member
Are you using digest authentication? If so the errors might be related to
this bug:

214341: Large XML-RPC requests fail when using digest authentication and
tracd
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214341

Steffen


PK wrote:

> Steffen,
> Thanks for replying. The mylyn trac connector is able to validate the
> connection to the server fine. After I posted the original message, I
> found out that I get http connection reset errors only when i am connected
> via my wireless connection. Through a wired connection it works fine.
>
> Any hints on why i might be getting http connection reset errors when
> connected via wireless? I am connecting to a tracd daemon running on my
> home server and trac is my mylyn task repository.
>
> Thanks,
> PK
Previous Topic:Web Templates Connector with BASIC Authentication
Next Topic:Gerneric Connector
Goto Forum:
  


Current Time: Sun Oct 26 03:11:00 GMT 2014

Powered by FUDForum. Page generated in 0.02110 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software