|Method names in interface Renderable renamed [message #561296]
||Thu, 28 May 2009 12:26
|| Jens von Pilgrim
Registered: July 2009
I have renamed the methods found in interface org.eclipse.draw3d.Renderable:
render(RenderContext) --> prerender(RenderContext)
postrender(RenderContext) --> render(RenderContext)
These new names better reflect how these methods should be used, in
most cases only the render method is assumed to be implemented.
If you run into any compiler problems, I would suggest to rename all
postrender(..) methods into render(..). I assume that prerender
(previously known as render) is only rarely used. If you have only
(pre-)render implemented, I would suggest to
call it render() now, unless you have good reasons to call it prerender.
I'm sorry for this inconvenience.
Powered by FUDForum
. Page generated in 0.03649 seconds