Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMW » Problem installing AMW and AM3 plugins.
Problem installing AMW and AM3 plugins. [message #559484] Thu, 16 September 2010 18:33 Go to next message
Toñi Reina is currently offline Toñi ReinaFriend
Messages: 209
Registered: July 2009
Senior Member
Hi,


I'd like to test AMW and the megamodel tools, so I have downloaded the
plugins from SVN as it is stated in the how to:
http://wiki.eclipse.org/AM3/How_Install_New_AM3_From_SVN

However, an error is reported on
org.eclipse.gmt.am3.extractor.launchers plugin. Concretely, the problem
is in the org.eclipse.gmt.am3.extractor.launchers.utils.ATLUtils class,
just in the piece of code I have included below.


private ATLUtils() {
super();
try {
//ATLLaunchConstants.REGULAR_VM_NAME
transformationLauncher =
CoreService.getLauncher(ATLLaunchConstants.EMF_VM_NAME);
transfoLauncherOptions = new HashMap<String,Object>();
transformationLauncher.initialize(transfoLauncherOptions);
modelFactory = CoreService.getModelFactory("EMF");
injector = CoreService.getInjector("EMF");
extractor = CoreService.getExtractor("EMF");
xmlExtractor = CoreService.getExtractor("XML");
} catch (ATLCoreException e) {
e.printStackTrace();
}
}
The problem seems to be in line modelFactory =
CoreService.getModelFactory("EMF"); and it is because the CoreService
class has not a method named getModelFactory (at least, that's what
Eclipse is reporting).

I have installed Eclipse Galileo, EMF 2.5.0 and ATL 3.0.2. Is there
something that I have missed?

Thanks in advance,
Toñi
Re: Problem installing AMW and AM3 plugins. [message #559681 is a reply to message #559484] Fri, 17 September 2010 14:48 Go to previous message
Toñi Reina is currently offline Toñi ReinaFriend
Messages: 209
Registered: July 2009
Senior Member
Hi,

I have found someone with a similar problem in the eclipse.am3
newsgroup, and the answer to the question.


El 16/09/2010 20:33, Toñi Reina Quintero escribió:
> Hi,
>
>
> I'd like to test AMW and the megamodel tools, so I have downloaded the
> plugins from SVN as it is stated in the how to:
> http://wiki.eclipse.org/AM3/How_Install_New_AM3_From_SVN
>
> However, an error is reported on org.eclipse.gmt.am3.extractor.launchers
> plugin. Concretely, the problem is in the
> org.eclipse.gmt.am3.extractor.launchers.utils.ATLUtils class, just in
> the piece of code I have included below.
>
>
> private ATLUtils() {
> super();
> try {
> //ATLLaunchConstants.REGULAR_VM_NAME
> transformationLauncher =
> CoreService.getLauncher(ATLLaunchConstants.EMF_VM_NAME);
> transfoLauncherOptions = new HashMap<String,Object>();
> transformationLauncher.initialize(transfoLauncherOptions);
> modelFactory = CoreService.getModelFactory("EMF");
> injector = CoreService.getInjector("EMF");
> extractor = CoreService.getExtractor("EMF");
> xmlExtractor = CoreService.getExtractor("XML");
> } catch (ATLCoreException e) {
> e.printStackTrace();
> }
> }
> The problem seems to be in line modelFactory =
> CoreService.getModelFactory("EMF"); and it is because the CoreService
> class has not a method named getModelFactory (at least, that's what
> Eclipse is reporting).
>
> I have installed Eclipse Galileo, EMF 2.5.0 and ATL 3.0.2. Is there
> something that I have missed?
>
> Thanks in advance,
> Toñi
Previous Topic:[AMW] weave a metamodel in the registry
Next Topic:Problems opening AMW files
Goto Forum:
  


Current Time: Thu Nov 27 00:44:01 GMT 2014

Powered by FUDForum. Page generated in 0.03163 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software