Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Missing "Object Constraint Language (OCL) 2.0 Compatibility API"
Missing "Object Constraint Language (OCL) 2.0 Compatibility API" [message #558350] Sat, 11 September 2010 13:28 Go to next message
Benjamin Klatt is currently offline Benjamin KlattFriend
Messages: 36
Registered: September 2010
Member
Hi all,

we have an eclipse extension with the dependency on org.eclipse.emf.ocl that is called "Object Constraint Language (OCL) 2.0 Compatibility API".

Now, I am checking the upgrade of our environment from galileo to helios. Unfortunately, I am not able to find the plugin with the id org.eclipse.emf.ocl anymore. Does anybody know where this has gone?

Thanks a lot!
Benjamin
Re: Missing "Object Constraint Language (OCL) 2.0 Compatibility API" [message #558513 is a reply to message #558350] Mon, 13 September 2010 09:55 Go to previous message
Adolfo Sanchez-Barbudo Herrera is currently offline Adolfo Sanchez-Barbudo HerreraFriend
Messages: 254
Registered: July 2009
Senior Member
Benjamin,

The set of org.eclipse.emf.ocl.* plugins/features have been deprecated
since time ago, when the set of org.eclipse.ocl.* appeared (in Europe
release if I'm not wrong).

The OCL team decided to throw away the set of org.eclipse.emf.ocl.* in
Helios release. Although the org.eclipse.emf.ocl.* source are still
available (http://www.eclipse.org/modeling/mdt/downloads/?project=ocl -
1.3.0 (2009/06/15) ), I encourage you to switch your client code to use
the set of org.eclipse.ocl.* plugins/features since we have not tested
that the org.eclipse.emf.ocl.* plugins/features work in an Helios
installation.

Since the org.eclipse.emf.ocl API delegates to the org.eclipse.ocl one,
it could be plausible that it worked. However, there was a major version
increment (MDT/OCL 3.0.0) so it's possible that the something could have
broken the org.eclipse.emf.ocl code

Anyway, as said, I recommend switching to the org.eclipse.ocl
plugins/features. It's up to you.

Regards,
Adolfo.
El 11/09/2010 14:28, Benjamin escribió:
> Hi all,
>
> we have an eclipse extension with the dependency on org.eclipse.emf.ocl
> that is called "Object Constraint Language (OCL) 2.0 Compatibility API".
>
> Now, I am checking the upgrade of our environment from galileo to
> helios. Unfortunately, I am not able to find the plugin with the id
> org.eclipse.emf.ocl anymore. Does anybody know where this has gone?
>
> Thanks a lot!
> Benjamin
Previous Topic:[OCLinEcore] Error using EReference::EKeys property
Next Topic:[OCLinEcore] Possibility of defining an attribute as a list of list
Goto Forum:
  


Current Time: Tue Dec 23 02:16:12 GMT 2014

Powered by FUDForum. Page generated in 0.07552 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software