Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » How to install Maven-Nar plugin?
How to install Maven-Nar plugin? [message #557532] Wed, 08 September 2010 01:50 Go to next message
Peter Missing name is currently offline Peter Missing name
Messages: 31
Registered: July 2010
Member
Folks,

I am new to Eclipse development environment. I am trying to understand how to add nar plugin for JNI development that is available at http://duns.github.com/maven-nar-plugin/index.html#nar-downl oad.

If I go into "Available Software" and add http://mojo.codehaus.org as a site, I get an error that "No software site found at http://mojo.codehaus.org."

Thank you in advance for your help.

Regards,
Peter
Re: How to install Maven-Nar plugin? [message #629011 is a reply to message #557532] Sat, 25 September 2010 23:27 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 1
Registered: September 2010
Junior Member
I had the same problem.

the maven-eclipse plugin is at
http://m2eclipse.sonatype.org/sites/m2e
which will do about 1/2 the job; don't know if that helps.

[Updated on: Sat, 25 September 2010 23:38]

Report message to a moderator

Re: How to install Maven-Nar plugin? [message #635562 is a reply to message #629011] Wed, 27 October 2010 10:58 Go to previous message
Pooja is currently offline Pooja
Messages: 3
Registered: October 2010
Junior Member
hello there
I am new to Eclipse Helios. I am trying to understand how to add maven that is available at http://m2eclipse.sonatype.org/sites/m2e
I pasted the link at "install new software" install, got the following software "Maven Integration for Eclipse (Required) 0.10.2.20100623-1649". At this level, it seemed that all dependencies were found but it shows the following error message while installing & fetching the software.

Cannot complete the install because one or more required items could not be found.
Software currently installed: Maven Integration for Eclipse (Required) 0.10.2.20100623-1649 (org.maven.ide.eclipse.feature.feature.group 0.10.2.20100623-1649)
Missing requirement: Java EMF Model Utilities 2.0.2.v200802192030 (org.eclipse.jem.util 2.0.2.v200802192030) requires 'bundle com.ibm.icu [3.4.4.1,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: EMF Utilities 1.1.104.v200709131115 (org.eclipse.wst.common.emf 1.1.104.v200709131115)
To: bundle org.eclipse.jem.util [2.0.0,3.0.0)
Cannot satisfy dependency:
From: Maven Integration for Eclipse 0.10.2.20100623-1649 (org.maven.ide.eclipse 0.10.2.20100623-1649)
To: bundle org.eclipse.wst.common.emf 0.0.0
Cannot satisfy dependency:
From: Maven Integration for Eclipse (Required) 0.10.2.20100623-1649 (org.maven.ide.eclipse.feature.feature.group 0.10.2.20100623-1649)
To: org.maven.ide.eclipse [0.10.2.20100623-1649]

Thanks in advance
Previous Topic:Unable to package project
Next Topic:can't install m2eclipse on Helios
Goto Forum:
  


Current Time: Mon Sep 15 09:44:53 GMT 2014

Powered by FUDForum. Page generated in 0.02362 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software