Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Workbench Save Restore
Workbench Save Restore [message #557430] Tue, 07 September 2010 11:56 Go to next message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
Hello
Can you give me an equivalent of iworkbenchconfigurer.setsaveandrestore ().
Thank you,
Claude
Re: Workbench Save Restore [message #557666 is a reply to message #557430] Wed, 08 September 2010 12:26 Go to previous messageGo to next message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

That's done by the save and restore of the deltas.xml file.

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Re: Workbench Save Restore [message #557749 is a reply to message #557666] Wed, 08 September 2010 17:25 Go to previous messageGo to next message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
Thank you for your reply.
For saveandrestore to false the only solution is a delete of deltas.xml?
If yes in the future improvement is expected?
Thank you
Claude
Re: Workbench Save Restore [message #557823 is a reply to message #557749] Thu, 09 September 2010 06:34 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Hi,

a) In your product-extension point define an attribute like this:
-----8<------
<property
name="persistState"
value="false">
</property>
-----8<------

b) Launch with -persistState false

Tom

Am 08.09.10 19:25, schrieb FAATH:
> Thank you for your reply.
> For saveandrestore to false the only solution is a delete of deltas.xml?
> If yes in the future improvement is expected?
> Thank you
> Claude
Re: Workbench Save Restore [message #557908 is a reply to message #557823] Thu, 09 September 2010 11:58 Go to previous messageGo to next message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
Hi,
Thank you for the info.

It's ok for the non persistence but with errors at startup [..... -consoleLog -persistState false java.lang.NullPointerException at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMos tRecentModel(ResourceHandler.java:233) ...... ] and the application shutdown [ java.net.UnknownServiceException: protocol doesn't support output at java.net.URLConnection.getOutputStream(Unknown Source) at org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createOut putStream(URIHandlerImpl.java:137) .......] test with or without deltas.xml.

Claude.
Re: Workbench Save Restore [message #557913 is a reply to message #557908] Thu, 09 September 2010 12:00 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Hm. Then this looks like a bug. Can you file a bugzilla and attach me to it.

Tom

Am 09.09.10 13:58, schrieb FAATH:
> Hi,
> Thank you for the info.
>
> It's ok for the non persistence but with errors at startup [.....
> -consoleLog -persistState false java.lang.NullPointerException at
> org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMos
> tRecentModel(ResourceHandler.java:233) ...... ] and the application
> shutdown [ java.net.UnknownServiceException: protocol doesn't support
> output at java.net.URLConnection.getOutputStream(Unknown Source) at
> org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createOut
> putStream(URIHandlerImpl.java:137) .......] test with or without
> deltas.xml.
>
> Claude.
Re: Workbench Save Restore [message #557925 is a reply to message #557913] Thu, 09 September 2010 12:51 Go to previous messageGo to next message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
I don 't know to file a bug.
I'll post my little application, if it can advance e4 (your email address tutorials.)
Thank you for your information and tutorials
Claude.
Re: Workbench Save Restore [message #557930 is a reply to message #557913] Thu, 09 September 2010 12:43 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Ok. You can also make the application clean up the delta.xml before
launching by using: -clearPersistedState

Tom

Am 09.09.10 14:00, schrieb Tom Schindl:
> Hm. Then this looks like a bug. Can you file a bugzilla and attach me to it.
>
> Tom
>
> Am 09.09.10 13:58, schrieb FAATH:
>> Hi,
>> Thank you for the info.
>>
>> It's ok for the non persistence but with errors at startup [.....
>> -consoleLog -persistState false java.lang.NullPointerException at
>> org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMos
>> tRecentModel(ResourceHandler.java:233) ...... ] and the application
>> shutdown [ java.net.UnknownServiceException: protocol doesn't support
>> output at java.net.URLConnection.getOutputStream(Unknown Source) at
>> org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createOut
>> putStream(URIHandlerImpl.java:137) .......] test with or without
>> deltas.xml.
>>
>> Claude.
>
Re: Workbench Save Restore [message #557931 is a reply to message #557925] Thu, 09 September 2010 12:55 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Hi,

I've already found the problem in our code. It is quite obvious from the
exception line you gave me here.

I'll file a bug my own and fix the problem in the code. In the meanwhile
you can use the -clearPersistedState option to clear the restoring (it's
not 100% ideal though because we still collect the deltas for well
nothing but it makes you application behave like you want it to).

Tom

Am 09.09.10 14:51, schrieb FAATH:
> I don 't know to file a bug.
> I'll post my little application, if it can advance e4 (your email
> address tutorials.)
> Thank you for your information and tutorials
> Claude.
Re: Workbench Save Restore [message #557932 is a reply to message #557931] Thu, 09 September 2010 13:30 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=324841

Tom

Am 09.09.10 14:55, schrieb Tom Schindl:
> Hi,
>
> I've already found the problem in our code. It is quite obvious from the
> exception line you gave me here.
>
> I'll file a bug my own and fix the problem in the code. In the meanwhile
> you can use the -clearPersistedState option to clear the restoring (it's
> not 100% ideal though because we still collect the deltas for well
> nothing but it makes you application behave like you want it to).
>
> Tom
>
> Am 09.09.10 14:51, schrieb FAATH:
>> I don 't know to file a bug.
>> I'll post my little application, if it can advance e4 (your email
>> address tutorials.)
>> Thank you for your information and tutorials
>> Claude.
>
Re: Workbench Save Restore [message #581491 is a reply to message #557666] Wed, 08 September 2010 17:25 Go to previous message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
Thank you for your reply.
For saveandrestore to false the only solution is a delete of deltas.xml?
If yes in the future improvement is expected?
Thank you
Claude
Re: Workbench Save Restore [message #581500 is a reply to message #581491] Thu, 09 September 2010 06:34 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Hi,

a) In your product-extension point define an attribute like this:
-----8<------
<property
name="persistState"
value="false">
</property>
-----8<------

b) Launch with -persistState false

Tom

Am 08.09.10 19:25, schrieb FAATH:
> Thank you for your reply.
> For saveandrestore to false the only solution is a delete of deltas.xml?
> If yes in the future improvement is expected?
> Thank you
> Claude
Re: Workbench Save Restore [message #581565 is a reply to message #557823] Thu, 09 September 2010 11:58 Go to previous message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
Hi,
Thank you for the info.

It's ok for the non persistence but with errors at startup [..... -consoleLog -persistState false java.lang.NullPointerException at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMos tRecentModel(ResourceHandler.java:233) ...... ] and the application shutdown [ java.net.UnknownServiceException: protocol doesn't support output at java.net.URLConnection.getOutputStream(Unknown Source) at org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createOut putStream(URIHandlerImpl.java:137) .......] test with or without deltas.xml.

Claude.
Re: Workbench Save Restore [message #581579 is a reply to message #581565] Thu, 09 September 2010 12:00 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Hm. Then this looks like a bug. Can you file a bugzilla and attach me to it.

Tom

Am 09.09.10 13:58, schrieb FAATH:
> Hi,
> Thank you for the info.
>
> It's ok for the non persistence but with errors at startup [.....
> -consoleLog -persistState false java.lang.NullPointerException at
> org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMos
> tRecentModel(ResourceHandler.java:233) ...... ] and the application
> shutdown [ java.net.UnknownServiceException: protocol doesn't support
> output at java.net.URLConnection.getOutputStream(Unknown Source) at
> org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createOut
> putStream(URIHandlerImpl.java:137) .......] test with or without
> deltas.xml.
>
> Claude.
Re: Workbench Save Restore [message #581594 is a reply to message #557913] Thu, 09 September 2010 12:43 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Ok. You can also make the application clean up the delta.xml before
launching by using: -clearPersistedState

Tom

Am 09.09.10 14:00, schrieb Tom Schindl:
> Hm. Then this looks like a bug. Can you file a bugzilla and attach me to it.
>
> Tom
>
> Am 09.09.10 13:58, schrieb FAATH:
>> Hi,
>> Thank you for the info.
>>
>> It's ok for the non persistence but with errors at startup [.....
>> -consoleLog -persistState false java.lang.NullPointerException at
>> org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMos
>> tRecentModel(ResourceHandler.java:233) ...... ] and the application
>> shutdown [ java.net.UnknownServiceException: protocol doesn't support
>> output at java.net.URLConnection.getOutputStream(Unknown Source) at
>> org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createOut
>> putStream(URIHandlerImpl.java:137) .......] test with or without
>> deltas.xml.
>>
>> Claude.
>
Re: Workbench Save Restore [message #581609 is a reply to message #557913] Thu, 09 September 2010 12:51 Go to previous message
FAATH  is currently offline FAATH Friend
Messages: 8
Registered: September 2010
Junior Member
I don 't know to file a bug.
I'll post my little application, if it can advance e4 (your email address tutorials.)
Thank you for your information and tutorials
Claude.
Re: Workbench Save Restore [message #581624 is a reply to message #557925] Thu, 09 September 2010 12:55 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
Hi,

I've already found the problem in our code. It is quite obvious from the
exception line you gave me here.

I'll file a bug my own and fix the problem in the code. In the meanwhile
you can use the -clearPersistedState option to clear the restoring (it's
not 100% ideal though because we still collect the deltas for well
nothing but it makes you application behave like you want it to).

Tom

Am 09.09.10 14:51, schrieb FAATH:
> I don 't know to file a bug.
> I'll post my little application, if it can advance e4 (your email
> address tutorials.)
> Thank you for your information and tutorials
> Claude.
Re: Workbench Save Restore [message #581644 is a reply to message #557931] Thu, 09 September 2010 13:30 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5466
Registered: July 2009
Senior Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=324841

Tom

Am 09.09.10 14:55, schrieb Tom Schindl:
> Hi,
>
> I've already found the problem in our code. It is quite obvious from the
> exception line you gave me here.
>
> I'll file a bug my own and fix the problem in the code. In the meanwhile
> you can use the -clearPersistedState option to clear the restoring (it's
> not 100% ideal though because we still collect the deltas for well
> nothing but it makes you application behave like you want it to).
>
> Tom
>
> Am 09.09.10 14:51, schrieb FAATH:
>> I don 't know to file a bug.
>> I'll post my little application, if it can advance e4 (your email
>> address tutorials.)
>> Thank you for your information and tutorials
>> Claude.
>
Previous Topic:Reuse eclipse 3.x views
Next Topic:Confusion about Eclipse 4.0 Application Model
Goto Forum:
  


Current Time: Tue Nov 25 02:08:56 GMT 2014

Powered by FUDForum. Page generated in 0.04409 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software