Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Generators and versions
Generators and versions [message #557002] Fri, 03 September 2010 15:04
Carsten Reckord is currently offline Carsten ReckordFriend
Messages: 139
Registered: July 2009
Senior Member
Hi,

I am experimenting with generator elements in my buckminster components, and so far failing miserably. My goal is to integrate an NSIS
installer build into our existing buckminster RCP build. The installer requires a JRE and my idea was to provide that as a generated
component with a version matching the JRE version, so I can just depend on i.e. com.sun.jre[1.5.0,1.6.0) in my installer component to use
buckminster's resolution mechanism to pick up the best JRE available.

My setup is

com.yattasolutions.umllab.rcp - the product feature containing the feature based product definition and the buckminster RCP build action
com.yattasolutions.umllab.installer - installer build, depends on rcp and com.sun.jre:
<cs:dependencies>
<cs:dependency name="com.yattasolutions.umllab.rcp" componentType="eclipse.feature"/>
<cs:dependency name="com.sun.jre"/>
</cs:dependencies>

com.yattasolutions.releng - buckminster project defining the generators and depending on installer:
<cs:dependencies>
<cs:dependency name="com.yattasolutions.umllab.installer" componentType="buckminster"/>
</cs:dependencies>
<cs:generators>
<cs:generator generates="com.sun.jre" attribute="sun-jre-1.6.0.21-win32-x64" generatesType="unknown" generatesVersion="1.6.0.21"/>
<cs:generator generates="com.sun.jre" attribute="sun-jre-1.5.0.22-win32-x64" generatesType="unknown" generatesVersion="1.5.0.22"/>
</cs:generators>


At first I ran into a bit of trouble with versions in the generators (see bug #323853). I fixed those locally and still couldn't get it
working, so I tried just one generator component and no versions. But still no dice:

Resolving the query for com.yattasolutions.releng gives me "A selected specification is unresolved" and a yellow
com.sun.jre:unknown:generated. The resulting BOM has this:

<md:idwrapper id="92204d8a-3a26-391f-b30a-6d67dfe6a57f">
<md:generatorNode declaringCSpecId="e8d57ac5-ead9-3a1b-9142-2bc3eefd7e18" attribute="sun-jre-1.6.0.21-win32-x64"
generates="com.sun.jre" generatesType="unknown"/>
</md:idwrapper>


Any idea what goes wrong there? Is there maybe a working example out there using generators to look at and experiment with?


Best regards,
Carsten
Previous Topic:Multiphase creation of update site?
Next Topic:Git Branches/Tags
Goto Forum:
  


Current Time: Fri Dec 19 22:59:28 GMT 2014

Powered by FUDForum. Page generated in 0.01637 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software