Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » B3 » multiple versions of a feature could not be mirrored
multiple versions of a feature could not be mirrored [message #555946] Mon, 30 August 2010 11:02 Go to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello,

I would like to mirror the Eclipse RAP Runtime site
(http://download.eclipse.org/rt/rap/1.3/runtime/) using B3 aggregator.

This site contains the feature
"org.eclipse.rap.runtime.sdk.feature.group" in two versions (1.3.0 and
1.3.1) If I use this update site inside an eclipse target platform
definition (".target"-file) I can choose between these two versions.

I created an aggregator model with one contribution containing the rap
repository. Nothing more.

When I run the aggregator with this model I get a new p2 mirror. But
when I try to use this as source inside my .target definition, there is
only version 1.3.1 contained.

I tried to explicit map the two versions by using a custom category, but
there is still only the higher version visible.

Where is my mistake? How can I create a mirror containing both versions
of the feature?

Regards,
Lars
Re: multiple versions of a feature could not be mirrored [message #633500 is a reply to message #555946] Mon, 18 October 2010 09:09 Go to previous messageGo to next message
Lars Fischer is currently offline Lars FischerFriend
Messages: 105
Registered: July 2009
Senior Member
Hello,

On 30.08.2010 13:02, Lars Fischer wrote:
>
> I would like to mirror the Eclipse RAP Runtime site
> (http://download.eclipse.org/rt/rap/1.3/runtime/) using B3 aggregator.
>
> This site contains the feature
> "org.eclipse.rap.runtime.sdk.feature.group" in two versions (1.3.0 and
> 1.3.1) If I use this update site inside an eclipse target platform
> definition (".target"-file) I can choose between these two versions.
>
> I created an aggregator model with one contribution containing the rap
> repository. Nothing more.
>
> When I run the aggregator with this model I get a new p2 mirror. But
> when I try to use this as source inside my .target definition, there is
> only version 1.3.1 contained.
>
> I tried to explicit map the two versions by using a custom category, but
> there is still only the higher version visible.
>
> Where is my mistake? How can I create a mirror containing both versions
> of the feature?

I still would like to see all versions of the features with all needed
bundles in the resulting mirror.

I would be very happy, if someone could please tell me, if this is
possible and how to do this.

Kind regards,
Lars
Re: multiple versions of a feature could not be mirrored [message #658461 is a reply to message #555946] Tue, 08 March 2011 15:36 Go to previous messageGo to next message
Matt Biggs is currently offline Matt BiggsFriend
Messages: 68
Registered: July 2009
Member
I've got the same problem with the orbit repository.

If i add the entire repository, i would expect it to pull down all versions of the plug-ins but instead i only get 1 version.

Eg. if i combine helios site and orbit, org.apache.commons.lang v2.3.0 is pulled down and v2.4.0 is ignored despite it existing on the orbit repository.
Re: multiple versions of a feature could not be mirrored [message #658473 is a reply to message #658461] Tue, 08 March 2011 16:16 Go to previous messageGo to next message
Stephane Bouchet is currently offline Stephane BouchetFriend
Messages: 261
Registered: July 2009
Senior Member
Same problem here, i raised a enhancement request for such a request,
because b3 is only used as an aggregator, not a mirror application

https://bugs.eclipse.org/bugs/show_bug.cgi?id=338409

Le 08/03/2011 16:36, Matt Biggs a écrit :
> I've got the same problem with the orbit repository.
> If i add the entire repository, i would expect it to pull down all
> versions of the plug-ins but instead i only get 1 version.
> Eg. if i combine helios site and orbit, org.apache.commons.lang v2.3.0
> is pulled down and v2.4.0 is ignored despite it existing on the orbit
> repository.
>


--
Cheers,

Stéphane Bouchet, OBEO
Re: multiple versions of a feature could not be mirrored [message #688403 is a reply to message #658473] Fri, 24 June 2011 16:05 Go to previous message
Terran Gilman is currently offline Terran GilmanFriend
Messages: 67
Registered: July 2009
Member
I have the same need.

http://www.eclipse.org/forums/index.php/t/212568/
Previous Topic:Merging two p2 repositories regardless of contents
Next Topic:(no subject)
Goto Forum:
  


Current Time: Sat Nov 22 18:20:12 GMT 2014

Powered by FUDForum. Page generated in 0.03227 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software