Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » The minimum number of the libraries to run the BIRT?
The minimum number of the libraries to run the BIRT? [message #555904] Mon, 30 August 2010 03:41 Go to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 55
Registered: July 2010
Member
Hello,

I'm planning to integrate the BIRT runtime to the production. I want only take the libraries which are necessary to run the BIRT.

Which are the libraries needed from the folder birt-runtime-2_6_0\ReportEngine\lib of the zip birt-runtime-2_6_0.zip to run the BIRT?

When I tested the BIRT with www.eclipse.org/birt/deploy/RunReport.java and XML datasource I used these libraries:

org.apache.commons.codec_1.3.0.v20100518-1140.jar
com.ibm.icu_4.2.1.v20100412.jar
engineapi.jar
js.jar
coreapi.jar

BR,

Mika

[Updated on: Mon, 30 August 2010 03:58]

Report message to a moderator

Re: The minimum number of the libraries to run the BIRT? [message #555960 is a reply to message #555904] Mon, 30 August 2010 07:50 Go to previous messageGo to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 55
Registered: July 2010
Member
Hello,

it seems that the program uses plugins dynamically from the ReportEngine folder.

There is about 150 plugins or jar:s in the runtime BIRT. Are these all needed or is there smaller set of the plugins and jars needed?

BR,

Mika
Re: The minimum number of the libraries to run the BIRT? [message #556066 is a reply to message #555960] Mon, 30 August 2010 13:13 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Mika,

It depends on what your reports will need. For example if you are not
using jdbc datasources those plugins can be removed. If you do not use
charting those plugins can be removed, etc. Right now the runtime
contains all the plugins that implement all runtime functions of BIRT.

Jason

On 8/30/2010 7:50 AM, mika.tapanainen@digia.com wrote:
> Hello,
>
> it seems that the program uses plugins dynamically from the ReportEngine
> folder.
>
> There is about 150 plugins or jar:s in the runtime BIRT. Are these all
> needed or is there smaller set of the plugins and jars needed?
>
> BR,
>
> Mika
Previous Topic:How I can show chart legend series dynamically based on Y series value?
Next Topic:How to get a custom property of a text item in emitter?
Goto Forum:
  


Current Time: Sat Jul 26 03:24:26 EDT 2014

Powered by FUDForum. Page generated in 0.01487 seconds