Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Generate EMF GenModel not working for providerType(I can't generate providerType="Stateful" with @emf.gen annotation)
Generate EMF GenModel not working for providerType [message #555478] Thu, 26 August 2010 17:34 Go to next message
Ken Sayers is currently offline Ken SayersFriend
Messages: 40
Registered: July 2009
Member
Hi,

I am using the wonderful "Generate EMF GenModel" in Eugenia. I have added an annotation like this in hopes of setting the provider type to stateful for the class. It doesn't seem to take though.


@emf.gen(providerType="Stateful")
abstract class ProductEntity {
attr String entityName;
attr String entityId;
}

Ken
Re: Generate EMF GenModel not working for providerType [message #555608 is a reply to message #555478] Fri, 27 August 2010 10:30 Go to previous messageGo to next message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Hi Ken,

It seems that enumeration values are not currently supported in all
@emf.gen annotations - but this should be straightforward to fix. Could
you please file a bug report and send the link here?

Cheers,
Dimitris

Ken Sayers wrote:
> Hi,
>
> I am using the wonderful "Generate EMF GenModel" in Eugenia. I have
> added an annotation like this in hopes of setting the provider type to
> stateful for the class. It doesn't seem to take though.
>
>
> @emf.gen(providerType="Stateful")
> abstract class ProductEntity {
> attr String entityName;
> attr String entityId; }
>
> Ken
Re: Generate EMF GenModel not working for providerType [message #555629 is a reply to message #555608] Fri, 27 August 2010 12:33 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Forgot to mention that in the meantime you can use an EOL polishing
script (Ecore2GenModel.eol file next to your .ecore metamodel) as a
workaround.

Cheers,
Dimitris

Dimitris Kolovos wrote:
> Hi Ken,
>
> It seems that enumeration values are not currently supported in all
> @emf.gen annotations - but this should be straightforward to fix. Could
> you please file a bug report and send the link here?
>
> Cheers,
> Dimitris
>
> Ken Sayers wrote:
>> Hi,
>>
>> I am using the wonderful "Generate EMF GenModel" in Eugenia. I have
>> added an annotation like this in hopes of setting the provider type to
>> stateful for the class. It doesn't seem to take though.
>>
>>
>> @emf.gen(providerType="Stateful")
>> abstract class ProductEntity {
>> attr String entityName;
>> attr String entityId; }
>>
>> Ken
Re: Generate EMF GenModel not working for providerType [message #593293 is a reply to message #555608] Fri, 27 August 2010 12:33 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Forgot to mention that in the meantime you can use an EOL polishing
script (Ecore2GenModel.eol file next to your .ecore metamodel) as a
workaround.

Cheers,
Dimitris

Dimitris Kolovos wrote:
> Hi Ken,
>
> It seems that enumeration values are not currently supported in all
> @emf.gen annotations - but this should be straightforward to fix. Could
> you please file a bug report and send the link here?
>
> Cheers,
> Dimitris
>
> Ken Sayers wrote:
>> Hi,
>>
>> I am using the wonderful "Generate EMF GenModel" in Eugenia. I have
>> added an annotation like this in hopes of setting the provider type to
>> stateful for the class. It doesn't seem to take though.
>>
>>
>> @emf.gen(providerType="Stateful")
>> abstract class ProductEntity {
>> attr String entityName;
>> attr String entityId; }
>>
>> Ken
Previous Topic:Generate EMF GenModel not working for providerType
Next Topic:[EWL] Use data from different
Goto Forum:
  


Current Time: Mon Dec 22 15:44:46 GMT 2014

Powered by FUDForum. Page generated in 0.05420 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software