Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Internal error on startup(Initializing PHP Tooling)
Internal error on startup [message #555443] Thu, 26 August 2010 11:28 Go to next message
Rob B is currently offline Rob B
Messages: 6
Registered: February 2010
Junior Member
Greetings,

I have just updated to 2.2.1.v20100822-1200 PDT when I receive the following error on opening eclipse:

An internal error occurred during: "Initializing PHP Tooling".
org.eclipse.php.internal.core.index.PhpElementResolver.resol ve(IIIIIILjava/lang/String;Ljava/lang/String;Ljava/lang/Stri ng;Ljava/lang/String;Lorg/eclipse/dltk/core/ISourceModule;)L org/eclipse/dltk/core/IModelElement;

Opening a PHP file gives this error:

An internal error occurred during: "Semantic Highlighting Job".
org.eclipse.php.internal.core.index.PhpElementResolver.resol ve(IIIIIILjava/lang/String;Ljava/lang/String;Ljava/lang/Stri ng;Ljava/lang/String;Lorg/eclipse/dltk/core/ISourceModule;)L org/eclipse/dltk/core/IModelElement;

Windows XP
eclipse.buildId=I20100608-0911
java.runtime.version=1.6.0_21-b07

It looks like I will have to revert this installation.

-Rob B
Re: Internal error on startup [message #555449 is a reply to message #555443] Thu, 26 August 2010 12:02 Go to previous message
Rob B is currently offline Rob B
Messages: 6
Registered: February 2010
Junior Member
It appears that I will be unable to revert as I get the following message:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.php, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: org.eclipse.update.feature,org.eclipse.php.all,2.2.0.v201005 19-1400-53-7A51J1WES6MOWsOaXRLXQYez-
No repository found containing: osgi.bundle,org.eclipse.php.debug.core.source,2.2.0.v2010061 7-1400
No repository found containing: org.eclipse.update.feature,org.eclipse.php,2.2.0.v20100519-1 400-7L7J-F8NcJTJKEUF9UcJJ
No repository found containing: org.eclipse.update.feature,org.eclipse.php.sdk,2.2.0.v201005 19-1400-53-84QAN2IGRoLXQNHWPXdyLa9Od
No repository found containing: org.eclipse.update.feature,org.eclipse.php.source,2.2.0.v201 00519-1400-7L7J-F8NcJTJKEUF9UcJJ

Fortunately I have another eclipse install on a separate machine that I can replace this corrupted install.

-Rob B
Previous Topic:PHPUnit + Eclipse Configuration
Next Topic:2.2 Plugin not being loaded
Goto Forum:
  


Current Time: Tue Jul 29 00:46:56 EDT 2014

Powered by FUDForum. Page generated in 0.01809 seconds