Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Helios RPC problem with p2 self-update(in passing a tutorial for learning to add self update feature to RPC application failed and need help)
Helios RPC problem with p2 self-update [message #552968] Sun, 15 August 2010 12:01 Go to next message
Jason  is currently offline Jason
Messages: 2
Registered: August 2010
Junior Member
Hi,
I'm new to RPC, and just finished some tutorials, turned to self-update feature concept. To learn it, I picked up this tutorial:
http://swtxml.com/blog/eclipsercp/p2_updates_tutorial/

Up to the 10th step, everything is ok. I exported the application as of th 10th step and run with no problem.

Next I added the "org.eclipse.equinox.p2.user.ui" to my included features as instructed. I've got the following error. Also, no menu item is added in the help menu for update checking and new software install.

If I export the application after adding p2.ui I get this error and exporting fails:
http://www.imagehousing.com/image/529248

For around 2 days I added various boundles to solve this, but no results. I searched forums and googled and found people with the same problem, but failed to find any solution.

Please kindly guide me out of it.


Error Messages:

!SESSION 2010-08-15 14:45:14.270 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product com.example.mail.product
Command-line arguments:  -product com.example.mail.product -data C:\zworkspace/../runtime-mail.product -dev file:C:/zworkspace/.metadata/.plugins/org.eclipse.pde.core/mail.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.osgi 2 0 2010-08-15 14:45:20.036
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-08-15 14:45:20.036
!MESSAGE Bundle reference:file:/C:/zworkspace/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.equinox.p2.ui.sdk_1.0.100.v20100513.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2010-08-15 14:45:20.036
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2010-08-15 14:45:20.036
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-08-15 14:45:20.036
!MESSAGE Bundle org.eclipse.equinox.p2.ui.sdk_1.0.100.v20100513 [125] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2010-08-15 14:45:20.036
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.

Re: Helios RPC problem with p2 self-update [message #553084 is a reply to message #552968] Mon, 16 August 2010 12:15 Go to previous messageGo to next message
karthikeyan  is currently offline karthikeyan
Messages: 6
Registered: July 2009
Junior Member
Hi Jason

I tryed the same tutorial for the self-update its working find... can you kindly check with your eclipse version...

Create a simple Hello World Rcp application and try to export as a product and check it wheather its working or not...

Download the eclipse for eclipse.org....


Thanks and Regards
Karthikeyan
ANCiT Consulting
www.ancitconsulting.com
Re: Helios RPC problem with p2 self-update [message #555610 is a reply to message #553084] Fri, 27 August 2010 10:51 Go to previous messageGo to next message
Jack Mising name is currently offline Jack Mising name
Messages: 16
Registered: August 2010
Junior Member
I am suffering from exactly the same problem and have spent several days trying different things and searching Google.

I have downloaded a fresh install of eclipse from eclipse.org : eclipse-rcp-helios-linux-gtk-x86_64.tar.gz

With a clean install and a new workspace, I get the following :-

!SESSION 2010-08-27 11:47:31.101 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Framework arguments:  -product com.example.mail.product
Command-line arguments:  -product com.example.mail.product -data /home/likewise-open/SAPPHIREAD/daves/workspace.temp/../runtime-mail.product -dev file:/home/likewise-open/SAPPHIREAD/daves/workspace.temp/.metadata/.plugins/org.eclipse.pde.core/mail.product/dev.properties -os linux -ws gtk -arch x86_64 -consoleLog

!ENTRY org.eclipse.osgi 2 0 2010-08-27 11:47:32.958
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-08-27 11:47:32.959
!MESSAGE Bundle reference:file:/home/likewise-open/SAPPHIREAD/daves/eclipse/plugins/org.eclipse.equinox.p2.ui.sdk_1.0.100.v20100513.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2010-08-27 11:47:32.960
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2010-08-27 11:47:32.973
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-08-27 11:47:32.974
!MESSAGE Bundle org.eclipse.equinox.p2.ui.sdk_1.0.100.v20100513 [68] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.ui.sdk 2 0 2010-08-27 11:47:32.975
!MESSAGE Missing required bundle org.eclipse.compare_0.0.0.


I really can't see what I am doing wrong. Can you enlighten me at all please?

TIA
Re: Helios RPC problem with p2 self-update [message #555676 is a reply to message #555610] Fri, 27 August 2010 14:50 Go to previous messageGo to next message
Jack Mising name is currently offline Jack Mising name
Messages: 16
Registered: August 2010
Junior Member
I'm making progress! Smile

Some have reported success by adding org.eclipse.compare as a dependency of the com.example.mail plugin.

I tried this and refreshed the active plugins in the launch configuration and it works!
Once I did this and a synchronisation of the product and it exports successfully!

I am pretty sure I had already tried this with my real application with no joy so YMMV.
icon11.gif  Re: Helios RPC problem with p2 self-update [message #556286 is a reply to message #555676] Tue, 31 August 2010 15:35 Go to previous messageGo to next message
Jack Mising name is currently offline Jack Mising name
Messages: 16
Registered: August 2010
Junior Member
This is getting annoying now.

The same trick does not work for my real application - I end up in dependency hell with the thing seeming to require just about everything (right down to org.eclipse.ide, before I gave up) to be explicitly packaged with my main plugin.

The mail demo (no changes since last export) now moans about not being able to resolve org.eclipse.editors.ui.

Any ideas what is going on here?
Re: Helios RPC problem with p2 self-update [message #557645 is a reply to message #556286] Wed, 08 September 2010 11:58 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

I would try the eclipse.technology.equinox newsgroup/forum. I guess
what you're trying to do is to take a simple RCP app and add p2 updating
(including the Add New Software menu items and UI)?


http://help.eclipse.org/helios/index.jsp?topic=/org.eclipse. platform.doc.isv/guide/p2_uireuse.htm

PW


--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Re: Helios RPC problem with p2 self-update [message #557657 is a reply to message #557645] Wed, 08 September 2010 12:59 Go to previous message
Jack Mising name is currently offline Jack Mising name
Messages: 16
Registered: August 2010
Junior Member
Thanks for the response. You have it exactly right.

The problem was tracked down to the fact that org.eclipse.equinox.p2.user.ui depends on org.eclipse.equinox.p2.ui.sdk which in turn depends on org.eclipse.compare which pulls in a lot of the IDE UI.

The compare dependency is to deal with the ability to roll-back to a previous configuration / installed plug-in set.

I can't find where it was mentioned, but apparently there are plans for a simplified package for a future release that will do p2 updates in the light-weight 'drop-in' fashion that is implied by the various tutorials about the subject.

As it is, my project is just for an internal group of bright peeps who can handle a bit of UI cruft, so it doesn't really cause us a problem now that I know what is going on.

[Updated on: Wed, 08 September 2010 12:59]

Report message to a moderator

Previous Topic:Autocomplete in text field.
Next Topic:Creating a Multi-Page Editor with HTML preview
Goto Forum:
  


Current Time: Sun Sep 21 12:17:13 GMT 2014

Powered by FUDForum. Page generated in 0.02269 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software