Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Eclipse Virgo tools installation
Eclipse Virgo tools installation [message #551192] Thu, 05 August 2010 14:42 Go to next message
Edwin Park is currently offline Edwin ParkFriend
Messages: 124
Registered: July 2009
Senior Member
I'm trying to use Virgo but am finding problems in following the documentation at http://www.eclipse.org/virgo/documentation/ :

The instructions for installing the Eclipse Virgo development tools don't seem to work. The update sites referred to in the documentation are either empty or don't seem to contain virgo bits:

* http://www.eclipse.org/virgo/documentation/virgo-documentati on-2.1.0.M02-incubation/docs/virgo-programmer-guide/html/ch0 7.html#tooling-installation refers to http://static.springsource.com/projects/sts-dm-server/update / which doesn't seem to have any Virgo features
* http://www.eclipse.org/virgo/documentation/virgo-documentati on-2.1.0.M02-incubation/docs/virgo-getting-started/html/ch02 s03.html refers to http://www.springsource.com/snapshot/e3.5, which is empty

So when I open Window → Show View → Other → Server → Servers and do New → Server, there is no EclipseRT group or Virgo Web Server option.

Edwin
Re: Eclipse Virgo tools installation [message #551304 is a reply to message #551192] Thu, 05 August 2010 20:26 Go to previous messageGo to next message
Edwin Park is currently offline Edwin ParkFriend
Messages: 124
Registered: July 2009
Senior Member
I got it working - I did some URL guessing and found the updated SpringSource dm Server Tools with the Virgo bits at http://www.springsource.com/milestone/e3.5
Re: Eclipse Virgo tools installation [message #552034 is a reply to message #551304] Tue, 10 August 2010 15:16 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

Thanks for pointing this out. I have looked in to it and will update the documentation. I need to check and get clarification from the tools team but from the looks of it you have got it right.

Thanks, Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Eclipse Virgo tools installation [message #552080 is a reply to message #551192] Tue, 10 August 2010 18:01 Go to previous messageGo to next message
Tim Goeke is currently offline Tim GoekeFriend
Messages: 15
Registered: July 2010
Junior Member
For STS 2.3.2 M2, I am using:

http://www.springsource.com/milestone/e3.6
Re: Eclipse Virgo tools installation [message #552179 is a reply to message #552080] Wed, 11 August 2010 07:49 Go to previous messageGo to next message
Steve PowellFriend
Messages: 23
Registered: January 2010
Location: Southampton
Junior Member
Now that's interesting -- STS 2.3.2.M2 is based on Eclipse 3.5.2, so one would expect .../e3.6 updates to have potential difficulties.

STS 2.3.3.M2 comes in versions based on Eclipse 3.5.2 or Eclipse 3.6, so I would expect ...../e3.n update sites to match.

However, Chris will get a definitive answer soon.


Steve Powell :-/
Re: Eclipse Virgo tools installation [message #552300 is a reply to message #552179] Wed, 11 August 2010 15:50 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Steve is right, I have no idea what is going to happen when you use tools for one version of Eclipse on another. 2.3.2.x is entirely on Eclipse 3.5 while the 2.3.3.x versions of STS are available for both 3.5 and 3.6. I'm still waiting for clarification from the tools team. I believe once 2.3.3 is out you should use http://dist.springsource.com/release/TOOLS/update/e3.6/ but until then or the tools team gets back to me we will have to stick to milestone site mentioned earlier.

Roll on 2.3.3


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Eclipse Virgo tools installation [message #552355 is a reply to message #552300] Wed, 11 August 2010 20:42 Go to previous messageGo to next message
Tim Goeke is currently offline Tim GoekeFriend
Messages: 15
Registered: July 2010
Junior Member
I'm very sorry, that was a typo. I am using 2.3.3 M2 with the 3.6 update site.
Re: Eclipse Virgo tools installation [message #555677 is a reply to message #551192] Fri, 27 August 2010 15:11 Go to previous messageGo to next message
Alastair Brayne is currently offline Alastair BrayneFriend
Messages: 2
Registered: August 2010
Junior Member
Any other suggestions on this?

I'm working with a clean install of the SpringSource Tool Suite eclipse version (3.5 under the hood) and I cannot get this to work. I'm failing on the integration of a Virgo server as well. I've tried clean installs (including cleaning out workspace metadata and ~/.eclipse/ settings) with variations on a theme of every link on this page and the original tutorials linked and ... nada.

Does anyone know where the virgo-enabling plugin lives right now? Or, has it been superceded?

Many thanks
Alastair
Re: Eclipse Virgo tools installation [message #556187 is a reply to message #555677] Tue, 31 August 2010 08:53 Go to previous messageGo to next message
Steve PowellFriend
Messages: 23
Registered: January 2010
Location: Southampton
Junior Member
This is the only information we have:
----
Update Sites
The following update site should work with Eclipse 3.5 and 3.6

Composite Update Site containing Spring IDE, dm Server Tools and SpringSource Tool Suite:

Release: http://dist.springsource.com/release/TOOLS/update/e3.5/ | http://dist.springsource.com/release/TOOLS/update/e3.6/ (not yet, will come soon)
Milestone http://dist.springsource.com/milestone/TOOLS/update/e3.5/ | http://dist.springsource.com/milestone/TOOLS/update/e3.6/
Nightly http://dist.springsource.com/snapshot/TOOLS/nightly/e3.5/ | http://dist.springsource.com/snapshot/TOOLS/nightly/e3.6/
Nightly Snapshot Update Sites per project/product:

Spring IDE: http://dist.springframework.org/snapshot/IDE/nightly
dm Server Tools: http://dist.springsource.com/snapshot/DMS-TOOLS/nightly
SpringSource Tool Suite: http://dist.springsource.com/snapshot/STS/nightly/e3.5
----
I suggest you try the release/TOOLS/update/e3.5 update site if the base installation doesn't work for you.
----
If you continue to have problems you can raise a problem on the STS jira, or if you put the information here, we would appreciate the exact download of the STS tools that you are using, and the platform you are running on.
Thank you.


Steve Powell :-/
Re: Eclipse Virgo tools installation [message #600916 is a reply to message #551304] Tue, 10 August 2010 15:16 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

Thanks for pointing this out. I have looked in to it and will update the documentation. I need to check and get clarification from the tools team but from the looks of it you have got it right.

Thanks, Chris.
--
------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Eclipse Virgo tools installation [message #606820 is a reply to message #552080] Wed, 11 August 2010 07:49 Go to previous messageGo to next message
Steve PowellFriend
Messages: 23
Registered: January 2010
Location: Southampton
Junior Member
Now that's interesting -- STS 2.3.2.M2 is based on Eclipse 3.5.2, so one would expect .../e3.6 updates to have potential difficulties.

STS 2.3.3.M2 comes in versions based on Eclipse 3.5.2 or Eclipse 3.6, so I would expect ...../e3.n update sites to match.

However, Chris will get a definitive answer soon.
--
Steve Powell :-/


Steve Powell :-/
Re: Eclipse Virgo tools installation [message #606835 is a reply to message #606820] Wed, 11 August 2010 15:50 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Steve is right, I have no idea what is going to happen when you use tools for one version of Eclipse on another. 2.3.2.x is entirely on Eclipse 3.5 while the 2.3.3.x versions of STS are available for both 3.5 and 3.6. I'm still waiting for clarification from the tools team. I believe once 2.3.3 is out you should use http://dist.springsource.com/release/TOOLS/update/e3.6/ but until then or the tools team gets back to me we will have to stick to milestone site mentioned earlier.

Roll on 2.3.3
--
------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Eclipse Virgo tools installation [message #607499 is a reply to message #606835] Wed, 11 August 2010 20:42 Go to previous messageGo to next message
Tim Goeke is currently offline Tim GoekeFriend
Messages: 15
Registered: July 2010
Junior Member
I'm very sorry, that was a typo. I am using 2.3.3 M2 with the 3.6 update site.
Re: Eclipse Virgo tools installation [message #638193 is a reply to message #551192] Wed, 10 November 2010 12:04 Go to previous message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

Virgo 2.1.0.RELEASE and STS 2.5.0.RELEASE are both out now. It is all working with either the STS release or the http://dist.springsource.com/release/TOOLS/release/e3.6/ update site.

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Previous Topic:HttpServletRequest.getRealPath() broken in Virgo?
Next Topic:Build RAP with Virgo
Goto Forum:
  


Current Time: Sun Nov 23 07:34:56 GMT 2014

Powered by FUDForum. Page generated in 0.02211 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software