Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Simultaneous release » error updating Ganymede to Galileo
error updating Ganymede to Galileo [message #4940] Wed, 24 June 2009 12:08 Go to next message
Alex Farberov is currently offline Alex Farberov
Messages: 13
Registered: July 2009
Junior Member
Hello

I'm trying to update eclipse Ganymede to Galileo.
I added http://download.eclipse.org/releases/galileo to the update sites.
Eclipse recognizes the updates and tries to dl/install them but
encounters the following error:


An error occurred while collecting items to be installed
No repository found containing: com.ibm.icu/osgi.bundle/4.0.1.v20090415
No repository found containing:
com.jcraft.jsch/osgi.bundle/0.1.41.v200903070017
No repository found containing: javax.xml/osgi.bundle/1.3.4.v200902170245
No repository found containing:
org.apache.ant/osgi.bundle/1.7.1.v20090120-1145
No repository found containing:
org.apache.jasper/osgi.bundle/5.5.17.v200903231320
No repository found containing:
org.apache.xerces/osgi.bundle/2.9.0.v200909240008
No repository found containing:
org.apache.xml.resolver/osgi.bundle/1.2.0.v200902170519
No repository found containing:
org.apache.xml.serializer/osgi.bundle/2.7.1.v200902170519
No repository found containing:
org.eclipse.ant.core/osgi.bundle/3.2.100.v20090520
No repository found containing:
org.eclipse.ant.ui/osgi.bundle/3.4.0.v20090520
Error closing the output stream for
org.eclipse.cdt.gnu.build/org.eclipse.update.feature/6.0.0.2 00906161748
on repository file:/scream/home/farbea2/tools/eclipse/.
Error unzipping
/tmp/org.eclipse.cdt.gnu.build_6.0.0.20090616174813150227528 71639845.jar:
Invalid zip file format
No repository found containing:
org.eclipse.compare/osgi.bundle/3.5.0.I20090514-0808
No repository found containing:
org.eclipse.core.commands/osgi.bundle/3.5.0.I20090525-2000
No repository found containing:
org.eclipse.core.contenttype/osgi.bundle/3.4.0.v20090429-180 0
No repository found containing:
org.eclipse.core.databinding/osgi.bundle/1.2.0.I20090604-200 0
No repository found containing:
org.eclipse.core.databinding.beans/osgi.bundle/1.2.0.I200905 25-2000
No repository found containing:
org.eclipse.core.expressions/osgi.bundle/3.4.100.v20090429-1 800
No repository found containing:
org.eclipse.core.filebuffers/osgi.bundle/3.5.0.v20090526-200 0
No repository found containing:
org.eclipse.core.filesystem/osgi.bundle/1.2.0.v20090507
No repository found containing:
org.eclipse.core.jobs/osgi.bundle/3.4.100.v20090429-1800
No repository found containing:
org.eclipse.core.net/osgi.bundle/1.2.0.I20090522-1010
No repository found containing:
org.eclipse.core.net.linux.x86/osgi.bundle/1.1.0.I20081021
No repository found containing:
org.eclipse.core.resources/osgi.bundle/3.5.0.v20090512
No repository found containing:
org.eclipse.core.resources.compatibility/osgi.bundle/3.4.0.v 20090505
No repository found containing:
org.eclipse.core.runtime/osgi.bundle/3.5.0.v20090525
No repository found containing:
org.eclipse.core.runtime.compatibility/osgi.bundle/3.2.0.v20 090413
No repository found containing:
org.eclipse.core.runtime.compatibility.auth/osgi.bundle/3.2. 100.v20090413
No repository found containing:
org.eclipse.core.runtime.compatibility.registry/osgi.bundle/ 3.2.200.v20090429-1800
No repository found containing:
org.eclipse.core.variables/osgi.bundle/3.2.200.v20090521
No repository found containing:
org.eclipse.cvs/osgi.bundle/1.0.300.v200906051444
No repository found containing:
org.eclipse.debug.core/osgi.bundle/3.5.0.v20090526-1600
No repository found containing:
org.eclipse.debug.ui/osgi.bundle/3.5.0.v20090603
No repository found containing:
org.eclipse.draw2d/osgi.bundle/3.5.0.v20090528-1511
No repository found containing:
org.eclipse.ecf/osgi.bundle/3.0.0.v20090604-1131
No repository found containing:
org.eclipse.ecf.filetransfer/osgi.bundle/3.0.0.v20090604-113 1
No repository found containing:
org.eclipse.ecf.identity/osgi.bundle/3.0.0.v20090604-1131
No repository found containing:
org.eclipse.ecf.provider.filetransfer/osgi.bundle/3.0.0.v200 90604-1131
No repository found containing:
org.eclipse.ecf.provider.filetransfer.ssl/osgi.bundle/1.0.0. v20090604-1131
No repository found containing:
org.eclipse.ecf.ssl/osgi.bundle/1.0.0.v20090604-1131
No repository found containing:
org.eclipse.emf.common/osgi.bundle/2.5.0.v200906080927
No repository found containing:
org.eclipse.emf.common.ui/osgi.bundle/2.5.0.v200906080927
No ruinox.p2.ui.sdk/osgi.bundle/1.0.100.v20090520-1905
No repository found containing:
org.eclipse.equinox.p2.updatechecker/osgi.bundle/1.1.0.v2009 0520-1905
No repository found containing:
org.eclipse.equinox.p2.updatesite/osgi.bundle/1.0.100.v20090 525
No repository found containing:
org.eclipse.equinox.preferences/osgi.bundle/3.2.300.v2009052 0-1800
No repository found containing:
org.eclipse.equinox.registry/osgi.bundle/3.4.100.v20090520-1 800
No repository found containing:
org.eclipse.equinox.security/osgi.bundle/1.0.100.v20090520-1 800
No repository found containing:
org.eclipse.equinox.security.ui/osgi.bundle/1.0.100.v2009052 0-1800
No repository found containing:
org.eclipse.equinox.simpleconfigurator/osgi.bundle/1.0.100.v 20090520-1905
No repository found containing:
org.eclipse.equinox.simpleconfigurator.manipulator/osgi.bund le/1.0.100.v20090520-1905
No repository found containing:
org.eclipse.gef/osgi.bundle/3.5.0.v20090528-1511
No repository found containing:
org.eclipse.help/osgi.bundle/3.4.0.v20090526
No repository found containing:
org.eclipse.help.appserver/osgi.bundle/3.1.400.v20090429_180 0
No repository found containing:
org.eclipse.help.base/osgi.bundle/3.4.0.v200906051444
No repository found containing:
org.eclipse.help.ui/osgi.bundle/3.4.0.v20090528
No repository found containing:
org.eclipse.help.webapp/osgi.bundle/3.4.0.v20090429_1800
No repository found containing:
org.eclipse.jdt/osgi.bundle/3.5.0.v200906051444
No repository found containing:
org.eclipse.jdt.apt.core/osgi.bundle/3.3.200.v20090528-1135
No repository found containing:
org.eclipse.jdt.apt.pluggable.core/osgi.bundle/1.0.200.v2009 0526-2130
No repository found containing:
org.eclipse.jdt.apt.ui/osgi.bundle/3.3.200.v20090528-1135
No repository found containing:
org.eclipse.jdt.compiler.apt/osgi.bundle/1.0.200.v20090528-1 135
No repository found containing:
org.eclipse.jdt.compiler.tool/osgi.bundle/1.0.100.v_963
No repository found containing:
org.eclipse.jdt.core/osgi.bundle/3.5.0.v_963
No repository found containing:
org.eclipse.jdt.core.manipulation/osgi.bundle/1.3.0.v2009060 3
No repository found containing:
org.eclipse.jdt.debug/osgi.bundle/3.5.0.v20090526
No repository found containing:
org.eclipse.jdt.debug.ui/osgi.bundle/3.4.0.v20090527
No repository found containing:
org.eclipse.jdt.doc.user/osgi.bundle/3.5.0.v20090603-1530
No repository found containing:
org.eclipse.jdt.junit/osgi.bundle/3.5.0.v20090526-2000
No repository found containing:
org.eclipse.jdt.junit.runtime/osgi.bundle/3.4.100.v20090513- 2000
No repository found containing:
org.eclipse.jdt.junit4.runtime/osgi.bundle/1.1.0.v20090513-2 000
No repository found containing:
org.eclipse.jdt.launching/osgi.bundle/3.5.0.v20090527
No repository found containing:
org.eclipse.jdt.ui/osgi.bundle/3.5.0.v20090604
No repository found containing:
org.eclipse.jem.util/osgi.bundle/2.0.200.v200905140200
No repository found containing:
org.eclipse.jface/osgi.bundle/3.5.0.I20090525-2000
No repository found containing:
org.eclipse.jface.databinding/osgi.bundle/1.3.0.I20090525-20 00
No repository found containing:
org.eclipse.jface.text/osgi.bundle/3.5.0.v20090602
No repository found containing:
org.eclipse.jsch.core/osgi.bundle/1.1.100.I20090430-0408
No repository found containing:
org.eclipse.jsch.ui/osgi.bundle/1.1.200.I20090430-0408
No repository found containing:
org.eclipse.ltk.core.refactoring/osgi.bundle/3.5.0.v20090513 -2000
No repository found containing:
org.eclipse.ltk.ui.refactoring/osgi.bundle/3.4.100.v20090604
No repository found containing:
org.eclipse.osgi/osgi.bundle/3.5.0.v20090520
No repository found containing:
org.eclipse.osgi.services/osgi.bundle/3.2.0.v20090520-1800
No repository found containing:
org.eclipse.osgi.util/osgi.bundle/3.2.0.v20090520-1800
No repository found containing:
org.eclipse.platform/osgi.bundle/3.3.200.v200906051444
No repository found containing:
org.eclipse.platform.doc.user/osgi.bundle/3.5.0.v20090604-20 00
No repository found containing:
org.eclipse.rcp/osgi.bundle/3.5.0.v200906051444
No repository found containing:
org.eclipse.search/osgi.bundle/3.5.0.v20090526-2000
No repository found containing: org.eclipse.swt/osgi.bundle/3.5.0.v3550a
No repository found containing:
org.eclipse.swt.gtk.linux.x86/osgi.bundle/3.5.0.v3550a
No repository found containing:
org.eclipse.team.core/osgi.bundle/3.5.0.I20090527-0620
No repository found containing:
org.eclipse.team.cvs.core/osgi.bundle/3.3.200.I20090430-0408
No repository found containing:
org.eclipse.team.cvs.ssh2/osgi.bundle/3.2.200.I20090508-2000
No repository found containing:
org.eclipse.team.cvs.ui/osgi.bundle/3.3.200.I20090521-1750
No repository found containing:
org.eclipse.team.ui/osgi.bundle/3.5.0.I20090430-0408
No repository found containing:
org.eclipse.text/osgi.bundle/3.5.0.v20090513-2000
No repository found containing:
org.eclipse.ui/osgi.bundle/3.5.0.I20090604-2000
No repository found containing:
org.eclipse.ui.browser/osgi.bundle/3.2.300.v20090526
No repository found containing:
org.eclipse.ui.cheatsheets/osgi.bundle/3.3.200.v20090526
No repository found containing:
org.eclipse.ui.console/osgi.bundle/3.4.0.v20090513
No repository found containing:
org.eclipse.ui.editors/osgi.bundle/3.5.0.v20090527-2000
No repository found containing:
org.eclipse.ui.externaltools/osgi.bundle/3.2.0.v20090504
No repository found containing:
org.eclipse.ui.forms/osgi.bundle/3.4.0.v20090526
No repository found containing:
org.eclipse.ui.ide/osgi.bundle/3.5.0.I20090525-2000
No repository found containing:
org.eclipse.ui.ide.application/osgi.bundle/1.0.100.I20090525 -2000
No repository found containing:
org.eclipse.ui.intro/osgi.bundle/3.3.0.v20090526
No repository found containing:
org.eclipse.ui.intro.universal/osgi.bundle/3.2.300.v20090526
No repository found containing:
org.eclipse.ui.navigator/osgi.bundle/3.4.0.I20090525-2000
No repository found containing:
org.eclipse.ui.navigator.resources/osgi.bundle/3.4.0.I200905 25-2000
No repository found containing:
org.eclipse.ui.net/osgi.bundle/1.2.0.I20090430-0408
No repository found containing:
org.eclipse.ui.presentations.r21/osgi.bundle/3.2.100.I200810 07-0800
No repository found containing:
org.eclipse.ui.views/osgi.bundle/3.4.0.I20090525-2000
No repository found containing:
org.eclipse.ui.views.log/osgi.bundle/1.0.100.v20090527
No repository found containing:
org.eclipse.ui.views.properties.tabbed/osgi.bundle/3.5.0.I20 090429-1800
No repository found containing:
org.eclipse.ui.workbench/osgi.bundle/3.5.0.I20090603-2000
No repository found containing:
org.eclipse.ui.workbench.compatibility/osgi.bundle/3.2.0.I20 090429-1800
No repository found containing:
org.eclipse.ui.workbench.texteditor/osgi.bundle/3.5.0.v20090 603
No repository found containing:
org.eclipse.update.configurator/osgi.bundle/3.3.0.v20090312
No repository found containing:
org.eclipse.update.core/osgi.bundle/3.2.300.v20090525
No repository found containing:
org.eclipse.update.core.linux/osgi.bundle/3.2.100.v20081008
No repository found containing:
org.eclipse.update.scheduler/osgi.bundle/3.2.200.v20081127
No repository found containing:
org.eclipse.update.ui/osgi.bundle/3.2.200.v20090213
No repository found containing:
org.eclipse.wst.common.emf/osgi.bundle/1.1.300.v200905060430
No repository found containing:
org.eclipse.wst.common.emfworkbench.integration/osgi.bundle/ 1.1.300.v200811200330
No repository found containing:
org.eclipse.wst.common.frameworks/osgi.bundle/1.1.300.v20090 4160730
No repository found containing:
org.eclipse.wst.common.frameworks.ui/osgi.bundle/1.1.300.v20 0904160730
No repository found containing:
org.eclipse.wst.common.modulecore/osgi.bundle/1.1.300.v20090 4132230
No repository found containing:
org.eclipse.wst.common.project.facet.core/osgi.bundle/1.4.0. v200906080535
No repository found containing:
org.eclipse.wst.common.snippets/osgi.bundle/1.1.300.v2009031 20643
No repository found containing:
org.eclipse.wst.common.ui/osgi.bundle/1.1.402.v200901262305
No repository found containing:
org.eclipse.wst.common_core.feature/org.eclipse.update.featu re/3.1.0.v200903021835-7B77FXTF7RZHITIwQkLs_V
No repository found containing:
org.eclipse.wst.common_ui.feature/org.eclipse.update.feature /3.1.0.v200903021835-7B5FREDhdMNPm7dkmBmpUJxRlMta
No repository found containing:
org.eclipse.wst.dtd.core/osgi.bundle/1.1.300.v200904181727
No repository found containing:
org.eclipse.wst.dtd.ui/osgi.bundle/1.0.400.v200904300717
No repository found containing:
org.eclipse.wst.dtdeditor.doc.user/osgi.bundle/1.0.500.v2009 04292308
No repository found containing:
org.eclipse.wst.sse.core/osgi.bundle/1.1.400.v200905141750
No repository found containing:
org.eclipse.wst.sse.ui/osgi.bundle/1.1.100.v200905141750
No repository found containing:
org.eclipse.wst.standard.schemas/osgi.bundle/1.0.200.v200902 270215
No repository found containing:
org.eclipse.wst.validation/osgi.bundle/1.2.102.v200905201610
No repository found containing:
org.eclipse.wst.validation.ui/osgi.bundle/1.2.104.v200904232 035
No repository found containing:
org.eclipse.wst.xml.core/osgi.bundle/1.1.400.v200904300540
No repository found containing:
org.eclipse.wst.xml.ui/osgi.bundle/1.1.0.v200905242047
No repository found containing:
org.eclipse.wst.xml_core.feature/org.eclipse.update.feature/ 3.1.0.v200901260254-7C7OFPeF7RZHIXHnTz0Jqc0
No repository found containing:
org.eclipse.wst.xml_ui.feature/org.eclipse.update.feature/3. 1.0.v200905240756-7H6FMVDxtkM-5OgPGKK4xQocS5AL
No repository found containing:
org.eclipse.wst.xml_userdoc.feature/org.eclipse.update.featu re/3.1.1.v200906020459-50FR7AkF77f7MESDKEF
No repository found containing:
org.eclipse.wst.xmleditor.doc.user/osgi.bundle/1.0.600.v2009 01231300
No repository found containing:
org.eclipse.wst.xsd.core/osgi.bundle/1.1.401.v200903020335
No repository found containing:
org.eclipse.wst.xsd.ui/osgi.bundle/1.2.203.v200904300717
No repository found containing:
org.eclipse.wst.xsdeditor.doc.user/osgi.bundle/1.0.700.v2009 05182240
No repository found containing:
org.eclipse.xsd/osgi.bundle/2.5.0.v200906080927
No repository found containing:
org.eclipse.xsd.edit/osgi.bundle/2.5.0.v200906080927
No repository found containing:
org.junit/osgi.bundle/3.8.2.v20090203-1005
No repository found containing: org.junit4/osgi.bundle/4.5.0.v20090423
No repository found containing:
org.sat4j.core/osgi.bundle/2.1.0.v20090520
No repository found containing: org.sat4j.pb/osgi.bundle/2.1.0.v20090520
No repository found containing:
org.eclipse.compare.core/osgi.bundle/3.5.0.I20090430-0408
No repository found containing:
org.eclipse.core.databinding.observable/osgi.bundle/1.2.0.I2 0090604-2000
No repository found containing:
org.eclipse.core.databinding.property/osgi.bundle/1.2.0.I200 90526-2000
No repository found containing:
org.eclipse.cvs/org.eclipse.update.feature/1.1.100.v20090514 -7E79FEc9BJ99r9YEV6IOIF
No repository found containing:
org.eclipse.cvs_root/binary/1.1.100.v20090514-7E79FEc9BJ99r9 YEV6IOIF
No repository found containing:
org.eclipse.ecf.provider.filetransfer.httpclient/osgi.bundle /3.0.0.v20090604-1131
No repository found containing:
org.eclipse.ecf.provider.filetransfer.httpclient.ssl/osgi.bu ndle/1.0.0.v20090604-1131
No repository found containing:
org.eclipse.equinox.concurrent/osgi.bundle/1.0.0.v20090520-1 800
No repository found containing:
org.eclipse.equinox.ds/osgi.bundle/1.1.0.v20090601
No repository found containing:
org.eclipse.equinox.p2.publisher/osgi.bundle/1.0.0.v20090527 -1812
No repository found containing:
org.eclipse.equinox.p2.repository/osgi.bundle/1.0.0.v2009060 1-1921
No repository found containing:
org.eclipse.equinox.p2.repository.tools/osgi.bundle/1.0.0.v2 0090527-1812
No repository found containing:
org.eclipse.equinox.p2.ui.sdk.scheduler/osgi.bundle/1.0.0.v2 0090520-1905
No repository found containing:
org.eclipse.equinox.p2.user.ui/org.eclipse.update.feature/1. 1.0.v20090605-1440-7u6Fb3FbPbJP5MiKiZgpdl
No repository found containing:
org.eclipse.equinox.util/osgi.bundle/1.0.100.v20090520-1800
No repository found containing:
org.eclipse.help/org.eclipse.update.feature/1.1.0.v20090602- 7e7eFAlFEx2XZoYqvM67e6F
No repository found containing:
org.eclipse.jdt/org.eclipse.update.feature/3.5.0.v20090527-2 000-7r88FEeFJePyvYeA27DiZdc1
No repository found containing:
org.eclipse.jdt_root/binary/3.5.0.v20090527-2000-7r88FEeFJeP yvYeA27DiZdc1
No repository found containing:
org.eclipse.platform/org.eclipse.update.feature/3.5.0.v20090 605-9gEeG1HFtQcmRThO2V4dTfhVTK1JW1-J
No repository found containing:
org.eclipse.platform_root/binary/3.5.0.v20090605-9gEeG1HFtQc mRThO2V4dTfhVTK1JW1-J
No repository found containing:
org.eclipse.rcp.configuration_root.gtk.linux.x86/binary/1.0. 0.I20090605-1444
No repository found containing:
org.eclipse.rcp/org.eclipse.update.feature/3.5.0.v20090519-9 SA0FwxFv6x089BEe3TVh51
No repository found containing:
org.eclipse.rcp_root/binary/3.5.0.v20090519-9SA0FwxFv6x089BE e3TVh51
No repository found containing:
org.eclipse.team.cvs.ssh/osgi.bundle/3.2.100.I20090508-2000
No repository found containing:
org.hamcrest.core/osgi.bundle/1.1.0.v20090501071000
No repository found containing:
org.mortbay.jetty.server/osgi.bundle/6.1.15.v200905151201
No repository found containing:
org.mortbay.jetty.util/osgi.bundle/6.1.15.v200905182336
Re: error updating Ganymede to Galileo [message #5013 is a reply to message #4940] Wed, 24 June 2009 23:32 Go to previous messageGo to next message
Eclipse User
Originally posted by: david_williams.linux.vnet.ibm.com

Alex Farberov wrote:
> Hello
>
> I'm trying to update eclipse Ganymede to Galileo.
> I added http://download.eclipse.org/releases/galileo to the update sites.
> Eclipse recognizes the updates and tries to dl/install them but
> encounters the following error:
>
>
> An error occurred while collecting items to be installed
> No repository found containing: com.ibm.icu/osgi.bundle/4.0.1.v20090415
> [ ... and many many more ... ]
That long list of errors does seem odd ... and not really sure what that
is from .... may have been a timing issue with the system a little
overloaded today.

BUT, upgrading from Ganymede to Galileo is not supported. You should
start off with one of the main packages found at
http://www.eclipse.org/downloads/ and then install other items into that
install.
Re: error updating Ganymede to Galileo [message #5076 is a reply to message #5013] Thu, 25 June 2009 10:50 Go to previous messageGo to next message
Eclipse User
Originally posted by: eclipse-news.rizzoweb.com

David Williams wrote:
> BUT, upgrading from Ganymede to Galileo is not supported. You should
> start off with one of the main packages found at
> http://www.eclipse.org/downloads/ and then install other items into that
> install.

David,
Are you certain that Ganymede -> Galileo updates are really not
supported. One of the benefits of p2 was supposed to be the ability to
(finally) update across major releases.

Eric
Re: error updating Ganymede to Galileo [message #5142 is a reply to message #5076] Thu, 25 June 2009 13:37 Go to previous messageGo to next message
Eclipse User
Originally posted by: david_williams.linux.vnet.ibm.com

Eric Rizzo wrote:
> David,
> Are you certain that Ganymede -> Galileo updates are really not
> supported. One of the benefits of p2 was supposed to be the ability to
> (finally) update across major releases.
>
Well, it's definitely not supported in the sense no one has tested it
(that I know of).

The way I heard it described was, to paraphrase, " ... it might work, in
some situations, depending on what you had installed, and what you were
updating, but it would never be perfectly correct (some things like
'config', eclipse executable etc., will never be updated) and it might
cause problems later", or something similar to that (but don't quote me :)

I'm not the definitive word (not being on p2 team) but that's my
understanding.
Re: error updating Ganymede to Galileo [message #5211 is a reply to message #5076] Thu, 25 June 2009 17:22 Go to previous message
Eclipse User
Originally posted by: eclipseng.arthorne.com

The Galileo repository is using a completely new kind of repository
called a "composite repository". Since Eclipse 3.4 doesn't know anything
about this repository type, it can't find any artifacts (hence the "No
repository found..." errors). The metadata is otherwise completely
compatible between 3.4 and 3.5, so upgrades across releases are
theoretically possible. But, if your metadata takes advantage of new
concepts added in 3.5 (such as composite repositories), then previous
releases won't be able to process it.

Enabling major release upgrades while still allowing new releases to
make use of new features really requires a "staged" upgrade: upgrade p2
first, then use the new p2 to upgrade the rest. Some support for this
was added in 3.5, which should increase the number of cases where we can
support major-release upgrades in the future. Supporting upgrades across
major releases is on the draft plan for 3.6, but we've learned enough
about how complicated this really is that we won't be making any
promises until we're sure it will work ;)

--

Eric Rizzo wrote:
> David Williams wrote:
>> BUT, upgrading from Ganymede to Galileo is not supported. You should
>> start off with one of the main packages found at
>> http://www.eclipse.org/downloads/ and then install other items into
>> that install.
>
> David,
> Are you certain that Ganymede -> Galileo updates are really not
> supported. One of the benefits of p2 was supposed to be the ability to
> (finally) update across major releases.
>
> Eric
Re: error updating Ganymede to Galileo [message #567847 is a reply to message #4940] Wed, 24 June 2009 23:32 Go to previous message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
Alex Farberov wrote:
> Hello
>
> I'm trying to update eclipse Ganymede to Galileo.
> I added http://download.eclipse.org/releases/galileo to the update sites.
> Eclipse recognizes the updates and tries to dl/install them but
> encounters the following error:
>
>
> An error occurred while collecting items to be installed
> No repository found containing: com.ibm.icu/osgi.bundle/4.0.1.v20090415
> [ ... and many many more ... ]
That long list of errors does seem odd ... and not really sure what that
is from .... may have been a timing issue with the system a little
overloaded today.

BUT, upgrading from Ganymede to Galileo is not supported. You should
start off with one of the main packages found at
http://www.eclipse.org/downloads/ and then install other items into that
install.
Re: error updating Ganymede to Galileo [message #567879 is a reply to message #5013] Thu, 25 June 2009 10:50 Go to previous message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2107
Registered: July 2009
Senior Member
David Williams wrote:
> BUT, upgrading from Ganymede to Galileo is not supported. You should
> start off with one of the main packages found at
> http://www.eclipse.org/downloads/ and then install other items into that
> install.

David,
Are you certain that Ganymede -> Galileo updates are really not
supported. One of the benefits of p2 was supposed to be the ability to
(finally) update across major releases.

Eric
Re: error updating Ganymede to Galileo [message #567911 is a reply to message #5076] Thu, 25 June 2009 13:37 Go to previous message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
Eric Rizzo wrote:
> David,
> Are you certain that Ganymede -> Galileo updates are really not
> supported. One of the benefits of p2 was supposed to be the ability to
> (finally) update across major releases.
>
Well, it's definitely not supported in the sense no one has tested it
(that I know of).

The way I heard it described was, to paraphrase, " ... it might work, in
some situations, depending on what you had installed, and what you were
updating, but it would never be perfectly correct (some things like
'config', eclipse executable etc., will never be updated) and it might
cause problems later", or something similar to that (but don't quote me :)

I'm not the definitive word (not being on p2 team) but that's my
understanding.
Re: error updating Ganymede to Galileo [message #567940 is a reply to message #5076] Thu, 25 June 2009 17:22 Go to previous message
John Arthorne is currently offline John Arthorne
Messages: 174
Registered: July 2009
Senior Member
The Galileo repository is using a completely new kind of repository
called a "composite repository". Since Eclipse 3.4 doesn't know anything
about this repository type, it can't find any artifacts (hence the "No
repository found..." errors). The metadata is otherwise completely
compatible between 3.4 and 3.5, so upgrades across releases are
theoretically possible. But, if your metadata takes advantage of new
concepts added in 3.5 (such as composite repositories), then previous
releases won't be able to process it.

Enabling major release upgrades while still allowing new releases to
make use of new features really requires a "staged" upgrade: upgrade p2
first, then use the new p2 to upgrade the rest. Some support for this
was added in 3.5, which should increase the number of cases where we can
support major-release upgrades in the future. Supporting upgrades across
major releases is on the draft plan for 3.6, but we've learned enough
about how complicated this really is that we won't be making any
promises until we're sure it will work ;)

--

Eric Rizzo wrote:
> David Williams wrote:
>> BUT, upgrading from Ganymede to Galileo is not supported. You should
>> start off with one of the main packages found at
>> http://www.eclipse.org/downloads/ and then install other items into
>> that install.
>
> David,
> Are you certain that Ganymede -> Galileo updates are really not
> supported. One of the benefits of p2 was supposed to be the ability to
> (finally) update across major releases.
>
> Eric
Previous Topic:error updating Ganymede to Galileo
Next Topic:Problem installing XML editors and tools from Galileo update site
Goto Forum:
  


Current Time: Thu Apr 17 14:42:08 EDT 2014

Powered by FUDForum. Page generated in 0.03833 seconds