Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Missing requirement: org.eclipse.rcp_root
Missing requirement: org.eclipse.rcp_root [message #549717] Tue, 27 July 2010 12:39 Go to next message
Carsten Reckord is currently offline Carsten Reckord
Messages: 139
Registered: July 2009
Senior Member
Hi folks,

My product build stopped working a few days ago and I have absolutely no clue what might have caused this. I used to build a very minimal
product containing little more than org.eclipse.rcp and a branding plugin and then install additional stuff into it using director.

These days this results in

[ant] Cannot complete the install because one or more required items could not be found.
[ant] Software being installed: Mylyn Bridge: Team Support 3.3.2.v20100222-0100-e3x (org.eclipse.mylyn.team_feature.feature.group
3.3.2.v20100222-0100-e3x)
[ant] Missing requirement: Eclipse RCP 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 (org.eclipse.rcp.feature.group
3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6) requires 'org.eclipse.rcp_root [3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6]' but
it could not be found
[ant] Cannot satisfy dependency:
[ant] From: Mylyn Task-Focused Interface (Recommended) 3.3.2.v20100222-0100-e3x (org.eclipse.mylyn.context_feature.feature.group
3.3.2.v20100222-0100-e3x)
[ant] To: org.eclipse.mylyn_feature.feature.group [3.3.2.v20100222-0100-e3x]
[ant] Cannot satisfy dependency:
[ant] From: Mylyn Bridge: Team Support 3.3.2.v20100222-0100-e3x (org.eclipse.mylyn.team_feature.feature.group 3.3.2.v20100222-0100-e3x)
[ant] To: org.eclipse.mylyn.context_feature.feature.group [3.3.2.v20100222-0100-e3x]
[ant] Cannot satisfy dependency:
[ant] From: Mylyn Task List (Required) 3.3.2.v20100222-0100-e3x (org.eclipse.mylyn_feature.feature.group 3.3.2.v20100222-0100-e3x)
[ant] To: org.eclipse.rcp.feature.group [3.4.0,4.0.0)
[ant] Application failed, log file location: /home/hudson/tools/buckminster_3.6/configuration/12802460674 35.log

This is easily reproducible with the mailapp example. Just build the product as usual, then using director, try installing
org.eclipse.rcp.feature.group into it:

$ director -repository http://update.yatta-solutions.com/update-sites/platform -destination
file:///home/creckord/buckminster/output/org.eclipse.buckmin ster.tutorial.mailapp.product.feature_1.0.0-eclipse.feature/ MailApp -bundlepool
file:///home/creckord/buckminster/output/org.eclipse.buckmin ster.tutorial.mailapp.product.feature_1.0.0-eclipse.feature/ MailApp -profile
MailProfile -profileProperties org.eclipse.update.install.features=true -installIU org.eclipse.rcp.feature.group -roaming

> Installing org.eclipse.rcp.feature.group 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6.
> Installation failed.
> Cannot complete the install because one or more required items could not be found.
> Software currently installed: Mailapp test build 1.0.0 (org.eclipse.buckminster.tutorial.mailapp.product 1.0.0)
> Missing requirement: Eclipse RCP 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6 (org.eclipse.rcp.feature.group
3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6) requires 'org.eclipse.rcp_root [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6]' but
it could not be found
> Cannot satisfy dependency:
> From: Mailapp test build 1.0.0 (org.eclipse.buckminster.tutorial.mailapp.product 1.0.0)
> To: org.eclipse.buckminster.tutorial.mailapp.product.feature.fea ture.group [1.0.0]
> Cannot satisfy dependency:
> From: Mailapp Product Feature 1.0.0 (org.eclipse.buckminster.tutorial.mailapp.product.feature.fe ature.group 1.0.0)
> To: org.eclipse.rcp.feature.group [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6]
> Application failed, log file location: /home/creckord/NoBackup/buckminster/buckminster/configuratio n/1280248002058.log

It works fine when I first uninstall org.eclipse.rcp and then reinstall it...

Cheers,
Carsten
Re: Missing requirement: org.eclipse.rcp_root [message #549782 is a reply to message #549717] Tue, 27 July 2010 18:49 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Hi Carsten,

This seems to be caused by a regression in the director (I published a 3.6 based director a few days ago). I can observe
the behavior using the new director but not the old one.

Can you please enter a bugzilla for this?

- thomas


On 07/27/2010 06:39 PM, Carsten Reckord wrote:
> Hi folks,
>
> My product build stopped working a few days ago and I have absolutely no
> clue what might have caused this. I used to build a very minimal product
> containing little more than org.eclipse.rcp and a branding plugin and
> then install additional stuff into it using director.
>
> These days this results in
>
> [ant] Cannot complete the install because one or more required items
> could not be found.
> [ant] Software being installed: Mylyn Bridge: Team Support
> 3.3.2.v20100222-0100-e3x (org.eclipse.mylyn.team_feature.feature.group
> 3.3.2.v20100222-0100-e3x)
> [ant] Missing requirement: Eclipse RCP
> 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6
> (org.eclipse.rcp.feature.group
> 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6) requires
> 'org.eclipse.rcp_root
> [3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6]' but it could not be
> found
> [ant] Cannot satisfy dependency:
> [ant] From: Mylyn Task-Focused Interface (Recommended)
> 3.3.2.v20100222-0100-e3x
> (org.eclipse.mylyn.context_feature.feature.group 3.3.2.v20100222-0100-e3x)
> [ant] To: org.eclipse.mylyn_feature.feature.group
> [3.3.2.v20100222-0100-e3x]
> [ant] Cannot satisfy dependency:
> [ant] From: Mylyn Bridge: Team Support 3.3.2.v20100222-0100-e3x
> (org.eclipse.mylyn.team_feature.feature.group 3.3.2.v20100222-0100-e3x)
> [ant] To: org.eclipse.mylyn.context_feature.feature.group
> [3.3.2.v20100222-0100-e3x]
> [ant] Cannot satisfy dependency:
> [ant] From: Mylyn Task List (Required) 3.3.2.v20100222-0100-e3x
> (org.eclipse.mylyn_feature.feature.group 3.3.2.v20100222-0100-e3x)
> [ant] To: org.eclipse.rcp.feature.group [3.4.0,4.0.0)
> [ant] Application failed, log file location:
> /home/hudson/tools/buckminster_3.6/configuration/12802460674 35.log
>
> This is easily reproducible with the mailapp example. Just build the
> product as usual, then using director, try installing
> org.eclipse.rcp.feature.group into it:
>
> $ director -repository
> http://update.yatta-solutions.com/update-sites/platform -destination
> file:///home/creckord/buckminster/output/org.eclipse.buckmin ster.tutorial.mailapp.product.feature_1.0.0-eclipse.feature/ MailApp
> -bundlepool
> file:///home/creckord/buckminster/output/org.eclipse.buckmin ster.tutorial.mailapp.product.feature_1.0.0-eclipse.feature/ MailApp
> -profile MailProfile -profileProperties
> org.eclipse.update.install.features=true -installIU
> org.eclipse.rcp.feature.group -roaming
>
> > Installing org.eclipse.rcp.feature.group
> 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6.
> > Installation failed.
> > Cannot complete the install because one or more required items could
> not be found.
> > Software currently installed: Mailapp test build 1.0.0
> (org.eclipse.buckminster.tutorial.mailapp.product 1.0.0)
> > Missing requirement: Eclipse RCP
> 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6
> (org.eclipse.rcp.feature.group
> 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6) requires
> 'org.eclipse.rcp_root
> [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6]' but it could not be
> found
> > Cannot satisfy dependency:
> > From: Mailapp test build 1.0.0
> (org.eclipse.buckminster.tutorial.mailapp.product 1.0.0)
> > To:
> org.eclipse.buckminster.tutorial.mailapp.product.feature.fea ture.group
> [1.0.0]
> > Cannot satisfy dependency:
> > From: Mailapp Product Feature 1.0.0
> (org.eclipse.buckminster.tutorial.mailapp.product.feature.fe ature.group
> 1.0.0)
> > To: org.eclipse.rcp.feature.group
> [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6]
> > Application failed, log file location:
> /home/creckord/NoBackup/buckminster/buckminster/configuratio n/1280248002058.log
>
>
> It works fine when I first uninstall org.eclipse.rcp and then reinstall
> it...
>
> Cheers,
> Carsten
Re: Missing requirement: org.eclipse.rcp_root [message #549891 is a reply to message #549782] Wed, 28 July 2010 07:33 Go to previous message
Carsten Reckord is currently offline Carsten Reckord
Messages: 139
Registered: July 2009
Senior Member
Hi Thomas,

Created and commented on :)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=321111

Carsten

On 28.07.2010 00:49, Thomas Hallgren wrote:
> Hi Carsten,
>
> This seems to be caused by a regression in the director (I published a 3.6 based director a few days ago). I can observe
> the behavior using the new director but not the old one.
>
> Can you please enter a bugzilla for this?
>
> - thomas
Previous Topic:Teneo/Texo build problem with Buckminster
Next Topic:Source plugins via url.zipped
Goto Forum:
  


Current Time: Tue Sep 02 12:54:04 EDT 2014

Powered by FUDForum. Page generated in 0.01850 seconds