Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Polish users » problem z file association(Otwieranie plików css i tpl w eclipse)
problem z file association [message #549188] Sun, 25 July 2010 20:27 Go to next message
Rafał  is currently offline Rafał
Messages: 4
Registered: July 2010
Junior Member
Witam wszystkich,

Grzebię od godziny w google i opcjach i nie mogę odnaleźć właściwej odpowiedzi. Może taki topic na tym forum spowoduje, że potomni będą mieli łatwiej znaleźć.

Problem jest znany. Mam plik .css, mam do niego przypisany edytor (tylko 1), ale mimo wszystko Eclipse po dwukliku na pliku .css otwiera edytor + domyślny edytor systemowy (czyt. notatnik), co powoduje nagły przypływ dodatkowej, niepotrzebnej i negatywnej adrenaliny. To samo mam z plikami .tpl. Wiem, że jest na to rozwiazanie, ponieważ stosowałem je kilka razy na różnych maszynach. Teraz mam nowy system i niestety nie mogę nigdzie znaleźć gdzie to się zmieniało Crying or Very Sad Jak google potrzeba, to nie pomoże...

Pomożecie?
Re: problem z file association [message #549224 is a reply to message #549188] Mon, 26 July 2010 03:57 Go to previous messageGo to next message
Tomasz Zarna is currently offline Tomasz Zarna
Messages: 164
Registered: July 2009
Senior Member
Sprawdź ustawienia na stronie File Associations w preferencjach.

Pomogliśmy? Smile
Re: problem z file association [message #549228 is a reply to message #549224] Mon, 26 July 2010 04:18 Go to previous messageGo to next message
Rafał  is currently offline Rafał
Messages: 4
Registered: July 2010
Junior Member
@Tomasz - nie bardzo Cool Tam jest wszystko ok, zresztą jak brzmi topic, to jest właśnie jakiś problem z file association. Mam ustawiony tylko 1 edytor i jest to plugin do otwierania CSSow (lub smartow w przypadku tpl).
Klikam dwukrotnie i otwiera mi się edytor CSSów/Smartów, ale oprócz tego otwiera się również notatnik...
Re: problem z file association [message #549253 is a reply to message #549228] Mon, 26 July 2010 05:30 Go to previous messageGo to next message
Tomasz Zarna is currently offline Tomasz Zarna
Messages: 164
Registered: July 2009
Senior Member
A jak klikniesz prawym na pliku CSS to w podmenu Open With co masz zaznaczone?
Re: problem z file association [message #549254 is a reply to message #549253] Mon, 26 July 2010 05:38 Go to previous messageGo to next message
Rafał  is currently offline Rafał
Messages: 4
Registered: July 2010
Junior Member
Pliiiiiissssss... To, że mam junior przy nicku, nie oznacza, że trzeba do mnie jak do juniora Razz Cokolwiek nie mam zaznaczone, CSS editor, Ant Editor, PHP editor, Java Editor, cokolwiek nie zaznaczę, zawsze otwiera mi notepada.

p.s. nie było by to może tak denerwujące, gdyby nie to, że przy przechodzeniu po zakładkach i wpadnięciu na plik .css też się notepad otwiera...

[Updated on: Mon, 26 July 2010 05:43]

Report message to a moderator

Re: problem z file association [message #549261 is a reply to message #549188] Mon, 26 July 2010 06:07 Go to previous messageGo to next message
Rafał  is currently offline Rafał
Messages: 4
Registered: July 2010
Junior Member
Dobra mam. Może się przyda potomnym ehhh...

Całość rozchodzi się o to, że przy instalacji PHP Eclipse, CSS jest domyślnie w jakimś "dziwnym" edytorze (już nie pamiętam w jakim). Jeśli sobie potem dodajesz Edytor właściwy do listy, usuwasz tamten, ale nie zaznaczysz nowego jako "default" dzieje się właśnie taki efekt, czyli otwiera się ten jedyny na liście edytor, ale otwiera się również domyślny edytor systemowy. Jak dla mnie to bug, ale cóż (jedyny edytor powinien być domyślnie defaultowym).

Rozwiązałem przy okazji kolejny problem z .tpl, który akurat jest łatwy, ale może komuś się przyda. Jeśli zainstalujemy wtyczkę do Smartów, może się zdarzać, że przy wejściu na plik pojawia się okienko pobierania naszego pliku. Dzieje się tak dlatego, że przeglądarka Eclipse nie rozumie rozszerzenia .tpl. Nie chciało mi się bawić z przeglądarką więc poprostu wyłączyłem ją (i tak z niej nie korzystam), czyli Window->Preferences->PHP Eclipse Development->Browser Preview Defaults i tam obie opcje odfajkować.

Tyla. Dzięki mimo wszystko za próbę pomocy.

[Updated on: Mon, 26 July 2010 06:08]

Report message to a moderator

Re: problem z file association [message #549280 is a reply to message #549254] Mon, 26 July 2010 07:16 Go to previous message
Tomasz Zarna is currently offline Tomasz Zarna
Messages: 164
Registered: July 2009
Senior Member
Rafał wrote on Mon, 26 July 2010 11:38
Pliiiiiissssss... To, że mam junior przy nicku, nie oznacza, że trzeba do mnie jak do juniora Razz


Sorry, nie chciałem Cię urazić. Ale uwierz że każdemu zdarza się przeoczyć coś oczywistego.

Cieszę się że sobie poradziłeś, choć i tak uważam że to ja Ciebie zmotywowałem Wink
Previous Topic:obsluga CVS w podlinkowanych zasobach
Next Topic:Jak debugować java.lang ?
Goto Forum:
  


Current Time: Thu Jul 31 01:31:35 EDT 2014

Powered by FUDForum. Page generated in 0.28398 seconds