Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Unable to bring in gef source for debugging(Cannot attach source to dependency jar gef)
Unable to bring in gef source for debugging [message #549098] Sat, 24 July 2010 11:35 Go to next message
Brady Diggs is currently offline Brady Diggs
Messages: 3
Registered: July 2010
Location: Frisco, TX
Junior Member
Hi all...
I'm trying to debug through my app and be able to step into org.eclipse.gef source code. I've tried several different ways to get
the source into the run path, but none of them works. When I go to Properties for my plugin, I look under Java Build Path->Libraries and look at the gef.jar. I expand this to see Source Attachments:
I see the org.elcipse.gef jar as the source attachment, but this jar has no source in it. And the Source Attachment says it's non-modifiable so I don't get an edit button to add a different source jar.
Am I doing something wrong here?
I'm running Eclipse 3.4 and I'm using GEF 3.2.1.
Thanks in advance for the help.

Brady
Re: Unable to bring in gef source for debugging [message #549104 is a reply to message #549098] Sat, 24 July 2010 13:22 Go to previous messageGo to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
On 24/07/2010 12:35, bwdiggs@yahoo.com wrote:
> Hi all...
> I'm trying to debug through my app and be able to step into
> org.eclipse.gef source code. I've tried several different ways to get
> the source into the run path, but none of them works. When I go to
> Properties for my plugin, I look under Java Build Path->Libraries and
> look at the gef.jar. I expand this to see Source Attachments:
> I see the org.elcipse.gef jar as the source attachment, but this jar has
> no source in it. And the Source Attachment says it's non-modifiable so I
> don't get an edit button to add a different source jar. Am I doing
> something wrong here?
> I'm running Eclipse 3.4 and I'm using GEF 3.2.1.
> Thanks in advance for the help.
>
> Brady

Did you download the GEF SDK (this has source) or GEF runtime?

PB
Re: Unable to bring in gef source for debugging [message #549115 is a reply to message #549104] Sat, 24 July 2010 18:38 Go to previous messageGo to next message
Brady Diggs is currently offline Brady Diggs
Messages: 3
Registered: July 2010
Location: Frisco, TX
Junior Member
Yes, I have the GEF source. I just can't seem to get it in the right place for Eclipse to see it. I put it in the build path, in the dependencies, etc. Nothing seems to work. I was basically wondering where I need to put it for a plugin to be able to debug through it.
Re: Unable to bring in gef source for debugging [message #549162 is a reply to message #549115] Sun, 25 July 2010 15:33 Go to previous message
Brady Diggs is currently offline Brady Diggs
Messages: 3
Registered: July 2010
Location: Frisco, TX
Junior Member
I figured it out. I added the GEF plugin to my target plaform dependencies and removed all other source directories for GEF.
Works fine now. Thanks!
Previous Topic:Flickering in custom feedback figure
Next Topic:Properties Order
Goto Forum:
  


Current Time: Mon Sep 22 16:32:23 GMT 2014

Powered by FUDForum. Page generated in 0.02366 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software