Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT publishes xml parser an crashes second webapp
BIRT publishes xml parser an crashes second webapp [message #548574] Thu, 22 July 2010 11:52 Go to next message
Thomas Hergenröder is currently offline Thomas Hergenröder
Messages: 15
Registered: July 2009
Junior Member
When I deploy BIRT on the same web application as the web application BIRT should generate reports for
and restart the other web application the other web application fails to start.

The other web application is running without problems until BIRT.

The used Server is Websphere 6.1(Servlet 2.4) on Windows or AS400.

I tried BIRT Versions 2.3.2.1, 2.5.2 and 2.6.

In the other web application JSF is added manually because the server does not support the required version.

It seems that BIRT loads an XML-Parser or sets some settings that cause the problem.

00000028 config        W   JSF1056: Unable to create InputSource for URL 'wsjar:file:/C:/Programme/IBM/SDP70/runtimes/base_v61/profiles/AppSrv01/installedApps/ws016155Node01Cell/ibp_ear.ear/ibp.war/WEB-INF/lib/jsf-impl-1.2_14.jar!/com/sun/faces/web-facesconfig_1_1.dtd'.
0000001f WebApp        E   Exception caught while initializing context 
com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED! java.sun.com
	at com.sun.faces.config.ConfigManager.initialize(ConfigManager.java:214)
	at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:199)
	at com.ibm.ws.wswebcontainer.webapp.WebApp.notifyServletContextCreated(WebApp.java:652)
(more...)
and
0000001f ServletWrappe E   SRVE0100E: Nicht erfasste Ausnahme für init() wurde von Servlet {0} ausgelöst: java.lang.IllegalStateException: Application was not properly initialized at startup, could not find Factory: javax.faces.context.FacesContextFactory
	at javax.faces.FactoryFinder$FactoryManager.getFactory(FactoryFinder.java:725)
	at javax.faces.FactoryFinder.getFactory(FactoryFinder.java:239)
	at javax.faces.webapp.FacesServlet.init(FacesServlet.java:164)
	at com.ibm.ws.webcontainer.servlet.ServletWrapper.init(ServletWrapper.java:226)
(more...)


Anyone an idea?

[Updated on: Mon, 26 July 2010 09:11]

Report message to a moderator

Re: BIRT publishes xml parser an crashes second webapp [message #630827 is a reply to message #548574] Tue, 05 October 2010 08:18 Go to previous messageGo to next message
Zacharakis Kostas is currently offline Zacharakis Kostas
Messages: 2
Registered: October 2010
Junior Member
I experience exactly the same behavior.
Has anybody a workaround on this?

Thanks
Re: BIRT publishes xml parser an crashes second webapp [message #630941 is a reply to message #630827] Tue, 05 October 2010 15:40 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you open a bugzilla entry for this?

Jason

On 10/5/2010 4:18 AM, Zacharakis Kostas wrote:
> I experience exactly the same behavior. Has anybody a workaround on this?
>
> Thanks
Re: BIRT publishes xml parser an crashes second webapp [message #632565 is a reply to message #630941] Wed, 13 October 2010 13:14 Go to previous messageGo to next message
Zacharakis Kostas is currently offline Zacharakis Kostas
Messages: 2
Registered: October 2010
Junior Member
Jason Weathersby wrote on Tue, 05 October 2010 11:40
Can you open a bugzilla entry for this?

Jason

On 10/5/2010 4:18 AM, Zacharakis Kostas wrote:
> I experience exactly the same behavior. Has anybody a workaround on this?
>
> Thanks


Logged.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=327660#c0
Re: BIRT publishes xml parser an crashes second webapp [message #632617 is a reply to message #632565] Wed, 13 October 2010 15:19 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Thanks for logging

On 10/13/2010 9:14 AM, Zacharakis Kostas wrote:
> Jason Weathersby wrote on Tue, 05 October 2010 11:40
>> Can you open a bugzilla entry for this?
>>
>> Jason
>>
>> On 10/5/2010 4:18 AM, Zacharakis Kostas wrote:
>> > I experience exactly the same behavior. Has anybody a workaround on
>> this?
>> >
>> > Thanks
>
>
> Logged.
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=327660#c0
>
Previous Topic:ErrorHandeling\Logging in BIRT
Next Topic:Wanted: Easy Report with JavaScript
Goto Forum:
  


Current Time: Thu Oct 23 04:51:58 GMT 2014

Powered by FUDForum. Page generated in 0.01703 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software