Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » GWT-User not installable with p2
GWT-User not installable with p2 [message #547572] Sun, 18 July 2010 22:34 Go to next message
Esteban Dugueperoux is currently offline Esteban DugueperouxFriend
Messages: 340
Registered: July 2009
Senior Member
Hi,

I have tried to install gwt-user from orbit p2 repository
( http://download.eclipse.org/tools/orbit/downloads/drops/R201 00519200754/repository)
but can't because of "Eclipse-PlatformFilter: (osgi.os=browser)" defined
in MANIFEST.MF of com.google.gwt.user bundle released 2.0.3.v20100419-0751 .
I know that this library is only used at development to generate
javascript but it would be useful to have it installable in standard
target platform to call gwtc compiler for example.

Best Regards.
Re: GWT-User not installable with p2 [message #548117 is a reply to message #547572] Tue, 20 July 2010 17:16 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 176
Registered: July 2009
Senior Member
Esteban DUGUEPEROUX wrote:
> Hi,
>
> I have tried to install gwt-user from orbit p2 repository
> ( http://download.eclipse.org/tools/orbit/downloads/drops/R201 00519200754/repository)
> but can't because of "Eclipse-PlatformFilter: (osgi.os=browser)" defined
> in MANIFEST.MF of com.google.gwt.user bundle released
> 2.0.3.v20100419-0751 .
> I know that this library is only used at development to generate
> javascript but it would be useful to have it installable in standard
> target platform to call gwtc compiler for example.
>
> Best Regards.

I appears this invalid filter was removed from cvs version, but the
"fixed" version not released for the R-build. Plus some other process
problems.

But, if it helps, I have just promoted an I-build that has a "2.0.4"
version, which does not have that filter.

http://download.eclipse.org/tools/orbit/downloads/drops/I201 00709085604/

I've also opened following bug, which you can follow or comment on. If
you need 2.0.3 (or, 2.0.4) fixed in an R-build, please say so in the bug
(with the reasons) and we can (probably) fix in Helios SR1.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=320422

Thanks,
Re: GWT-User not installable with p2 [message #548204 is a reply to message #547572] Wed, 21 July 2010 05:51 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 452
Registered: July 2009
Location: Germany ✈ Vancouver
Senior Member

Hi,

Am 19.07.2010 00:34, schrieb Esteban DUGUEPEROUX:
> I know that this library is only used at development to generate
> javascript but it would be useful to have it installable in standard
> target platform to call gwtc compiler for example.

You need to check "Include all environments" when installing into your
target platform. However, you still need the gwt-dev.jar with the
compiler which is not in Orbit. I use the GWT Tooling plug-in for
compilations.

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Re: GWT-User not installable with p2 [message #565951 is a reply to message #547572] Tue, 20 July 2010 17:16 Go to previous message
David Williams is currently offline David WilliamsFriend
Messages: 176
Registered: July 2009
Senior Member
Esteban DUGUEPEROUX wrote:
> Hi,
>
> I have tried to install gwt-user from orbit p2 repository
> ( http://download.eclipse.org/tools/orbit/downloads/drops/R201 00519200754/repository)
> but can't because of "Eclipse-PlatformFilter: (osgi.os=browser)" defined
> in MANIFEST.MF of com.google.gwt.user bundle released
> 2.0.3.v20100419-0751 .
> I know that this library is only used at development to generate
> javascript but it would be useful to have it installable in standard
> target platform to call gwtc compiler for example.
>
> Best Regards.

I appears this invalid filter was removed from cvs version, but the
"fixed" version not released for the R-build. Plus some other process
problems.

But, if it helps, I have just promoted an I-build that has a "2.0.4"
version, which does not have that filter.

http://download.eclipse.org/tools/orbit/downloads/drops/I201 00709085604/

I've also opened following bug, which you can follow or comment on. If
you need 2.0.3 (or, 2.0.4) fixed in an R-build, please say so in the bug
(with the reasons) and we can (probably) fix in Helios SR1.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=320422

Thanks,
Re: GWT-User not installable with p2 [message #566000 is a reply to message #547572] Wed, 21 July 2010 05:51 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 452
Registered: July 2009
Location: Germany ✈ Vancouver
Senior Member

Hi,

Am 19.07.2010 00:34, schrieb Esteban DUGUEPEROUX:
> I know that this library is only used at development to generate
> javascript but it would be useful to have it installable in standard
> target platform to call gwtc compiler for example.

You need to check "Include all environments" when installing into your
target platform. However, you still need the gwt-dev.jar with the
compiler which is not in Orbit. I use the GWT Tooling plug-in for
compilations.

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Previous Topic:SLF4j Version 1.6.0
Next Topic:Version of iText
Goto Forum:
  


Current Time: Sat Nov 29 10:11:44 GMT 2014

Powered by FUDForum. Page generated in 0.02004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software