Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Debugger breaks at every Zend Framework class
Debugger breaks at every Zend Framework class [message #547214] Fri, 16 July 2010 00:49 Go to next message
Matt McCormick is currently offline Matt McCormickFriend
Messages: 6
Registered: July 2010
Junior Member
I recently installed PDT Helios from the Zend Framework site on Ubuntu 10.04 and now when using the debugger, it will break everytime a new class is referenced in the stack for all Zend Framework classes. As far as I can tell, it is only done with ZF classes, and not my application's own classes.

If I have no breakpoints set, it will run continuously until completion but when I set a breakpoint, it stops at every Zend Class along the way.

I never had this problem before. Any workaround for it? This is really a nuisance as it makes debugging pretty much impossible.
Re: Debugger breaks at every Zend Framework class [message #547216 is a reply to message #547214] Fri, 16 July 2010 01:01 Go to previous messageGo to next message
Matt McCormick is currently offline Matt McCormickFriend
Messages: 6
Registered: July 2010
Junior Member
I just installed Galileo to check and debugging works correctly in Galileo. The only difference I notice is that in the Breakpoints tab, the file names are different

Galileo just lists the file name

eg. IndexController.php [line: 9]

while Helios lists longer names:

eg. /myproject/application/controllers/IndexController.php [line: 9]

Would love to get this working on Helios as it seems to be much faster.
Re: Debugger breaks at every Zend Framework class [message #547226 is a reply to message #547216] Fri, 16 July 2010 03:03 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 359
Registered: July 2009
Location: Japan
Senior Member
I had similar problem.
Try update "2.2.0 / M201006170734".
PHP Development Tools (PDT) - Downloads

or latest stable build (not recommended).
https://build.eclipse.org/hudson/job/cbi-pdt-2.2-helios/last StableBuild/
Re: Debugger breaks at every Zend Framework class [message #547232 is a reply to message #547226] Fri, 16 July 2010 04:04 Go to previous messageGo to next message
Matt McCormick is currently offline Matt McCormickFriend
Messages: 6
Registered: July 2010
Junior Member
Hmmm...I think I'm using that build already:

My Build ID: 20100617-1415
Re: Debugger breaks at every Zend Framework class [message #548775 is a reply to message #547214] Thu, 22 July 2010 23:16 Go to previous messageGo to next message
Tristan is currently offline TristanFriend
Messages: 4
Registered: July 2010
Junior Member
Same issue here, but I can confirm that it is not limited to Zend Framework classes. I added PHPExcel as a module and it stops at every PHPExcel class for me.
Re: Debugger breaks at every Zend Framework class [message #548777 is a reply to message #548775] Thu, 22 July 2010 23:21 Go to previous messageGo to next message
Matt McCormick is currently offline Matt McCormickFriend
Messages: 6
Registered: July 2010
Junior Member
I have opened a bug about this - https://bugs.eclipse.org/bugs/show_bug.cgi?id=320058

You may want to post your experience on the bug report to let them know that it is a common problem.
Re: Debugger breaks at every Zend Framework class [message #548851 is a reply to message #548775] Fri, 23 July 2010 09:59 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 359
Registered: July 2009
Location: Japan
Senior Member
>Try update "2.2.0 / M201006170734".
>PHP Development Tools (PDT) - Downloads

again Wink
Re: Debugger breaks at every Zend Framework class [message #548955 is a reply to message #548851] Fri, 23 July 2010 14:28 Go to previous messageGo to next message
Matt McCormick is currently offline Matt McCormickFriend
Messages: 6
Registered: July 2010
Junior Member
Ok, that worked. Thank you!
Re: Debugger breaks at every Zend Framework class [message #548959 is a reply to message #547214] Fri, 23 July 2010 14:34 Go to previous messageGo to next message
Tristan is currently offline TristanFriend
Messages: 4
Registered: July 2010
Junior Member
Newbie question..

How do I manually apply that update once I download it?

Ok, I think I figured that part out, just point the "Install New Software" to content.jar in the update folder.

Now I get :

An error occurred while collecting items to be installed
session context was:(profile=epp.package.php, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: osgi.bundle,org.eclipse.php.debug.core,2.2.0.v20100617-1400.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/plugins/org.eclipse.php.debug.core_2.2.0.v2010061 7-1400.jar
Artifact not found: osgi.bundle,org.eclipse.php.debug.core.source,2.2.0.v2010061 7-1400.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/plugins/org.eclipse.php.debug.core.source_2.2.0.v 20100617-1400.jar
Artifact not found: org.eclipse.update.feature,org.eclipse.php.all,2.2.0.v201005 19-1400-53-7A51J1WES6MOWsOaXRLXQYez-.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/features/org.eclipse.php.all_2.2.0.v20100519-1400 -53-7A51J1WES6MOWsOaXRLXQYez-.jar
Artifact not found: org.eclipse.update.feature,org.eclipse.php,2.2.0.v20100519-1 400-7L7J-F8NcJTJKEUF9UcJJ.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/features/org.eclipse.php_2.2.0.v20100519-1400-7L7 J-F8NcJTJKEUF9UcJJ.jar
Artifact not found: org.eclipse.update.feature,org.eclipse.php.mylyn,2.2.0.v2010 0519-1400-2--7w3121152101411.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/features/org.eclipse.php.mylyn_2.2.0.v20100519-14 00-2--7w3121152101411.jar
Artifact not found: osgi.bundle,org.eclipse.php.mylyn.ui,1.0.0.v20100410-0300.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/plugins/org.eclipse.php.mylyn.ui_1.0.0.v20100410- 0300.jar
Artifact not found: org.eclipse.update.feature,org.eclipse.php.sdk,2.2.0.v201005 19-1400-53-84QAN2IGRoLXQNHWPXdyLa9Od.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/features/org.eclipse.php.sdk_2.2.0.v20100519-1400 -53-84QAN2IGRoLXQNHWPXdyLa9Od.jar
Artifact not found: org.eclipse.update.feature,org.eclipse.php.source,2.2.0.v201 00519-1400-7L7J-F8NcJTJKEUF9UcJJ.
jar:file:/Users/seed/Downloads/pdt-Update-M201006170734/arti facts.jar!/features/org.eclipse.php.source_2.2.0.v20100519-1 400-7L7J-F8NcJTJKEUF9UcJJ.jar

[Updated on: Fri, 23 July 2010 14:43]

Report message to a moderator

Re: Debugger breaks at every Zend Framework class [message #548968 is a reply to message #548959] Fri, 23 July 2010 14:47 Go to previous messageGo to next message
Matt McCormick is currently offline Matt McCormickFriend
Messages: 6
Registered: July 2010
Junior Member
I couldn't figure out how to install the All-in-one update. The instructions at http://wiki.eclipse.org/PDT/Updates are very vague. I didn't understand how to "point it at your existing workspace"

So I just downloaded the SDK and extracted it into /dropins. Then start eclipse with "eclipse -clean"

That worked for me.

[Updated on: Fri, 23 July 2010 14:48]

Report message to a moderator

Re: Debugger breaks at every Zend Framework class [message #548973 is a reply to message #547214] Fri, 23 July 2010 14:54 Go to previous message
Tristan is currently offline TristanFriend
Messages: 4
Registered: July 2010
Junior Member
Matt...

Your way worked! Thank you.
Previous Topic:Autocomplete in CSS files
Next Topic:PHP 5.3 Zend Debugger
Goto Forum:
  


Current Time: Sun Dec 21 10:09:21 GMT 2014

Powered by FUDForum. Page generated in 0.11725 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software