Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » RCP display problems with multiple monitors in Windows 7 x64  () 1 Vote
RCP display problems with multiple monitors in Windows 7 x64 [message #546524] Tue, 13 July 2010 09:36 Go to next message
Elvis  is currently offline Elvis
Messages: 4
Registered: July 2010
Junior Member
I have multiple monitors with 64-bit Windows 7.

If the monitors are arranged in a way so that there is a monitor placed on the top (having negative y-coordinates) or on the left (having negative x-coordinates) to the primary monitor, the border of moving view region is wrongly displayed when a view is dragged around the screen.

The region border is somehow shifted by the number of pixels that the monitor is extended. However, the view can be correctly dropped at the mouse location (regardless of where the region border is drawn).

This problem happens not only to the RCP applications that I built, but also to the Eclipse IDE (version 3.5.x and 3.6) itself.

Does anyone encounter similar issues?
Re: RCP display problems with multiple monitors in Windows 7 x64 [message #546525 is a reply to message #546524] Tue, 13 July 2010 09:42 Go to previous messageGo to next message
Leung Wang Hei is currently offline Leung Wang Hei
Messages: 62
Registered: July 2010
Member
I got a similar case. Very frustrated
Re: RCP display problems with multiple monitors in Windows 7 x64 [message #546528 is a reply to message #546524] Tue, 13 July 2010 09:44 Go to previous messageGo to next message
Elvis  is currently offline Elvis
Messages: 4
Registered: July 2010
Junior Member
This problem actually stops me from migrating to Win7 x64 from WinXP x86.

There's no such problem in WinXP x86 at all.
Re: RCP display problems with multiple monitors in Windows 7 x64 [message #546585 is a reply to message #546528] Tue, 13 July 2010 13:37 Go to previous messageGo to next message
Grant Gayed is currently offline Grant Gayed
Messages: 2151
Registered: July 2009
Senior Member
Hi,

Please log a bug with swt at
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=SWT
and provide steps that show this problem with a base eclipse install. Also
be sure to mention that this is Windows 7-specific.

Thanks,
Grant


"Elvis" <elvislam@hotmail.com> wrote in message
news:i1hci0$6rk$1@build.eclipse.org...
> This problem actually stops me from migrating to Win7 x64 from WinXP x86.
> There's no such problem in WinXP x86 at all.
Re: RCP display problems with multiple monitors in Windows 7 x64 [message #546737 is a reply to message #546585] Wed, 14 July 2010 02:50 Go to previous message
Elvis  is currently offline Elvis
Messages: 4
Registered: July 2010
Junior Member
Please refer to Bug #319806. Thanks.
Previous Topic:Recommended Target Platform for RCP + IDE + Resources
Next Topic:How to investigate "Too many open files" error?
Goto Forum:
  


Current Time: Sun Sep 21 04:23:31 GMT 2014

Powered by FUDForum. Page generated in 0.01757 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software