Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Problem with Tables
Problem with Tables [message #546436] Mon, 12 July 2010 18:30 Go to next message
Eclipse UserFriend
Originally posted by: pschoenb.gmx.de

Hi,

I am quite new to BIRT, and I am building a report using scripting.
Although I was able to build a simple example successfully, I have
problems in my main app to get anything displayed in a table.

To find out what is happening, I installed a row event handler. I
noticed that onPrepare() gets called, but onCreate() and onRender()
never is called.

I checked my dataset and it seems that the data is filled in correctly.

What could be wrong?

--
Regards,
Patrick

--
email: pschoenb@gmx.de
PGP public key available. Key ID: 0B7DDE39
Or email to pgp@robustsoft.de with subject 'pschoenb'.
Fingerprint: BE80 0E7E B68E CE99 623C 902D 62A6 806A 0B7D DE39
Re: Problem with Tables [message #546455 is a reply to message #546436] Mon, 12 July 2010 20:06 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Are you sure the table is bound to the dataset? Look at the binding tab
in the properties editor.

Jason

On 7/12/2010 2:30 PM, Patrick Schönbach wrote:
> Hi,
>
> I am quite new to BIRT, and I am building a report using scripting.
> Although I was able to build a simple example successfully, I have
> problems in my main app to get anything displayed in a table.
>
> To find out what is happening, I installed a row event handler. I
> noticed that onPrepare() gets called, but onCreate() and onRender()
> never is called.
>
> I checked my dataset and it seems that the data is filled in correctly.
>
> What could be wrong?
>
Re: Problem with Tables [message #546550 is a reply to message #546455] Tue, 13 July 2010 10:38 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: pschoenb.gmx.de

On Mon, 12 Jul 2010 16:06:26 -0400, Jason Weathersby wrote:

> Are you sure the table is bound to the dataset? Look at the binding tab
> in the properties editor.

Yes, the table *is* bound to the dataset.

--
Regards,
Patrick

--
email: pschoenb@gmx.de
PGP public key available. Key ID: 0B7DDE39
Or email to pgp@robustsoft.de with subject 'pschoenb'.
Fingerprint: BE80 0E7E B68E CE99 623C 902D 62A6 806A 0B7D DE39
Re: Problem with Tables [message #546568 is a reply to message #546550] Tue, 13 July 2010 11:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: pschoenb.gmx.de

On Tue, 13 Jul 2010 12:38:22 +0200, Patrick Schönbach wrote:

> On Mon, 12 Jul 2010 16:06:26 -0400, Jason Weathersby wrote:
>
>> Are you sure the table is bound to the dataset? Look at the binding tab
>> in the properties editor.
>
> Yes, the table *is* bound to the dataset.

For the table, onPrepare(), onCreate() and onRender() is called
correctly. However, for the detail row, only onPrepare() is called. Due
to some unfortunate dependency, I am stuck with Eclipse 3.3 and BIRT
2.2.2.

What could be wrong?

--
Regards,
Patrick

--
email: pschoenb@gmx.de
PGP public key available. Key ID: 0B7DDE39
Or email to pgp@robustsoft.de with subject 'pschoenb'.
Fingerprint: BE80 0E7E B68E CE99 623C 902D 62A6 806A 0B7D DE39
Re: Problem with Tables [message #546606 is a reply to message #546568] Tue, 13 July 2010 14:18 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Can you post the report?

On 7/13/2010 7:25 AM, Patrick Schönbach wrote:
> On Tue, 13 Jul 2010 12:38:22 +0200, Patrick Schönbach wrote:
>
>> On Mon, 12 Jul 2010 16:06:26 -0400, Jason Weathersby wrote:
>>
>>> Are you sure the table is bound to the dataset? Look at the binding tab
>>> in the properties editor.
>>
>> Yes, the table *is* bound to the dataset.
>
> For the table, onPrepare(), onCreate() and onRender() is called
> correctly. However, for the detail row, only onPrepare() is called. Due
> to some unfortunate dependency, I am stuck with Eclipse 3.3 and BIRT
> 2.2.2.
>
> What could be wrong?
>
Re: Problem with Tables [message #546727 is a reply to message #546606] Tue, 13 July 2010 23:47 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Patrick,

I looked at your report. Where do you have the dataset eventhandler
class located?
Are you sure it is being called? The row event adapter will not be
called if no rows are available in the dataset.

Jason

On 7/13/2010 10:18 AM, Jason Weathersby wrote:
> Can you post the report?
>
> On 7/13/2010 7:25 AM, Patrick Schönbach wrote:
>> On Tue, 13 Jul 2010 12:38:22 +0200, Patrick Schönbach wrote:
>>
>>> On Mon, 12 Jul 2010 16:06:26 -0400, Jason Weathersby wrote:
>>>
>>>> Are you sure the table is bound to the dataset? Look at the binding tab
>>>> in the properties editor.
>>>
>>> Yes, the table *is* bound to the dataset.
>>
>> For the table, onPrepare(), onCreate() and onRender() is called
>> correctly. However, for the detail row, only onPrepare() is called. Due
>> to some unfortunate dependency, I am stuck with Eclipse 3.3 and BIRT
>> 2.2.2.
>>
>> What could be wrong?
>>
>
Previous Topic:Error in chart
Next Topic:Viewer web.xml being ignored in 2.5.2?
Goto Forum:
  


Current Time: Sun Dec 21 04:18:26 GMT 2014

Powered by FUDForum. Page generated in 0.02552 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software