Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Riena » Remote Service Registration with Riena 1.2.0(Problems while register services on stand alone server)
Remote Service Registration with Riena 1.2.0 [message #546307] Mon, 12 July 2010 12:49 Go to next message
Dirk Steiner is currently offline Dirk Steiner
Messages: 10
Registered: June 2010
Location: Holzwickede, Germany
Junior Member
Hi all,

I wrote some services inside Eclipse and registered them as remote services via Riena (Spring DM and inside Activators).

Everythins worked fine, when I let it run inside Eclipse. But when my OSGi server is configured and started similar to my Eclipse environment, services start, but they won't be restired as remote services, althow I set all service properties.

What do I have to do to use get my services registered inside a stand alone server?

I need help as fast as possible, because services should be used in prudutive environment soon.

Kind regards

Dirk
Re: Remote Service Registration with Riena 1.2.0 [message #546310 is a reply to message #546307] Mon, 12 July 2010 12:55 Go to previous messageGo to next message
Amel Jakupovic is currently offline Amel Jakupovic
Messages: 52
Registered: March 2010
Member
is service started in standalone springdm?
Re: Remote Service Registration with Riena 1.2.0 [message #546315 is a reply to message #546310] Mon, 12 July 2010 13:09 Go to previous messageGo to next message
Dirk Steiner is currently offline Dirk Steiner
Messages: 10
Registered: June 2010
Location: Holzwickede, Germany
Junior Member
Yes, all services are started properly.
Re: Remote Service Registration with Riena 1.2.0 [message #546319 is a reply to message #546307] Mon, 12 July 2010 13:11 Go to previous messageGo to next message
Christian Campo is currently offline Christian Campo
Messages: 590
Registered: July 2009
Senior Member
Am 12.07.10 14:49, schrieb Dirk Steiner:
> Hi all,
>
> I wrote some services inside Eclipse and registered them as remote
> services via Riena (Spring DM and inside Activators).
>
> Everythins worked fine, when I let it run inside Eclipse. But when my
> OSGi server is configured and started similar to my Eclipse environment,
> services start, but they won't be restired as remote services, althow I
> set all service properties.
> What do I have to do to use get my services registered inside a stand
> alone server?
>
> I need help as fast as possible, because services should be used in
> prudutive environment soon.
>
> Kind regards
>
> Dirk
You are probably missing some bundles like org.eclipse.riena.communication.publisher.hessian or
org.eclipse.riena.communication.publisher and you need to make sure that these bundles are actually started. They scan
the OSGi service registry and make sure that all OSGi Services with property are published as remote services.....

- hope that helps....

christian

feel free to put my direct email address in CC if it is urgent and you need more help
icon14.gif  Re: Remote Service Registration with Riena 1.2.0 [message #546352 is a reply to message #546319] Mon, 12 July 2010 14:18 Go to previous messageGo to next message
Dirk Steiner is currently offline Dirk Steiner
Messages: 10
Registered: June 2010
Location: Holzwickede, Germany
Junior Member
Hi Christian,

thank's a lot for that hint!

I forgot to start org.eclipse.riena.communication.publisher Embarrassed

I obviously lost control on configuring 119 bundles.

Kind regards

Dirk
Re: Remote Service Registration with Riena 1.2.0 [message #586437 is a reply to message #546319] Mon, 12 July 2010 14:18 Go to previous message
Dirk Steiner is currently offline Dirk Steiner
Messages: 10
Registered: June 2010
Location: Holzwickede, Germany
Junior Member
Hi Christian,

thank's a lot for that hint!

I forgot to start org.eclipse.riena.communication.publisher :blush:

I obviously lost control on configuring 119 bundles.

Kind regards

Dirk
Previous Topic:Remote Service Registration with Riena 1.2.0
Next Topic:openSecure project
Goto Forum:
  


Current Time: Thu Oct 23 15:26:25 GMT 2014

Powered by FUDForum. Page generated in 0.02062 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software