Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Using midp_2.0 library in Eclipse
Using midp_2.0 library in Eclipse [message #545600] Thu, 08 July 2010 11:31 Go to next message
No real name is currently offline No real nameFriend
Messages: 2
Registered: July 2010
Junior Member
Hi.

I have the following problem using eclipse for mobile development:

I installed eclipse with the necessary extensions for mobile development and imported devices from the devkit. I created a new MIDlet project for CLCC 1.1 and MIDP 2.1. Now I am wondering why eclipse is using the midp_1.0 library instead of midp_2.0. I searched a lot and was not able to find a solution, so I hope one of you can help me. This is the first time I am trying to develop a tool for a mobile device, so I may missed an important setting. If you need more information feel free to ask. Thanks.

EDIT: This might be important to know. I am using the Java_ME_platform_SDK_3.0

SOLUTION:
In the past years of developing java software it was always the same. After hours of debugging and posting a topic like this, the solution jumps in ^^.
The emulator i used had a maybe wrong description and was not able to use midp_2.0 even though it was listed.

[Updated on: Thu, 08 July 2010 11:50]

Report message to a moderator

Re: Using midp_2.0 library in Eclipse [message #546023 is a reply to message #545600] Fri, 09 July 2010 22:34 Go to previous messageGo to next message
Gorkem Ercan is currently offline Gorkem ErcanFriend
Messages: 166
Registered: July 2009
Senior Member
Unfortunately there is a problem with WTK 3.0 and MTJ working together on the current release. Your problem seems to be related to that. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=315209 for details and follow up for the fix.
--
Gorkem
Re: Using midp_2.0 library in Eclipse [message #581238 is a reply to message #545600] Fri, 09 July 2010 22:34 Go to previous message
Gorkem Ercan is currently offline Gorkem ErcanFriend
Messages: 166
Registered: July 2009
Senior Member
Unfortunately there is a problem with WTK 3.0 and MTJ working together on the current release. Your problem seems to be related to that. See https://bugs.eclipse.org/bugs/show_bug.cgi?id=315209 for details and follow up for the fix.
--
Gorkem
Previous Topic:MTJ and Java SDK 3: bullshit
Next Topic:persistance
Goto Forum:
  


Current Time: Fri Nov 28 23:16:40 GMT 2014

Powered by FUDForum. Page generated in 0.01595 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software