Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Cannot Execute Script in IDE
icon8.gif  Cannot Execute Script in IDE [message #545435] Wed, 07 July 2010 18:23 Go to next message
Howard Maler is currently offline Howard MalerFriend
Messages: 3
Registered: July 2010
Junior Member
Hi

I am running CentOS 5.5 32 Bit

I have downloaded the all-in-one from zend and unpacked it to /bin/eclipse

I have setup the zend debugger successfully, and phpinfo() reports that the zend debugger is present

I have created a phpproject in a brand new workspace

I have created a new php file, called 'hello.php'

I have populated it with simple output statements to establish that the debugger works.

when I attempt to run I get

>>
Cannot run program " bin/eclipse/plugins/org.zend.php.debug.debugger_5.3.18.v2010 0603/resource/php5/php-cgi "

error=13, permission denied.
<<

Well I find that interesting since that location does not exists.

I have no idea what this means and have spent hours attempting to find where to set this path.

-- HELP --, I have fallen and can't get up

Pretend I am a total idiot, can someone please explain how to correct this problem.

Eclipse is located at '/bin/eclipse'
Zend debugger is located at "/opt/ZendDebugger-5.2.14-linux-glibc23-i386"
php is at "var/bin"
project is at "/projects/eclipse/demo/"

I have provided lines from the php.ini

>>
;;;;;;;;;;;;;;;;;;;
; Module Settings ;
;;;;;;;;;;;;;;;;;;;

[DEBUGGER]
;zend php debugger
zend_extension = /opt/ZendDebugger-5.2.14-linux-glibc23-i386/5_1_x_comp/ZendD ebugger.so
zend_debugger.allow_hosts=127.0.0.1/192.168.15
zend_debugger.expose_remotely=always

[Date]
; Defines the default timezone used by the date functions
;date.timezone =
<<










Re: Cannot Execute Script in IDE [message #545451 is a reply to message #545435] Wed, 07 July 2010 19:58 Go to previous messageGo to next message
Howard Maler is currently offline Howard MalerFriend
Messages: 3
Registered: July 2010
Junior Member
Additional Info

Started over

Realized that the php was referencing the wrong path for php-cgi, and not using the
one that I have installed on the system. However the path is incorrect.

Extracted to "/usr/bin/eclipse"

Started Eclipse PHP Version
Created a brand new clean workspace at "/projects/demos/php"
Created a new php file "phpdemo"

Populated it with output statments
>>
<?php
echo "<p>Hello World</p>";
echo "<p><u>I am a PHP Script:</u> <b>PHPDemo.php</b></p>\n";
?>
<<

which produces the expected output in my web browser

When I attempt to run the script inside the IDE I get
>>
Cannot run program "/usr/bin/eclipse/plugins/
org.zend.php.debug.debugger.linux.x86_5.3.18.v20100603/
resources/php5/php-cgi" (in directory /projects/demos/php"):
error=13, Permission denied
<<

Ok here is the mystery, the location is actually

" /usr/bin/eclipse/plugins/org.zend.php.debug.debugger.linux.x 86_5.3.18.v20100603/
resources/php5/ext/php-cgi"

After several lost hours attempting to reset the path, I find myself writing this

Would someone please help me (explain it like I was a third grader), as I have a
deadline to meet
RESOLVED: Re: Cannot Execute Script in IDE [message #545740 is a reply to message #545451] Thu, 08 July 2010 20:18 Go to previous message
Howard Maler is currently offline Howard MalerFriend
Messages: 3
Registered: July 2010
Junior Member
I had set up eclipse as the root user and attempted to run it as a user that did not belong to the root group.

Adding the user to the root group and doing a 'chmod' solved the problem, the php executable needed to be able to execute and thus needed execu Embarrassed te privileges


Embarrassed
Previous Topic:Information: breakpoints stop working when using xdebug with PDT.
Next Topic:context sensitive highlighting ... ?
Goto Forum:
  


Current Time: Sat Nov 22 17:02:38 GMT 2014

Powered by FUDForum. Page generated in 0.15145 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software