Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Strange content type and encoding detection
Strange content type and encoding detection [message #545295] Wed, 07 July 2010 11:43 Go to next message
Tchick is currently offline Tchick
Messages: 2
Registered: July 2009
Junior Member
I have a file named changes.xml, with an xml header like this:
<?xml version="1.0" encoding="ISO-8859-15"?>
The properties dialog of the file looks like this:
Quote:

...
Type: File (XML)
...
Text file encoding:
determined from content: ISO-8859-15



Everything looks OK.

BUT: in my friend's eclipse, the properties dialog says this:
Quote:

...
Type: File (Base JPA content)
...
Text file encoding:
determined from content: UTF-8



There is no changes.xml file configured as a JPA content type under General -> Content Types.

Does anybody know what's going on here?

Greetings,
Tchick.
Re: Strange content type and encoding detection [message #545401 is a reply to message #545295] Wed, 07 July 2010 15:44 Go to previous messageGo to next message
Walter Harley is currently offline Walter Harley
Messages: 847
Registered: July 2009
Senior Member
"Tchick" <monsorno-nospam@gmx.de> wrote in message
news:i11p9e$5vb$1@build.eclipse.org...
>I have a file named changes.xml, with an xml header like this:
> <?xml version="1.0" encoding="ISO-8859-15"?>The properties dialog of the
> file looks like this:
> Quote:
>> ...
>> Type: File (XML)
>> ...
>> Text file encoding:
>> determined from content: ISO-8859-15
>
>
> Everything looks OK.
>
> BUT: in my friend's eclipse, the properties dialog says this:
> Quote:
>> ...
>> Type: File (Base JPA content)
>> ...
>> Text file encoding:
>> determined from content: UTF-8
>
>
> There is no changes.xml file configured as a JPA content type under
> General -> Content Types.
>
> Does anybody know what's going on here?

I wonder whether your friend has some additional Eclipse plugins installed
which you do not have? I believe each plugin can contribute to the process
that decides what the file's encoding and contents are. Maybe he has some
JPA functionality installed that you don't?
Re: Strange content type and encoding detection [message #548277 is a reply to message #545401] Wed, 21 July 2010 10:47 Go to previous message
Tchick is currently offline Tchick
Messages: 2
Registered: July 2009
Junior Member
Thanks for your help. Yes that could be the reason.

We decided not to take more research into this issue, but all start with a fresh eclipse 3.6 and some plugins installation. The problem is not occurred again since then.

Very Happy
Previous Topic:How to add submenu using extension "org.eclipse.ui.menus"?
Next Topic:Platform Debug: Restrict launch configuration to one instance?
Goto Forum:
  


Current Time: Sun Oct 26 08:31:00 GMT 2014

Powered by FUDForum. Page generated in 0.01821 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software