Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » B3 » macos carbon broken?
macos carbon broken? [message #544995] Tue, 06 July 2010 09:52 Go to next message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Hi all,

I have created a working b3aggr model for a composite repository containing
the Helios update site without mirroring artifacts.

However, if I enable these configurations:
* macosx, carbon, x86
* macosx, carbon, ppc
then the build fails with the following error during verifying these
configs:

Missing requirement for filter properties ~= $0:
org.eclipse.rcp.configuration.feature.group 1.0.0.I20100608-0911 requires
'toolingorg.eclipse.equinox.launcher.carbon.macosx [1.1.0.v20100503]' but it
could not be found

Is this a bug? If yes, it is maybe the same one as the one described in the
last post in this newsgroup ("Unable to build Helios release with b3")?

Thanks for your help.

Regards,
Axel
Re: macos carbon broken? [message #544996 is a reply to message #544995] Tue, 06 July 2010 09:53 Go to previous messageGo to next message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Note that macosx with cocoa does work without problems.

Greetings
Axel


Axel Guckelsberger wrote:

> Hi all,
>
> I have created a working b3aggr model for a composite repository
> containing the Helios update site without mirroring artifacts.
>
> However, if I enable these configurations:
> * macosx, carbon, x86
> * macosx, carbon, ppc
> then the build fails with the following error during verifying these
> configs:
>
> Missing requirement for filter properties ~= $0:
> org.eclipse.rcp.configuration.feature.group 1.0.0.I20100608-0911 requires
> 'toolingorg.eclipse.equinox.launcher.carbon.macosx [1.1.0.v20100503]' but
> it could not be found
>
> Is this a bug? If yes, it is maybe the same one as the one described in
> the last post in this newsgroup ("Unable to build Helios release with
> b3")?
>
> Thanks for your help.
>
> Regards,
> Axel
Re: macos carbon broken? [message #544997 is a reply to message #544996] Tue, 06 July 2010 10:08 Go to previous message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Could it be possible that this works only when building the composite
repository on a Windows machine? (just like with the branding iron bug, too)

Regards
Axel


Axel Guckelsberger wrote:

> Note that macosx with cocoa does work without problems.
>
> Greetings
> Axel
>
>
> Axel Guckelsberger wrote:
>
>> Hi all,
>>
>> I have created a working b3aggr model for a composite repository
>> containing the Helios update site without mirroring artifacts.
>>
>> However, if I enable these configurations:
>> * macosx, carbon, x86
>> * macosx, carbon, ppc
>> then the build fails with the following error during verifying these
>> configs:
>>
>> Missing requirement for filter properties ~= $0:
>> org.eclipse.rcp.configuration.feature.group 1.0.0.I20100608-0911 requires
>> 'toolingorg.eclipse.equinox.launcher.carbon.macosx [1.1.0.v20100503]' but
>> it could not be found
>>
>> Is this a bug? If yes, it is maybe the same one as the one described in
>> the last post in this newsgroup ("Unable to build Helios release with
>> b3")?
>>
>> Thanks for your help.
>>
>> Regards,
>> Axel
Re: macos carbon broken? [message #611586 is a reply to message #544995] Tue, 06 July 2010 09:53 Go to previous message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Note that macosx with cocoa does work without problems.

Greetings
Axel


Axel Guckelsberger wrote:

> Hi all,
>
> I have created a working b3aggr model for a composite repository
> containing the Helios update site without mirroring artifacts.
>
> However, if I enable these configurations:
> * macosx, carbon, x86
> * macosx, carbon, ppc
> then the build fails with the following error during verifying these
> configs:
>
> Missing requirement for filter properties ~= $0:
> org.eclipse.rcp.configuration.feature.group 1.0.0.I20100608-0911 requires
> 'toolingorg.eclipse.equinox.launcher.carbon.macosx [1.1.0.v20100503]' but
> it could not be found
>
> Is this a bug? If yes, it is maybe the same one as the one described in
> the last post in this newsgroup ("Unable to build Helios release with
> b3")?
>
> Thanks for your help.
>
> Regards,
> Axel
Re: macos carbon broken? [message #611588 is a reply to message #544996] Tue, 06 July 2010 10:08 Go to previous message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Could it be possible that this works only when building the composite
repository on a Windows machine? (just like with the branding iron bug, too)

Regards
Axel


Axel Guckelsberger wrote:

> Note that macosx with cocoa does work without problems.
>
> Greetings
> Axel
>
>
> Axel Guckelsberger wrote:
>
>> Hi all,
>>
>> I have created a working b3aggr model for a composite repository
>> containing the Helios update site without mirroring artifacts.
>>
>> However, if I enable these configurations:
>> * macosx, carbon, x86
>> * macosx, carbon, ppc
>> then the build fails with the following error during verifying these
>> configs:
>>
>> Missing requirement for filter properties ~= $0:
>> org.eclipse.rcp.configuration.feature.group 1.0.0.I20100608-0911 requires
>> 'toolingorg.eclipse.equinox.launcher.carbon.macosx [1.1.0.v20100503]' but
>> it could not be found
>>
>> Is this a bug? If yes, it is maybe the same one as the one described in
>> the last post in this newsgroup ("Unable to build Helios release with
>> b3")?
>>
>> Thanks for your help.
>>
>> Regards,
>> Axel
Previous Topic:macos carbon broken?
Next Topic:Aggregator: Transformation failed: null
Goto Forum:
  


Current Time: Fri Oct 31 18:49:43 GMT 2014

Powered by FUDForum. Page generated in 0.02370 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software