Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Upgrade Birt Engine 2.3.2 to 2.6(Upgrade Birt Engine 2.3.2 to 2.6)
icon5.gif  Upgrade Birt Engine 2.3.2 to 2.6 [message #544692] Mon, 05 July 2010 09:43 Go to next message
Wael Mashal is currently offline Wael MashalFriend
Messages: 10
Registered: January 2010
Junior Member
Hi All

i have a task to upgrade the Birt Engine that already installed on our application, what we have now Birt version 2.3.2 and ineed to upgrade it to the new release 2.6 ?

my questions , which jars i need to replace them or i need to replace all the runtime folder?

best regards

[Updated on: Mon, 05 July 2010 12:50]

Report message to a moderator

Re: Upgrade Birt Engine 2.3.2 to 2.6 [message #545043 is a reply to message #544692] Tue, 06 July 2010 14:00 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Are you upgrading the viewer or just the engine? If you are replacing
the engine just download the 2.6 runtime and replace your current
birt-runtime-2_3_2\ReportEngine\lib with
birt-runtime-2_6_0\ReportEngine\lib and your
birt-runtime-2_3_2\ReportEngine\plugins with
birt-runtime-2_6_0\ReportEngine\plugins. Also delete
birt-runtime-2_3_2\ReportEngine\configuration directory and replace it
with birt-runtime-2_6_0\ReportEngine\configuration.

Jason


On 7/5/2010 5:43 AM, Wael Mashal wrote:
> Hi All
>
> i have a task to upgrade the Birt Engine that already installed on our
> application, what we have now Birt version 2.3.2 and ineed to upgrade it
> to the new release 2.6 ?
> my questions , which jars i need to replace them or i need to replace
> all the runtime folder?
>
> best regards
>
Re: Upgrade Birt Engine 2.3.2 to 2.6 [message #545340 is a reply to message #545043] Wed, 07 July 2010 13:30 Go to previous messageGo to next message
Katerina  is currently offline Katerina Friend
Messages: 4
Registered: January 2010
Junior Member
Hello,
until now I was using birt-runtime-2_5_1.

I just downloaded the birt-runtime-2_6_0. When I run my application I get the following error:

Jul 7, 2010 3:25:15 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet jsp threw exception
java.lang.NoSuchMethodError: org.eclipse.birt.report.engine.api.EngineConfig.getLogRollin gSize()I
at org.eclipse.birt.report.engine.api.impl.ReportEngine.intiali zeLogger(ReportEngine.java:221)
at org.eclipse.birt.report.engine.api.impl.ReportEngine.<init>(ReportEngine.java:133)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$ 1.run(ReportEngineFactory.java:18)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$ 1.run(ReportEngineFactory.java:1)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory. createReportEngine(ReportEngineFactory.java:14)
at com.qmplus.common.util.birt.BirtEngine.createEngineInstance( BirtEngine.java:122)
at com.qmplus.common.util.birt.BirtEngine.getBirtEngine(BirtEng ine.java:39)




I even tried the birt-runtime-2_5_2 but then I got another error:

Jul 7, 2010 3:12:01 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet jsp threw exception
java.lang.NoSuchMethodError: org.eclipse.birt.report.engine.api.EmitterInfo.setOverridePr iority(I)V
at org.eclipse.birt.report.engine.extension.internal.ExtensionM anager.loadEmitterExtensionDefns(ExtensionManager.java:629)
at org.eclipse.birt.report.engine.extension.internal.ExtensionM anager. <init>(ExtensionManager.java:148)
at org.eclipse.birt.report.engine.extension.internal.ExtensionM anager.createInstance(ExtensionManager.java:161)
at org.eclipse.birt.report.engine.extension.internal.ExtensionM anager.getInstance(ExtensionManager.java:170)
at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.<init >(ReportEngineHelper.java:81)
at org.eclipse.birt.report.engine.api.impl.ReportEngine.<init>(ReportEngine.java:136)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$ 1.run(ReportEngineFactory.java:18)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory$ 1.run(ReportEngineFactory.java:1)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.birt.report.engine.api.impl.ReportEngineFactory. createReportEngine(ReportEngineFactory.java:14)
at com.qmplus.common.util.birt.BirtEngine.createEngineInstance( BirtEngine.java:122)
at com.qmplus.common.util.birt.BirtEngine.getBirtEngine(BirtEng ine.java:39)


Is there some compatibility issue between birt-runtime versions? I tried deleting
everything in WEB-INF\platform\configuration except
the config.ini file as was suggested in another thread for a similar problem, but nothing changed. Any suggestions?

Thanks!
Katerina
Re: Upgrade Birt Engine 2.3.2 to 2.6 [message #547181 is a reply to message #544692] Thu, 15 July 2010 20:19 Go to previous messageGo to next message
Brian is currently offline BrianFriend
Messages: 8
Registered: May 2010
Location: Madison
Junior Member
I am trying to do the same thing, upgrade from 2.3.0 to 2.6. Does anyone what I have to do to get it up and running with 2.6?
Re: Upgrade Birt Engine 2.3.2 to 2.6 [message #547372 is a reply to message #547181] Fri, 16 July 2010 13:33 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

On 7/15/2010 4:19 PM, Brian wrote:
> I am trying to do the same thing, upgrade from 2.3.0 to 2.6. Does
> anyone what I have to do to get it up and running with 2.6?
Did you try:
Are you upgrading the viewer or just the engine? If you are replacing
the engine just download the 2.6 runtime and replace your current
birt-runtime-2_3_2\ReportEngine\lib with
birt-runtime-2_6_0\ReportEngine\lib and your
birt-runtime-2_3_2\ReportEngine\plugins with
birt-runtime-2_6_0\ReportEngine\plugins. Also delete
birt-runtime-2_3_2\ReportEngine\configuration directory and replace it
with birt-runtime-2_6_0\ReportEngine\configuration.

Jason
Re: Upgrade Birt Engine 2.3.2 to 2.6 [message #547381 is a reply to message #547372] Fri, 16 July 2010 14:22 Go to previous message
Brian is currently offline BrianFriend
Messages: 8
Registered: May 2010
Location: Madison
Junior Member
I took all the plugins/configurations/lib files in the2.6 report viewer and copied them over the old 2.3.0 files that were in are web app. It seems that we have integrated 2.3.0 report viewer with are app. I just replaced all the 2.3 with 2.6 report viewer jar's/jsp's and it worked.

Well it looks what I did is what you told me to do. This was just to see if going to 2.6 would clear up some other out standing problems.


The other thing that I noticed is, with 2.3.0 you could have a data type of any and now, 2.6 do not like this, however from what I have tested, It seems to still work.


Thanks

[Updated on: Fri, 16 July 2010 14:26]

Report message to a moderator

Previous Topic:DataSource Property Binding
Next Topic:Firewall Issues? [2.3.2]
Goto Forum:
  


Current Time: Sun Dec 21 02:38:08 GMT 2014

Powered by FUDForum. Page generated in 0.01703 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software