Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits
Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits [message #544446] Fri, 02 July 2010 17:15 Go to next message
Philippe Cayouette is currently offline Philippe CayouetteFriend
Messages: 9
Registered: July 2010
Junior Member
On Ubuntu 10.04 desktop 64 bits:
On a fresh package of Eclipse Helios CDT from eclipse.org, with ~/.eclipse deleted, I installed the plugin "Eclipse XML Editors and Tools" which I used in the past on erlier version of Eclipse and Ubuntu. However, it doesn't seem to recognize XML files... Eclipse still see them as regular text files and I can't find a way to make it see them or open them as XML files, with the internal XML editor.

That being said, I tried the exact same thing, but on WinXP Pro 32 bits and it worked without problem.

Your help is much appreciated.
Re: Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits [message #544459 is a reply to message #544446] Fri, 02 July 2010 18:02 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2342
Registered: July 2009
Senior Member
On 7/2/2010 1:15 PM, Philippe Cayouette wrote:
> On Ubuntu 10.04 desktop 64 bits:
> On a fresh package of Eclipse Helios CDT from eclipse.org, with
> ~/.eclipse deleted, I installed the plugin "Eclipse XML Editors and
> Tools" which I used in the past on erlier version of Eclipse and Ubuntu.
> However, it doesn't seem to recognize XML files... Eclipse still see
> them as regular text files and I can't find a way to make it see them or
> open them as XML files, with the internal XML editor.
>
> That being said, I tried the exact same thing, but on WinXP Pro 32 bits
> and it worked without problem.
>
> Your help is much appreciated.

Files opened previously will open with the last editor you used on them,
unless you choose "Open with" from the file's context menu. If the
editor is not available from that menu, are the preferences for it
showing up?

--
Nitin Dahyabhai
Eclipse WTP Source Editing and JSDT
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits [message #544471 is a reply to message #544459] Fri, 02 July 2010 18:58 Go to previous messageGo to next message
Philippe Cayouette is currently offline Philippe CayouetteFriend
Messages: 9
Registered: July 2010
Junior Member
Here are useful information:
http://www.spoluck.ca/files/1.JPG

When I right click on a XML file:
http://www.spoluck.ca/files/2.JPG

When I choose other in the contextual menu of the XML file:
http://www.spoluck.ca/files/3.JPG

I don't see any preference for the plugin anywhere I look.

Thanks
Re: Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits [message #545067 is a reply to message #544471] Tue, 06 July 2010 14:30 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2342
Registered: July 2009
Senior Member
The contents of your log files may hold some information about why the
XML plug-ins aren't loading. Otherwise I'm not sure how to proceed.

http://wiki.eclipse.org/IRC_FAQ#Where_are_Eclipse.27s_log_fi les_located.3F

--
Nitin Dahyabhai
Eclipse WTP Source Editing and JSDT
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits [message #659722 is a reply to message #545067] Tue, 15 March 2011 11:00 Go to previous messageGo to next message
Matt  is currently offline Matt Friend
Messages: 1
Registered: March 2011
Junior Member
I realize it's been about 2 years since this thread, but I'm having identical problems while using Windows XP SP 3.0.
Re: Can't use Eclipse XML Editors and Tools in Helios on Ubuntu 10.04 64 bits [message #659745 is a reply to message #659722] Tue, 15 March 2011 13:15 Go to previous message
Philippe Cayouette is currently offline Philippe CayouetteFriend
Messages: 9
Registered: July 2010
Junior Member
Hi Matt,

My problem went away a few months ago, when I installed the very latest version of Eclipse Helios. What version are you currently using? You also have to make sure the repository URL is appropriate for the version of Eclipse you use.

I think I am using http://download.eclipse.org/releases/helios/ for my Helios install.
Previous Topic:JSP call the axis2 code generator
Next Topic:web resources in project explorer
Goto Forum:
  


Current Time: Mon Dec 22 00:46:46 GMT 2014

Powered by FUDForum. Page generated in 0.09100 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software