Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Problems compiling .g file
Problems compiling .g file [message #4883] Fri, 31 August 2007 09:18 Go to next message
Tor Neple is currently offline Tor NepleFriend
Messages: 57
Registered: July 2009
Member
Hello

When making changes to my .g file the Parser.java file does not get
updated. I do get an error in the "errors" section of the "problems" tab:


" 3.2.1/eclipse/plugins/org.eclipse.imp.lpg.metatooling_1.0.62 /templates/;C:/tools/Eclipse3.2.1/eclipse/plugins/lpg.runtim e_2.0.6/templates/ "
is an invalid option org.sintef.MOF2Text/src/mof2text/safari/parser
MOF2TextLexer.gi line 1 1188551373520 137

It seems as if the path for my eclipse installation has been truncated,
or rather some of the first path elements have been removed.

Any suggestions


Regards

Tor
Re: Problems compiling .g file [message #4951 is a reply to message #4883] Tue, 04 September 2007 14:37 Go to previous message
Stan Sutton is currently offline Stan SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Hi Tor,

Apologies for the slow response; we're just getting back from a four-day
weekend, during which our systems were shut down.

The particular option in question here is the "include path" option that
tells LPG where to look for template files that it uses in generating
all of the stuff that it generates.

I'm not sure where the specific message that you report is generated,
but I believe it must come out of the LPG executable, which is called in
the compile(..) method in the LPG builder. The LPG builder gets
information about the include path (and other preferences) from the IMP
preferences service and passes those values to the LPG executable in the
compile() method.

One place to start looking is in the LPG preferences, to see if a valid
value is stored for the "IncludePathToUse" preference. Is that value
truncated or complete? (You need to check the value that will be in
effect for the project in which your grammar file resides.)

Another thing to look at is the error log, to see if an exception is
thrown and, if so, whether it originates in the LPG compiler or
somewhere else. (Although I don't think this could be.)

Regards,

Stan


Tor Neple wrote:
> Hello
>
> When making changes to my .g file the Parser.java file does not get
> updated. I do get an error in the "errors" section of the "problems" tab:
>
>
> " 3.2.1/eclipse/plugins/org.eclipse.imp.lpg.metatooling_1.0.62 /templates/;C:/tools/Eclipse3.2.1/eclipse/plugins/lpg.runtim e_2.0.6/templates/ "
> is an invalid option org.sintef.MOF2Text/src/mof2text/safari/parser
> MOF2TextLexer.gi line 1 1188551373520 137
>
> It seems as if the path for my eclipse installation has been truncated,
> or rather some of the first path elements have been removed.
>
> Any suggestions
>
>
> Regards
>
> Tor
Re: Problems compiling .g file [message #566344 is a reply to message #4883] Tue, 04 September 2007 14:37 Go to previous message
Stan Sutton is currently offline Stan SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Hi Tor,

Apologies for the slow response; we're just getting back from a four-day
weekend, during which our systems were shut down.

The particular option in question here is the "include path" option that
tells LPG where to look for template files that it uses in generating
all of the stuff that it generates.

I'm not sure where the specific message that you report is generated,
but I believe it must come out of the LPG executable, which is called in
the compile(..) method in the LPG builder. The LPG builder gets
information about the include path (and other preferences) from the IMP
preferences service and passes those values to the LPG executable in the
compile() method.

One place to start looking is in the LPG preferences, to see if a valid
value is stored for the "IncludePathToUse" preference. Is that value
truncated or complete? (You need to check the value that will be in
effect for the project in which your grammar file resides.)

Another thing to look at is the error log, to see if an exception is
thrown and, if so, whether it originates in the LPG compiler or
somewhere else. (Although I don't think this could be.)

Regards,

Stan


Tor Neple wrote:
> Hello
>
> When making changes to my .g file the Parser.java file does not get
> updated. I do get an error in the "errors" section of the "problems" tab:
>
>
> " 3.2.1/eclipse/plugins/org.eclipse.imp.lpg.metatooling_1.0.62 /templates/;C:/tools/Eclipse3.2.1/eclipse/plugins/lpg.runtim e_2.0.6/templates/ "
> is an invalid option org.sintef.MOF2Text/src/mof2text/safari/parser
> MOF2TextLexer.gi line 1 1188551373520 137
>
> It seems as if the path for my eclipse installation has been truncated,
> or rather some of the first path elements have been removed.
>
> Any suggestions
>
>
> Regards
>
> Tor
Previous Topic:Problems compiling .g file
Next Topic:Problems with LPG parser
Goto Forum:
  


Current Time: Mon Nov 24 03:09:43 GMT 2014

Powered by FUDForum. Page generated in 0.04716 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software