Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » EGit installation
EGit installation [message #543396] Tue, 29 June 2010 05:56 Go to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

Hi, I recently downloaded Eclipse Helios Modeling and I then installed JGit and EGit but I can not share any project using Git.

Through Help->About->Installation details I can see that the features EGit and JGit were installed (version 0.8.4) but in the list of plugins loaded I can not find any plugins starting with org.eclipse.egit or org.eclipse.jgit

how can I find out the problem?

Thank you,

Federico


Re: EGit installation [message #543916 is a reply to message #543396] Thu, 01 July 2010 02:12 Go to previous messageGo to next message
Kay Huber is currently offline Kay Huber
Messages: 36
Registered: July 2009
Member
How did you install egit? Have you been using the Helios update site (http://download.eclipse.org/releases/helios)?

In the plugin's list you should see plugins named "Git Team Provider ..." from the provider "Eclipse EGit".

Regards
Kay
Re: EGit installation [message #544305 is a reply to message #543396] Fri, 02 July 2010 05:51 Go to previous messageGo to next message
AndreaZ  is currently offline AndreaZ
Messages: 4
Registered: July 2010
Junior Member
same problem Sad

i see egit/jgit (0.8.4) installed in "installed software" but not on "plug-ins"

i installed egit from helios official repository with eclipse "install new software..." dialog

i tried to remove whole eclipse cdt, included .eclipse and workspace directory on my profile

eclipse helios cdt on windows vista
Re: EGit installation [message #544311 is a reply to message #544305] Fri, 02 July 2010 06:08 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

It seems to me that on Windows 7/Vista it matters if you install eclipse under C:\Program Files instead of a non-system directory.

Have you perphas Eclipse installed under C:\Program Files?


Re: EGit installation [message #544515 is a reply to message #544311] Sat, 03 July 2010 02:20 Go to previous messageGo to next message
AndreaZ  is currently offline AndreaZ
Messages: 4
Registered: July 2010
Junior Member
yes, it is on c:\program files

i ran eclipse as administrator, reinstalled egit and now it works

before egit files was on <myhome>\.eclipse instead on c:\program files

thanks
Re: EGit installation [message #545058 is a reply to message #544515] Tue, 06 July 2010 10:38 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

Ok, I tried also installing it on different machines: it seems that to install it not as an admin and having all plugins working correctly you have to put it not under c:\program files (or equivalent dirs). It seems to me a permissions/privilege problem.

Re: EGit installation [message #581880 is a reply to message #543396] Thu, 01 July 2010 02:12 Go to previous messageGo to next message
Kay Huber is currently offline Kay Huber
Messages: 36
Registered: July 2009
Member
How did you install egit? Have you been using the Helios update site (http://download.eclipse.org/releases/helios)?

In the plugin's list you should see plugins named "Git Team Provider ..." from the provider "Eclipse EGit".

Regards
Kay
Re: EGit installation [message #581901 is a reply to message #543396] Fri, 02 July 2010 05:51 Go to previous messageGo to next message
AndreaZ  is currently offline AndreaZ
Messages: 4
Registered: July 2010
Junior Member
same problem :(

i see egit/jgit (0.8.4) installed in "installed software" but not on "plug-ins"

i installed egit from helios official repository with eclipse "install new software..." dialog

i tried to remove whole eclipse cdt, included .eclipse and workspace directory on my profile

eclipse helios cdt on windows vista
Re: EGit installation [message #581915 is a reply to message #544305] Fri, 02 July 2010 06:08 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

It seems to me that on Windows 7/Vista it matters if you install eclipse under C:\Program Files instead of a non-system directory.

Have you perphas Eclipse installed under C:\Program Files?
--
website: http://www.federico-tomassetti.it


Re: EGit installation [message #581932 is a reply to message #581915] Sat, 03 July 2010 02:20 Go to previous messageGo to next message
AndreaZ  is currently offline AndreaZ
Messages: 4
Registered: July 2010
Junior Member
yes, it is on c:\program files

i ran eclipse as administrator, reinstalled egit and now it works

before egit files was on <myhome>\.eclipse instead on c:\program files

thanks
Re: EGit installation [message #581981 is a reply to message #544515] Tue, 06 July 2010 10:38 Go to previous message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

Ok, I tried also installing it on different machines: it seems that to install it not as an admin and having all plugins working correctly you have to put it not under c:\program files (or equivalent dirs). It seems to me a permissions/privilege problem.
--
website: http://www.federico-tomassetti.it


Previous Topic:EGit not working in Galileo 3.5.2?
Next Topic:Import remote git repository in one folder and create project in another one
Goto Forum:
  


Current Time: Sun Apr 20 09:39:24 EDT 2014

Powered by FUDForum. Page generated in 0.01976 seconds