Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » content.xml missing when building against Helios (RESOLVED)
content.xml missing when building against Helios (RESOLVED) [message #543259] Mon, 28 June 2010 20:23 Go to next message
Michael Xia is currently offline Michael Xia
Messages: 8
Registered: July 2009
Junior Member
Hi, we currently run into a problem with our build after updating to use Eclipse 3.6 as the base with its launcher and builder plugins (was using 3.5.2). We noticed an issue where content.xml is missing from the resulted content.jar file, even though everything else built successfully (features, plugins, and artifacts.jar). As a result, the repo is not being recognized as a valid update site. Are there additional steps we need to add to our build.xml besides updating the variables in build_local.properties to get content.xml generated correctly in 3.6?

Thanks.

[Updated on: Mon, 28 June 2010 21:27]

Report message to a moderator

Re: content.xml missing when building against Helios (RESOLVED) [message #543268 is a reply to message #543259] Mon, 28 June 2010 21:28 Go to previous messageGo to next message
Michael Xia is currently offline Michael Xia
Messages: 8
Registered: July 2009
Junior Member
Resolved the issue by using org.eclipse.equinox.p2.metadata.generator.EclipseGenerator to categorize the site instead of org.eclipse.equinox.p2.publisher.CategoryPublisher.
Re: content.xml missing when building against Helios (RESOLVED) [message #606200 is a reply to message #543259] Mon, 28 June 2010 21:28 Go to previous message
Michael Xia is currently offline Michael Xia
Messages: 8
Registered: July 2009
Junior Member
Resolved the issue by using org.eclipse.equinox.p2.metadata.generator.EclipseGenerator to categorize the site instead of org.eclipse.equinox.p2.publisher.CategoryPublisher.
Previous Topic:content.xml missing when building against Helios
Next Topic:chmod touchpoint failed with @artifact not substituted in Helios
Goto Forum:
  


Current Time: Mon Sep 22 04:18:46 GMT 2014

Powered by FUDForum. Page generated in 0.11848 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software