Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » EL validation error for quote escaping
EL validation error for quote escaping [message #542583] Fri, 25 June 2010 07:32 Go to next message
Michael Krkoska is currently offline Michael Krkoska
Messages: 11
Registered: July 2009
Junior Member
Hi all,

I just installed Helios and I get "Unable to analyze EL expression due to lexical analysis error" for these valid EL expressions:
${'\"'}
${fn:replace(name,'\"','')}

I found several bug reports for this, which are supposed to be resolved: 151065, 150794 and lots of duplicates.

So this seems to be a regression in 3.2. I am pretty certain, that there is already a bug open for that, but I fail to find it in bugzilla (I hate that search). I wouldn't like to create the 23rd bug report for this...

Does anybody know the corresponding bug report for this regression or even a workaround?

Thanks,
Michael
Re: EL validation error for quote escaping [message #543144 is a reply to message #542583] Mon, 28 June 2010 10:50 Go to previous messageGo to next message
Nick Sandonato is currently offline Nick Sandonato
Messages: 125
Registered: July 2009
Senior Member
Hi Michael,

If it's comforting, there was no regression Wink It seems like the bugs listed (151065, 150794 and the duplicates associated with them) had a fix that corrected escaped quotes in JSP tags, but not actually in EL regions. We would need to track this with a new Bug.

[Updated on: Mon, 28 June 2010 10:51]

Report message to a moderator

Re: EL validation error for quote escaping [message #543243 is a reply to message #543144] Mon, 28 June 2010 14:58 Go to previous messageGo to next message
Michael Krkoska is currently offline Michael Krkoska
Messages: 11
Registered: July 2009
Junior Member
Hi Nick,

thanks for your answer! I don't know about the exact fixes for these bugs, but I know, that Eclipse 3.5.1 doesn't behave like this, while 3.6 does. That's why I called it a regression.

I'll open a bug report then.

Thanks,
Michael

[Updated on: Mon, 28 June 2010 14:58]

Report message to a moderator

Re: EL validation error for quote escaping [message #543372 is a reply to message #543243] Tue, 29 June 2010 05:01 Go to previous messageGo to next message
Michael Krkoska is currently offline Michael Krkoska
Messages: 11
Registered: July 2009
Junior Member
Oops, the regression is somewhere else:
I have set the Validation option "EL syntax problem" to "Warning". This has the expected effect for this bug in 3.5.1 but not in 3.6.
Re: EL validation error for quote escaping [message #543375 is a reply to message #543372] Tue, 29 June 2010 05:14 Go to previous message
Michael Krkoska is currently offline Michael Krkoska
Messages: 11
Registered: July 2009
Junior Member
I filed this bug report: https://bugs.eclipse.org/318281
Previous Topic:My JSF libraries won't publish - Gallieo
Next Topic:Apache Tomcat
Goto Forum:
  


Current Time: Wed Jul 23 10:07:24 EDT 2014

Powered by FUDForum. Page generated in 0.02544 seconds