Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Simple Feature Patch Question
Simple Feature Patch Question [message #542456] Thu, 24 June 2010 22:13 Go to next message
Zirb Schaden is currently offline Zirb Schaden
Messages: 2
Registered: June 2010
Junior Member
Hello, I have a plugin, version=2.0.0, a feature version=2.0.0, and an update site with said feature. All is well in the universe, users add my update site and they get my feature/plugin...

Now, I want to make a bug update. If I make the change to the plugin, and "Build All" the update site, nothing happens. If I bump the plugin's version to 2.0.1 and Build All, nothing happens. If I bump both plugin and feature versions to 2.0.1 and Build All, then the new feature is available but not through the "Search for updates of the currently installed features" -- instead, users have to Search for new features, process the update sites, and then select the new feature version.

Next, I tried creating a Feature Patch project, set the dependency on the other feature, and set the feature patch version to 2.0.1 and Build All, but it doesn't do anything. If I update my plugin to 2.0.1 as well, then it complains it can't find my 2.0.0 plugin (presumably since now I've got both features in the update site and only 1 plugin). However, if I remove the old feature from the update site, and build all, users do not get any updates.

Any thoughts?
Re: Simple Feature Patch Question [message #542595 is a reply to message #542456] Fri, 25 June 2010 11:55 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

You might want to ask your question over on eclipse.tools.equinox, as of
3.4 p2 deals with the updating.

Really, upping your feature from 2.0.0 to 2.0.1 should have made it
available for an update, especially if you feature lists your update
site and its the same update site that they got 2.0.0 from.

A feature patch (which will allow you to change the plugins) 1) should
be made optional and 2) will not be included as an update. Users would
have to install the feature patch as it's a new thing with a new namespace.

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse .platform.doc.isv/guide/workbench.htm


Re: Simple Feature Patch Question [message #542685 is a reply to message #542595] Fri, 25 June 2010 15:47 Go to previous message
Zirb Schaden is currently offline Zirb Schaden
Messages: 2
Registered: June 2010
Junior Member
Thanks! I added the Update site URL and it seems to work. The way I update it now is I bump the version of the plugin, bump the version of the feature, update the version of the plugin in the feature, add the new feature to the update site, build all, and now the plugin is automatically updated. There is one other thing in that Eclipse re-asks if the user accepts the license each time, is there a way around this?
Previous Topic:"Comparing identical expressions"
Next Topic:Detecting active editor change in my plugin
Goto Forum:
  


Current Time: Fri Oct 31 04:02:52 GMT 2014

Powered by FUDForum. Page generated in 0.27929 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software