Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » AM3 » problem on installing new am3 (difficults in launching?)
problem on installing new am3 [message #542264] Thu, 24 June 2010 11:57 Go to next message
Júlio is currently offline Júlio
Messages: 8
Registered: June 2010
Junior Member
Hi everybody

I'm new in atl and also in am3.

I'm using Eclipse 3.4, emf-xsd-SDK-2.6.0M7 and m2m-atl-runtime-3.1.0.

I have trying runnig an UML2OWL example, but I got the problem of not recognizing the am3 tag's by running the build.

I got from the " http://wiki.eclipse.org/ATL/User_Guide_-_The_ATL_Tools#ATL_a nt_tasks" that the tag's for atl 3.xx must be modified.

But my problem is in lunching am3. I have downloaded it from the SVN conforms to "http://wiki.eclipse.org/AM3/How_Install_New_AM3_From_SVN"

but I don't get how to execute am3 in Run-time workbench, and there are errors in the projects.

Is there any package of am3 binaries for just put it in the plugins and features eclipse's folder?

if yes, where? if not, how launching/execute am3 from source.

could you please help me?

Thank you very much for help!

Best wishes,

Júlio



Re: problem on installing new am3 [message #542349 is a reply to message #542264] Thu, 24 June 2010 15:16 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 607
Registered: July 2009
Senior Member
Hi Julio,

If you use ATL3.x, you have to use the "new" ATL ANT tasks as explained in the ATL user guide: http://wiki.eclipse.org/ATL/User_Guide_-_The_ATL_Tools#ATL_a nt_tasks

If you want to use ATL2.x with the "old" ANT tasks, you have to get the required plugins by following the instructions from http://wiki.eclipse.org/AM3/How_Install_AM3_From_SVN
You can also get a ready-to-use bundle with ATL2.x from http://docatlanmod.emn.fr/Eclipse_Bundles/AMMA_Prototype/AMM APrototypeEclipse.zip
The manual for these "old" tasks is available from http://wiki.eclipse.org/AM3_Ant_Tasks

I hope this help.

Best regards,

Hugo


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: problem on installing new am3 [message #542358 is a reply to message #542349] Thu, 24 June 2010 15:31 Go to previous messageGo to next message
Júlio is currently offline Júlio
Messages: 8
Registered: June 2010
Junior Member
Hi Hugo!
Thank you so much for your attention.

I'm using ATL3.x and actually using the ATL ANT tasks as explained in the ATL user guide that you have mentioned. The error as described before not happens anymore.

SO it means that I don't need to install am3?

I'm gonna use the OWL2XML.atl, an ATL transformation that transforms an OWL Model into an XML models with OWL/XML syntax elements.

I have heard it uses the XML extractor, so Do I need am3 for that?

if yes, I still will have the problem concerning to install the new am3 with ATL3.xx

Thank you so much

Regards

Júlio

Re: problem on installing new am3 [message #543847 is a reply to message #542349] Wed, 30 June 2010 18:33 Go to previous messageGo to next message
wafaa is currently offline wafaa
Messages: 163
Registered: January 2010
Location: Egypt
Senior Member
hi Júlio

can you please explain more your reply
ATL3.x am3 checkouts, where can I find them and what is the right link for SVS eclipse 3.5.2 to check them out.
please I wana download them as soon as possible



Hugo Bruneliere wrote on Thu, 24 June 2010 18:16
Hi Julio,

If you use ATL3.x, you have to use the "new" ATL ANT tasks as explained in the ATL user guide: http://wiki.eclipse.org/ATL/User_Guide_-_The_ATL_Tools#ATL_a nt_tasks

If you want to use ATL2.x with the "old" ANT tasks, you have to get the required plugins by following the instructions from http://wiki.eclipse.org/AM3/How_Install_AM3_From_SVN
You can also get a ready-to-use bundle with ATL2.x from http://docatlanmod.emn.fr/Eclipse_Bundles/AMMA_Prototype/AMM APrototypeEclipse.zip
The manual for these "old" tasks is available from http://wiki.eclipse.org/AM3_Ant_Tasks

I hope this help.

Best regards,

Hugo

Re: problem on installing new am3 [message #544145 is a reply to message #543847] Thu, 01 July 2010 18:15 Go to previous messageGo to next message
Júlio is currently offline Júlio
Messages: 8
Registered: June 2010
Junior Member
Hi

sorry, I didn't understand your question...

please be more objective and clear

regards
Re: problem on installing new am3 [message #552888 is a reply to message #542349] Sat, 14 August 2010 04:31 Go to previous messageGo to next message
Transformed is currently offline Transformed
Messages: 21
Registered: June 2010
Junior Member
Hi Hugo,

I tried installing AM3 for my existing configuration of eclipse ( ATL 3) and it showed wierd error so I left the installing for now.

I downloaded the preconfigured eclipse from the link that you provided.

When I switch to AM3 presepctive, it reports me an error.
Could not create the view: Plug-in "org.eclipse.am3.ui" was unable to instantiate class "org.eclipse.am3.ui.view.ResourceNavigatorAM3".

I dont have any clue abt this error.

Could you please help me out?
Re: problem on installing new am3 [message #552950 is a reply to message #552888] Sun, 15 August 2010 04:29 Go to previous messageGo to next message
Transformed is currently offline Transformed
Messages: 21
Registered: June 2010
Junior Member
Hello all,
I downloaded the version specified by Hugos for ATL 2.X and started working in AM3. Smile

Please discard this message.

[Updated on: Sun, 15 August 2010 04:30]

Report message to a moderator

Re: problem on installing new am3 [message #579981 is a reply to message #542264] Thu, 24 June 2010 15:16 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 607
Registered: July 2009
Senior Member
Hi Julio,

If you use ATL3.x, you have to use the "new" ATL ANT tasks as explained in the ATL user guide: http://wiki.eclipse.org/ATL/User_Guide_-_The_ATL_Tools#ATL_a nt_tasks

If you want to use ATL2.x with the "old" ANT tasks, you have to get the required plugins by following the instructions from http://wiki.eclipse.org/AM3/How_Install_AM3_From_SVN
You can also get a ready-to-use bundle with ATL2.x from http://docatlanmod.emn.fr/Eclipse_Bundles/AMMA_Prototype/AMM APrototypeEclipse.zip
The manual for these "old" tasks is available from http://wiki.eclipse.org/AM3_Ant_Tasks

I hope this help.

Best regards,

Hugo
--
--------------------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (INRIA & EMN)
Ecole des Mines de Nantes
Nantes - France
---------------------------------------------------------


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: problem on installing new am3 [message #580077 is a reply to message #579981] Wed, 30 June 2010 18:33 Go to previous messageGo to next message
wafaa is currently offline wafaa
Messages: 163
Registered: January 2010
Location: Egypt
Senior Member
hi Júlio

can you please explain more your reply
ATL3.x am3 checkouts, where can I find them and what is the right link for SVS eclipse 3.5.2 to check them out.
please I wana download them as soon as possible


Hugo Bruneliere wrote on Thu, 24 June 2010 18:16
> Hi Julio,
>
> If you use ATL3.x, you have to use the "new" ATL ANT tasks as explained in the ATL user guide: http://wiki.eclipse.org/ATL/User_Guide_-_The_ATL_Tools#ATL_a nt_tasks
>
> If you want to use ATL2.x with the "old" ANT tasks, you have to get the required plugins by following the instructions from http://wiki.eclipse.org/AM3/How_Install_AM3_From_SVN
> You can also get a ready-to-use bundle with ATL2.x from http://docatlanmod.emn.fr/Eclipse_Bundles/AMMA_Prototype/AMM APrototypeEclipse.zip
> The manual for these "old" tasks is available from http://wiki.eclipse.org/AM3_Ant_Tasks
>
> I hope this help.
>
> Best regards,
>
> Hugo
Re: problem on installing new am3 [message #580096 is a reply to message #580077] Thu, 01 July 2010 18:15 Go to previous messageGo to next message
Júlio is currently offline Júlio
Messages: 8
Registered: June 2010
Junior Member
Hi

sorry, I didn't understand your question...

please be more objective and clear

regards
Re: problem on installing new am3 [message #580147 is a reply to message #579981] Sat, 14 August 2010 04:32 Go to previous messageGo to next message
Transformed is currently offline Transformed
Messages: 21
Registered: June 2010
Junior Member
Hi Hugo,

I tried installing AM3 for my existing configuration of eclipse ( ATL 3) and it showed wierd error so I left the installing for now.

I downloaded the preconfigured eclipse from the link that you provided.

When I switch to AM3 presepctive, it reports me an error.

Could not create the view: Plug-in "org.eclipse.am3.ui" was unable to instantiate class "org.eclipse.am3.ui.view.ResourceNavigatorAM3".

I dont have any clue abt this error.

Could you please help me out?
Re: problem on installing new am3 [message #580164 is a reply to message #580147] Sun, 15 August 2010 04:30 Go to previous message
Transformed is currently offline Transformed
Messages: 21
Registered: June 2010
Junior Member
Hello all,
I managed to solve this.

Please discard this message.
Previous Topic:[KM3] Problems with meta-model extension
Next Topic:Interesting problem
Goto Forum:
  


Current Time: Thu Oct 30 13:52:47 GMT 2014

Powered by FUDForum. Page generated in 0.04676 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software