Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Problem updating to final helios release from RC6
Problem updating to final helios release from RC6 [message #542129] Wed, 23 June 2010 20:46 Go to next message
Del Myers is currently offline Del Myers
Messages: 82
Registered: July 2009
Member
Hi,

I was trying to update to the final Helios release today from RC6, and I got
this error.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.rcp,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing:
osgi.bundle,org.eclipse.equinox.p2.engine,2.0.0.v20100606
No repository found containing:
osgi.bundle,org.eclipse.help.base,3.5.0.v201006080911
No repository found containing: osgi.bundle,org.eclipse.platform,3.6.0.v201006080911
No repository found containing:
osgi.bundle,org.eclipse.platform.doc.user,3.6.0.v20100608
No repository found containing: osgi.bundle,org.eclipse.rcp,3.6.0.v201006080911
No repository found containing:
org.eclipse.update.feature,org.eclipse.equinox.p2.user.ui,2. 0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt
No repository found containing:
org.eclipse.update.feature,org.eclipse.help,1.2.0.v20100427- 7e7jEKFEx2XlnZinYPtgz03
No repository found containing:
org.eclipse.update.feature,org.eclipse.platform,3.6.0.v20100 602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
No repository found containing:
binary,org.eclipse.platform_root,3.6.0.v20100602-9gF78GpqFt6 trOGhL60z0oEx3fz-JKNwxPY
No repository found containing:
binary,org.eclipse.rcp.configuration_root.win32.win32.x86,1. 0.0.I20100608-0911
No repository found containing:
org.eclipse.update.feature,org.eclipse.rcp,3.6.0.v20100519-9 OArFKvFtsd7WLUKh-DcYTS
No repository found containing:
binary,org.eclipse.rcp_root,3.6.0.v20100519-9OArFKvFtsd7WLUK h-DcYTS

I simply used the "Check for Updates" action. The update manager said that I
needed to update my "Eclipse for RCP and RAP developers", but it gave me the
above error when I attempted the update. I have
http://download.eclipse.org/releases/helios and
http://download.eclipse.org/updates/3.6 as available software sites.

This is my build info:

eclipse.buildId=I20100603-1500
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
Framework arguments: -product org.eclipse.epp.package.rcp.product -product
org.eclipse.epp.package.rcp.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product
org.eclipse.epp.package.rcp.product

Anyone else having this problem? I know that helios just went live, so I may
just need to wait for the update sites to start working.

I've been told that it is possible to use another Eclipse install as an update
site as well. Is that true?

Del
Re: Problem updating to final helios release from RC6 [message #542130 is a reply to message #542129] Wed, 23 June 2010 20:50 Go to previous message
Del Myers is currently offline Del Myers
Messages: 82
Registered: July 2009
Member
Sorry, that was a typo. I meant RC4, not RC6.

On 23/06/2010 5:46 PM, Del Myers wrote:
> Hi,
>
> I was trying to update to the final Helios release today from RC6, and I
> got this error.
>
> An error occurred while collecting items to be installed
> session context was:(profile=epp.package.rcp,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
> action=).
> No repository found containing:
> osgi.bundle,org.eclipse.equinox.p2.engine,2.0.0.v20100606
> No repository found containing:
> osgi.bundle,org.eclipse.help.base,3.5.0.v201006080911
> No repository found containing:
> osgi.bundle,org.eclipse.platform,3.6.0.v201006080911
> No repository found containing:
> osgi.bundle,org.eclipse.platform.doc.user,3.6.0.v20100608
> No repository found containing:
> osgi.bundle,org.eclipse.rcp,3.6.0.v201006080911
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.equinox.p2.user.ui,2. 0.0.v20100503-897HFZ-FdHjO2NQo0sD_Nt
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.help,1.2.0.v20100427- 7e7jEKFEx2XlnZinYPtgz03
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.platform,3.6.0.v20100 602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY
>
> No repository found containing:
> binary,org.eclipse.platform_root,3.6.0.v20100602-9gF78GpqFt6 trOGhL60z0oEx3fz-JKNwxPY
>
> No repository found containing:
> binary,org.eclipse.rcp.configuration_root.win32.win32.x86,1. 0.0.I20100608-0911
>
> No repository found containing:
> org.eclipse.update.feature,org.eclipse.rcp,3.6.0.v20100519-9 OArFKvFtsd7WLUKh-DcYTS
>
> No repository found containing:
> binary,org.eclipse.rcp_root,3.6.0.v20100519-9OArFKvFtsd7WLUK h-DcYTS
>
> I simply used the "Check for Updates" action. The update manager said
> that I needed to update my "Eclipse for RCP and RAP developers", but it
> gave me the above error when I attempted the update. I have
> http://download.eclipse.org/releases/helios and
> http://download.eclipse.org/updates/3.6 as available software sites.
>
> This is my build info:
>
> eclipse.buildId=I20100603-1500
> java.version=1.6.0_20
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
> Framework arguments: -product org.eclipse.epp.package.rcp.product
> -product org.eclipse.epp.package.rcp.product
> Command-line arguments: -os win32 -ws win32 -arch x86 -product
> org.eclipse.epp.package.rcp.product
>
> Anyone else having this problem? I know that helios just went live, so I
> may just need to wait for the update sites to start working.
>
> I've been told that it is possible to use another Eclipse install as an
> update site as well. Is that true?
>
> Del
Previous Topic:Dynamically expanding sub-menu on right click
Next Topic:Resource editor opened event?
Goto Forum:
  


Current Time: Thu Apr 24 01:23:40 EDT 2014

Powered by FUDForum. Page generated in 0.02083 seconds