Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse Helios Hanging(Helios hangs for no apparent reason)
Eclipse Helios Hanging [message #542100] Wed, 23 June 2010 16:51 Go to next message
Ivan Rei is currently offline Ivan Rei
Messages: 2
Registered: July 2009
Junior Member
Can someone please help me, I've been struggling with this problem for ages.

The only Helios i can use is eclipse-SDK-3.6M4-win32, from eclipse-SDK-3.6M5-win32 to eclipse-SDK-3.6-win32, eclipse is unusable. When I open eclipse it hangs for ages, all the projects in the Package Explorer view show up without the CVS Server label. After quite a few minutes the CVS labels start showing up. The server view does the same thing, after quite a few minutes the [Stopped, Republish] shows up. In the eclipse-SDK-3.6M4-win32, they show up right after I open eclipse.

This all happens with the CPU at 100%. I then try to do an action like publish the server and it comes up as waiting, but in the process view there is nothing running. I eventually give up and go back to eclipse-SDK-3.6M4-win32.

I also downloaded the eclipse-jee-helios-win32.zip SR, but to no avail. Same problem persists. I then decided to create a new workspace to see if that is the problem, but the same thing happens after I import the projects and create the servers.

I have 47 projects in the workspace and 12 servers (In the new workspace created I have only 2) created. I'm using JDK1.6.0_20 and Tomcat 6.0.26 on a Windows 7 machine.

Please HELP!!!!
Re: Eclipse Helios Hanging [message #542185 is a reply to message #542100] Thu, 24 June 2010 03:59 Go to previous messageGo to next message
Mariot Chauvin is currently offline Mariot Chauvin
Messages: 174
Registered: July 2009
Senior Member
Ivan Rei a écrit :
> Can someone please help me, I've been struggling with this problem for
> ages.
> The only Helios i can use is eclipse-SDK-3.6M4-win32, from
> eclipse-SDK-3.6M5-win32 to eclipse-SDK-3.6-win32, eclipse is unusable.
> When I open eclipse it hangs for ages, all the projects in the Package
> Explorer view show up without the CVS Server label. After quite a few
> minutes the CVS labels start showing up. The server view does the same
> thing, after quite a few minutes the [Stopped, Republish] shows up. In
> the eclipse-SDK-3.6M4-win32, they show up right after I open eclipse.
>
> This all happens with the CPU at 100%. I then try to do an action like
> publish the server and it comes up as waiting, but in the process view
> there is nothing running. I eventually give up and go back to
> eclipse-SDK-3.6M4-win32.
>
> I also downloaded the eclipse-jee-helios-win32.zip SR, but to no avail.
> Same problem persists. I then decided to create a new workspace to see
> if that is the problem, but the same thing happens after I import the
> projects and create the servers.
>
> I have 47 projects in the workspace and 12 servers (In the new workspace
> created I have only 2) created. I'm using JDK1.6.0_20 and Tomcat 6.0.26
> on a Windows 7 machine.
>
> Please HELP!!!!

I think you should open a bug with steps to reproduce and information you provide here.

Regards,

Mariot
Re: Eclipse Helios Hanging [message #542364 is a reply to message #542185] Thu, 24 June 2010 11:22 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew Niefer
Messages: 990
Registered: July 2009
Senior Member
A stack trace would be useful
http://wiki.eclipse.org/How_to_report_a_deadlock

-Andrew
Mariot Chauvin wrote:

> Ivan Rei a écrit :
>> Can someone please help me, I've been struggling with this problem for
>> ages.
>> The only Helios i can use is eclipse-SDK-3.6M4-win32, from
>> eclipse-SDK-3.6M5-win32 to eclipse-SDK-3.6-win32, eclipse is unusable.
>> When I open eclipse it hangs for ages, all the projects in the Package
>> Explorer view show up without the CVS Server label. After quite a few
>> minutes the CVS labels start showing up. The server view does the same
>> thing, after quite a few minutes the [Stopped, Republish] shows up. In
>> the eclipse-SDK-3.6M4-win32, they show up right after I open eclipse.
>>
>> This all happens with the CPU at 100%. I then try to do an action like
>> publish the server and it comes up as waiting, but in the process view
>> there is nothing running. I eventually give up and go back to
>> eclipse-SDK-3.6M4-win32.
>>
>> I also downloaded the eclipse-jee-helios-win32.zip SR, but to no avail.
>> Same problem persists. I then decided to create a new workspace to see
>> if that is the problem, but the same thing happens after I import the
>> projects and create the servers.
>>
>> I have 47 projects in the workspace and 12 servers (In the new workspace
>> created I have only 2) created. I'm using JDK1.6.0_20 and Tomcat 6.0.26
>> on a Windows 7 machine.
>>
>> Please HELP!!!!
>
> I think you should open a bug with steps to reproduce and information you
> provide here.
>
> Regards,
>
> Mariot
Re: Eclipse Helios Hanging [message #542398 is a reply to message #542100] Thu, 24 June 2010 13:18 Go to previous message
Ivan Rei is currently offline Ivan Rei
Messages: 2
Registered: July 2009
Junior Member
I've created a bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=317830. The Thread Dumps are attached. I did a dump every minute or so till eclipse got stuck in "waiting"
Previous Topic:p2 Help
Next Topic:How to programmatically activate a command's handler?
Goto Forum:
  


Current Time: Sun Apr 20 09:43:12 EDT 2014

Powered by FUDForum. Page generated in 0.07553 seconds