Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] problem with am3 and using ant(run atl transformation using ant)
[ATL] problem with am3 and using ant [message #542088] Wed, 23 June 2010 19:58 Go to next message
Júlio is currently offline JúlioFriend
Messages: 8
Registered: June 2010
Junior Member
hello
I'm new on atl. I'm trying to run the UML2OWL example

I'm using ecplise 3.4 e ATL 3.1.


When executing the build.xml I got the error:


H:\Master\Desenvolvimento\Projetos\OC2OWL\build.xml:35: Problem: failed to create task or type am3.loadModel
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken place.

I think it is because of am3

I've been trying to install am3 using ( http://wiki.eclipse.org/index.php?title=AM3/How_Install_New_ AM3_From_SVN) instructions but I didn't understand how Launching AM3 and make it run. I just have download it from the SVN

However how to make it run?

Doing that I think I can try to run the build.xml again.

Could you please help me in how to make it happen.

Regards
Júlio
Re: [ATL] problem with am3 and using ant [message #542674 is a reply to message #542088] Fri, 25 June 2010 15:20 Go to previous message
wafaa is currently offline wafaaFriend
Messages: 163
Registered: January 2010
Location: Egypt
Senior Member
hi

i have been facing similar problem and many told me that he am3 current version is deprecated and some gave me a full version of eclipse with suitable am3

I will try to give you the link for the thread

http://www.eclipse.org/forums/index.php?t=msg&goto=53013 3&#msg_530133

u can find the link in the first reply for Sylvain EVEILLARD whom I repeat my thanks a lot!!
Previous Topic:[QVT-R] Suggestions for QVT-Relations plug-in
Next Topic:Does ecore only supports .xmi models?
Goto Forum:
  


Current Time: Thu Nov 27 04:28:32 GMT 2014

Powered by FUDForum. Page generated in 0.01893 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software