Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Missing imported package (Eclipse 3.6RC4 Milestone)
Missing imported package [message #541405] Mon, 21 June 2010 01:40 Go to next message
celeraman + is currently offline celeraman +Friend
Messages: 4
Registered: July 2009
Junior Member
When export a RCP product I get the following error:

osgi> diag 161
reference:file:plugins/org.eclipse.swt_3.6.0.v3650b.jar [161]
  Direct constraints which are unresolved:
    Missing dynamically imported package org.eclipse.swt.accessibility2_0.0.0.
    Missing dynamically imported package org.mozilla.xpcom_0.0.0.


I'm running under Eclipse 3.6RC4 target platform and JavaSE-1.6.

There aren't error running the application inside the IDE. And no errors validating the product before export it too.

Any help are welcome! Thanks!

Re: Missing imported package [message #541800 is a reply to message #541405] Tue, 22 June 2010 14:44 Go to previous messageGo to next message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
Hi,

These are both dynamic plug-in imports, meaning that they are not required
to be there (but if they are then swt's functionality is extended
accordingly). The absence of these plug-ins should not cause the loading of
swt to fail in any context. Is this actually failing for you, or is it
working and you're just looking at osgi's logged info? If it's causing your
swt load to fail then it seems like a problem either in osgi or in the
export of your rcp app, because the attempted importing of these two
plug-ins should never cause a failure.

Grant


"celeraman" <dany.eudes@gmail.com> wrote in message
news:hvmfui$h14$1@build.eclipse.org...
> When export a RCP product I get the following error:
>
>
> osgi> diag 161
> reference:file:plugins/org.eclipse.swt_3.6.0.v3650b.jar [161]
> Direct constraints which are unresolved:
> Missing dynamically imported package
org.eclipse.swt.accessibility2_0.0.0.
> Missing dynamically imported package org.mozilla.xpcom_0.0.0.
>
>
> I'm running under Eclipse 3.6RC4 target platform and JavaSE-1.6.
>
> There aren't error running the application inside the IDE. And no errors
validating the product before export it too.
>
> Any help are welcome! Thanks!
>
>
Re: Missing imported package [message #541891 is a reply to message #541800] Wed, 23 June 2010 01:25 Go to previous message
celeraman + is currently offline celeraman +Friend
Messages: 4
Registered: July 2009
Junior Member
@Grant,
thank you for your reply.

I dropped out these following plugins from my EclipseLink feature and Equinox P2 feature and the error was gone:

org.eclipse.persistence.dbws_2.1.0.v20100614-r7608

org.eclipse.equinox.p2.ui.sdk_1.0.100.v20100513

I cannot figure out why. Shocked
I will continue to investigate that.
Previous Topic:Galileo Internal Web Browser
Next Topic:Backgorund mdoe inherit doesn't work with windoes theme classic
Goto Forum:
  


Current Time: Thu Nov 27 11:02:38 GMT 2014

Powered by FUDForum. Page generated in 0.01741 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software